summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-04-27 07:13:18 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-04-27 07:13:18 +0000
commit40b50ba2012727232ca4346a61bb477dd0647289 (patch)
tree65d61ad75ed1f7f0f934cb64e73392cbb683f980 /net-libs/libicq2000/libicq2000-0.3.1.ebuild
parentupdate to a version that doesn't mangle P (diff)
downloadgentoo-2-40b50ba2012727232ca4346a61bb477dd0647289.tar.gz
gentoo-2-40b50ba2012727232ca4346a61bb477dd0647289.tar.bz2
gentoo-2-40b50ba2012727232ca4346a61bb477dd0647289.zip
blazing hot and new version
Diffstat (limited to 'net-libs/libicq2000/libicq2000-0.3.1.ebuild')
-rw-r--r--net-libs/libicq2000/libicq2000-0.3.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-libs/libicq2000/libicq2000-0.3.1.ebuild b/net-libs/libicq2000/libicq2000-0.3.1.ebuild
new file mode 100644
index 000000000000..b05a902c8652
--- /dev/null
+++ b/net-libs/libicq2000/libicq2000-0.3.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author: Spider <spider@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libicq2000/libicq2000-0.3.1.ebuild,v 1.1 2002/04/27 07:13:18 spider Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="ICQ 200x compatible ICQ libraries."
+SRC_URI="http://prdownloads.sourceforge.net/libicq2000/${P}.tar.gz"
+HOMEPAGE="http://ickle.sf.net"
+SLOT="0"
+
+
+DEPEND=">=dev-libs/libsigc++-1.0.4"
+
+src_compile() {
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --localstatedir=/var/lib \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS TODO
+}