summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2008-02-12 00:04:03 +0000
committerAndrej Kacian <ticho@gentoo.org>2008-02-12 00:04:03 +0000
commit5ef98636949c67a0df036646f080f5c652a20765 (patch)
tree4afc113263a47fb2a46e5ab737fcafce2e26318d /net-libs/libetpan
parentwhitespace (diff)
downloadgentoo-2-5ef98636949c67a0df036646f080f5c652a20765.tar.gz
gentoo-2-5ef98636949c67a0df036646f080f5c652a20765.tar.bz2
gentoo-2-5ef98636949c67a0df036646f080f5c652a20765.zip
Version bump.
(Portage version: 2.1.4.3)
Diffstat (limited to 'net-libs/libetpan')
-rw-r--r--net-libs/libetpan/ChangeLog9
-rw-r--r--net-libs/libetpan/libetpan-0.53.ebuild62
2 files changed, 69 insertions, 2 deletions
diff --git a/net-libs/libetpan/ChangeLog b/net-libs/libetpan/ChangeLog
index 71cc194f1def..3cf543699f44 100644
--- a/net-libs/libetpan/ChangeLog
+++ b/net-libs/libetpan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libetpan
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/ChangeLog,v 1.57 2007/11/29 09:47:37 jokey Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/ChangeLog,v 1.58 2008/02/12 00:04:03 ticho Exp $
+
+*libetpan-0.53 (11 Feb 2008)
+
+ 11 Feb 2008; Andrej Kacian <ticho@gentoo.org> +libetpan-0.53.ebuild:
+ Version bump.
29 Nov 2007; Markus Ullmann <jokey@gentoo.org> libetpan-0.49.ebuild,
libetpan-0.52.ebuild, libetpan-0.52-r1.ebuild:
diff --git a/net-libs/libetpan/libetpan-0.53.ebuild b/net-libs/libetpan/libetpan-0.53.ebuild
new file mode 100644
index 000000000000..74539fd32a34
--- /dev/null
+++ b/net-libs/libetpan/libetpan-0.53.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/libetpan-0.53.ebuild,v 1.1 2008/02/12 00:04:03 ticho Exp $
+
+DESCRIPTION="A portable, efficient middleware for different kinds of mail access."
+HOMEPAGE="http://libetpan.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="berkdb debug gnutls ipv6 liblockfile sasl ssl"
+
+DEPEND="virtual/libc
+ berkdb? ( sys-libs/db )
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( ssl? ( dev-libs/openssl ) )
+ sasl? ( dev-libs/cyrus-sasl )
+ liblockfile? ( net-libs/liblockfile )"
+
+src_compile() {
+ local sslconf
+
+ if use ssl; then
+ if use gnutls; then
+ sslconf="--with-gnutls --without-openssl"
+ else
+ sslconf="--without-gnutls --with-openssl"
+ fi
+ else
+ if use gnutls; then
+ sslconf="--with-gnutls --without-openssl"
+ else
+ sslconf="--without-gnutls --without-openssl"
+ fi
+ fi
+
+ econf \
+ $(use_enable debug) \
+ $(use_enable berkdb db) \
+ $(use_with sasl) \
+ $(use_enable ipv6) \
+ $(use_enable liblockfile lockfile) \
+ ${sslconf} \
+ || die "econf failed"
+
+ # build system is broken, we need -j1 (bug #126848) - Ticho, 2006-05-02
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc NEWS ChangeLog
+}
+
+pkg_postinst() {
+ echo
+ ewarn "The soname for libetpan has changed after libetpan-0.48."
+ ewarn "If you have upgraded from that or earlier version, it is recommended to run"
+ ewarn "revdep-rebuild to fix any linking errors caused by this change."
+ echo
+}