summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2008-10-16 18:16:56 +0000
committerChristian Faulhammer <opfer@gentoo.org>2008-10-16 18:16:56 +0000
commit5a821426ba57c2d457d3c1437c0e9bb5f7e6aca0 (patch)
tree2b0c9d3ca1bc9682ed6f5de48f0e601e6072cd6d /net-libs/libetpan
parentppc stable, bug #232831 (diff)
downloadgentoo-2-5a821426ba57c2d457d3c1437c0e9bb5f7e6aca0.tar.gz
gentoo-2-5a821426ba57c2d457d3c1437c0e9bb5f7e6aca0.tar.bz2
gentoo-2-5a821426ba57c2d457d3c1437c0e9bb5f7e6aca0.zip
version bump for bug 236178
(Portage version: 2.1.4.5)
Diffstat (limited to 'net-libs/libetpan')
-rw-r--r--net-libs/libetpan/ChangeLog8
-rw-r--r--net-libs/libetpan/libetpan-0.57.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/net-libs/libetpan/ChangeLog b/net-libs/libetpan/ChangeLog
index 57327e91be5b..81865d004ef8 100644
--- a/net-libs/libetpan/ChangeLog
+++ b/net-libs/libetpan/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libetpan
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/ChangeLog,v 1.70 2008/09/07 16:50:35 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/ChangeLog,v 1.71 2008/10/16 18:16:56 opfer Exp $
+
+*libetpan-0.57 (16 Oct 2008)
+
+ 16 Oct 2008; Christian Faulhammer <opfer@gentoo.org>
+ +libetpan-0.57.ebuild:
+ version bump for bug 236178
*libetpan-0.56 (07 Sep 2008)
diff --git a/net-libs/libetpan/libetpan-0.57.ebuild b/net-libs/libetpan/libetpan-0.57.ebuild
new file mode 100644
index 000000000000..8b7ab4e9ac12
--- /dev/null
+++ b/net-libs/libetpan/libetpan-0.57.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/libetpan-0.57.ebuild,v 1.1 2008/10/16 18:16:56 opfer Exp $
+
+DESCRIPTION="A portable, efficient middleware for different kinds of mail access."
+HOMEPAGE="http://libetpan.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="berkdb debug gnutls ipv6 liblockfile sasl ssl"
+
+DEPEND="virtual/libc
+ berkdb? ( sys-libs/db )
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( ssl? ( dev-libs/openssl ) )
+ sasl? ( dev-libs/cyrus-sasl )
+ liblockfile? ( net-libs/liblockfile )"
+
+src_compile() {
+ local sslconf
+
+ if use ssl; then
+ if use gnutls; then
+ sslconf="--with-gnutls --without-openssl"
+ else
+ sslconf="--without-gnutls --with-openssl"
+ fi
+ else
+ if use gnutls; then
+ sslconf="--with-gnutls --without-openssl"
+ else
+ sslconf="--without-gnutls --without-openssl"
+ fi
+ fi
+
+ econf \
+ $(use_enable debug) \
+ $(use_enable berkdb db) \
+ $(use_with sasl) \
+ $(use_enable ipv6) \
+ $(use_enable liblockfile lockfile) \
+ ${sslconf} \
+ || die "econf failed"
+
+ # build system is broken, we need -j1 (bug #126848) - Ticho, 2006-05-02
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc NEWS ChangeLog
+}
+
+pkg_postinst() {
+ echo
+ ewarn "The soname for libetpan has changed after libetpan-0.53."
+ ewarn "If you have upgraded from that or earlier version, it is recommended to run"
+ ewarn "revdep-rebuild to fix any linking errors caused by this change."
+ echo
+}