summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-11-10 15:28:48 +0000
committerMarinus Schraal <foser@gentoo.org>2003-11-10 15:28:48 +0000
commit4d8aee3fa491c566a73ccfbf075819b1342fdd69 (patch)
tree5432b298268267fd1473d50c0b1c6f69914c40e3 /net-libs/libesmtp/libesmtp-1.0.1.ebuild
parentNew release, mark 1.0 x86 (diff)
downloadgentoo-2-4d8aee3fa491c566a73ccfbf075819b1342fdd69.tar.gz
gentoo-2-4d8aee3fa491c566a73ccfbf075819b1342fdd69.tar.bz2
gentoo-2-4d8aee3fa491c566a73ccfbf075819b1342fdd69.zip
New release, mark 1.0 x86
Diffstat (limited to 'net-libs/libesmtp/libesmtp-1.0.1.ebuild')
-rw-r--r--net-libs/libesmtp/libesmtp-1.0.1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-libs/libesmtp/libesmtp-1.0.1.ebuild b/net-libs/libesmtp/libesmtp-1.0.1.ebuild
new file mode 100644
index 000000000000..005a3a6b26c0
--- /dev/null
+++ b/net-libs/libesmtp/libesmtp-1.0.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libesmtp/libesmtp-1.0.1.ebuild,v 1.1 2003/11/10 15:28:42 foser Exp $
+
+inherit gcc eutils gnuconfig libtool
+
+DESCRIPTION="libESMTP is a library that implements the client side of the SMTP protocol"
+SRC_URI="http://www.stafford.uklinux.net/libesmtp/${P}.tar.bz2"
+HOMEPAGE="http://www.stafford.uklinux.net/libesmtp/"
+LICENSE="LGPL-2.1 GPL-2"
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-1.4.1
+ >=sys-apps/sed-4"
+
+IUSE="ssl"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha"
+
+src_compile() {
+ gnuconfig_update
+
+ elibtoolize
+
+ local myconf
+
+ use ssl || myconf="${myconf} --without-openssl"
+
+ if [ "`gcc-major-version`" -eq "2" ]; then
+ myconf="${myconf} --disable-isoc"
+ fi
+
+ ./configure \
+ --prefix=/usr \
+ --enable-all \
+ --enable-threads \
+ ${myconf} || die "configure failed"
+
+ if [ "`gcc-major-version`" -eq "3" ] && [ "`gcc-minor-version`" -ge "3" ]; then
+ sed -i "s:-Wsign-promo::g" Makefile
+ fi
+
+ emake || die "emake failed"
+}
+
+src_install () {
+
+ make prefix=${D}/usr install || die "make install failed"
+ dodoc AUTHORS COPYING COPYING.GPL INSTALL ChangeLog NEWS Notes README TODO
+ dohtml doc/api.xml
+
+}
+