summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-08-07 09:39:00 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-08-07 09:39:00 +0000
commit695e88f0db2467b85e4bf9a989a3149172a7a11d (patch)
treecbbc4b805b7e6f64b9b6f7813579404dda625637 /net-libs/libasyncns
parentAdd sci-libs as converted category, GLEP 56. sci-* done. (diff)
downloadgentoo-2-695e88f0db2467b85e4bf9a989a3149172a7a11d.tar.gz
gentoo-2-695e88f0db2467b85e4bf9a989a3149172a7a11d.tar.bz2
gentoo-2-695e88f0db2467b85e4bf9a989a3149172a7a11d.zip
Version bump, thanks to Damien Thébault in bug #233912 for reporting. Fixed the typo reported, removed the eautoreconf (Makefile fixed upstream), added flag-o-matic inherit as needed for append-flags, corrected license.
(Portage version: 2.2_rc6/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'net-libs/libasyncns')
-rw-r--r--net-libs/libasyncns/ChangeLog10
-rw-r--r--net-libs/libasyncns/libasyncns-0.4.ebuild52
2 files changed, 61 insertions, 1 deletions
diff --git a/net-libs/libasyncns/ChangeLog b/net-libs/libasyncns/ChangeLog
index 7ce388831cc3..1cb31d58e36d 100644
--- a/net-libs/libasyncns/ChangeLog
+++ b/net-libs/libasyncns/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-libs/libasyncns
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libasyncns/ChangeLog,v 1.10 2008/01/26 21:30:03 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libasyncns/ChangeLog,v 1.11 2008/08/07 09:39:00 flameeyes Exp $
+
+*libasyncns-0.4 (07 Aug 2008)
+
+ 07 Aug 2008; Diego Pettenò <flameeyes@gentoo.org> +libasyncns-0.4.ebuild:
+ Version bump, thanks to Damien Thébault in bug #233912 for reporting.
+ Fixed the typo reported, removed the eautoreconf (Makefile fixed
+ upstream), added flag-o-matic inherit as needed for append-flags,
+ corrected license.
26 Jan 2008; Tobias Scherbaum <dertobi123@gentoo.org>
libasyncns-0.3.ebuild:
diff --git a/net-libs/libasyncns/libasyncns-0.4.ebuild b/net-libs/libasyncns/libasyncns-0.4.ebuild
new file mode 100644
index 000000000000..12221858c766
--- /dev/null
+++ b/net-libs/libasyncns/libasyncns-0.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libasyncns/libasyncns-0.4.ebuild,v 1.1 2008/08/07 09:39:00 flameeyes Exp $
+
+inherit libtool flag-o-matic
+
+DESCRIPTION="C library for executing name service queries asynchronously."
+HOMEPAGE="http://0pointer.de/lennart/projects/libasyncns/"
+SRC_URI="http://0pointer.de/lennart/projects/libasyncns/${P}.tar.gz"
+
+SLOT="0"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="doc debug"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+
+ elibtoolize
+}
+
+src_compile() {
+ # libasyncns uses assert()
+ use debug || append-flags -DNDEBUG
+
+ econf \
+ --disable-dependency-tracking \
+ --disable-lynx \
+ || die "econf failed"
+ emake || die "emake failed"
+
+ if use doc; then
+ doxygen doxygen/doxygen.conf || die "doxygen failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc doc/README
+ dohtml doc/README.html doc/style.css
+
+ if use doc; then
+ docinto apidocs
+ dohtml html/*
+ fi
+}