summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-05-04 11:50:56 +0000
committerJustin Lecher <jlec@gentoo.org>2013-05-04 11:50:56 +0000
commitea1f1b2ab8205e6888edb7e70b594eba68768b0c (patch)
treef2cc23f9d44a2578da9b98cbc0bbe227938fbaa2 /net-libs/gupnp-igd
parentAdd comment for ncurses[tinfo] fix (diff)
downloadgentoo-2-ea1f1b2ab8205e6888edb7e70b594eba68768b0c.tar.gz
gentoo-2-ea1f1b2ab8205e6888edb7e70b594eba68768b0c.tar.bz2
gentoo-2-ea1f1b2ab8205e6888edb7e70b594eba68768b0c.zip
net-libs/gupnp-igd: Add fix for underlinking, fix obsolete macros in automake-1.13, #467888, fix python handling, #450392
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'net-libs/gupnp-igd')
-rw-r--r--net-libs/gupnp-igd/ChangeLog11
-rw-r--r--net-libs/gupnp-igd/files/gupnp-igd-0.2.2-underlinking.patch16
-rw-r--r--net-libs/gupnp-igd/gupnp-igd-0.2.2-r1.ebuild93
-rw-r--r--net-libs/gupnp-igd/metadata.xml8
4 files changed, 122 insertions, 6 deletions
diff --git a/net-libs/gupnp-igd/ChangeLog b/net-libs/gupnp-igd/ChangeLog
index fa108731124e..bdfa2736ed4b 100644
--- a/net-libs/gupnp-igd/ChangeLog
+++ b/net-libs/gupnp-igd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/gupnp-igd
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-igd/ChangeLog,v 1.43 2012/12/01 17:59:08 armin76 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-igd/ChangeLog,v 1.44 2013/05/04 11:50:56 jlec Exp $
+
+*gupnp-igd-0.2.2-r1 (04 May 2013)
+
+ 04 May 2013; Justin Lecher <jlec@gentoo.org> +gupnp-igd-0.2.2-r1.ebuild,
+ +files/gupnp-igd-0.2.2-underlinking.patch, metadata.xml:
+ Add fix for underlinking, fix obsolete macros in automake-1.13, #467888, fix
+ python handling, #450392
01 Dec 2012; Raúl Porcel <armin76@gentoo.org> gupnp-igd-0.2.1.ebuild:
alpha/ia64/sparc stable wrt #434300
diff --git a/net-libs/gupnp-igd/files/gupnp-igd-0.2.2-underlinking.patch b/net-libs/gupnp-igd/files/gupnp-igd-0.2.2-underlinking.patch
new file mode 100644
index 000000000000..0e1dfb48a388
--- /dev/null
+++ b/net-libs/gupnp-igd/files/gupnp-igd-0.2.2-underlinking.patch
@@ -0,0 +1,16 @@
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index c4f7d47..f13b398 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -10,7 +10,7 @@ AC_STDC_HEADERS
+ AC_PROG_LIBTOOL
+ AC_FUNC_MMAP
+
+-PKG_CHECK_MODULES(LIBGUPNP, gobject-2.0 >= 2.14 gupnp-1.0 >= 0.18 gthread-2.0)
++PKG_CHECK_MODULES(LIBGUPNP, gobject-2.0 >= 2.14 gupnp-1.0 >= 0.18 gthread-2.0 gssdp-1.0)
+
+ # glib-genmarshal
+ GLIB_GENMARSHAL=`pkg-config --variable=glib_genmarshal glib-2.0`
diff --git a/net-libs/gupnp-igd/gupnp-igd-0.2.2-r1.ebuild b/net-libs/gupnp-igd/gupnp-igd-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..40654be4f2ed
--- /dev/null
+++ b/net-libs/gupnp-igd/gupnp-igd-0.2.2-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-igd/gupnp-igd-0.2.2-r1.ebuild,v 1.1 2013/05/04 11:50:56 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils gnome.org python-r1
+
+DESCRIPTION="Library to handle UPnP IGD port mapping for GUPnP"
+HOMEPAGE="http://gupnp.org"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection python"
+
+RDEPEND="
+ net-libs/gssdp
+ >=net-libs/gupnp-0.18
+ >=dev-libs/glib-2.16:2
+ introspection? ( >=dev-libs/gobject-introspection-0.10 )
+ python? (
+ >=dev-libs/gobject-introspection-0.10[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-2.16:2[${PYTHON_USEDEP}]
+ )"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+# The only existing test is broken
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-underlinking.patch
+ "${FILESDIR}"/${PN}-0.1.11-disable_static_modules.patch
+ )
+
+src_prepare() {
+ rm missing || die
+ sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.ac || die
+
+ # Python bindings are built/installed manually.
+ if use python; then
+ sed -e "/PYTHON_SUBDIR =/s/ python//" -i Makefile.am Makefile.in || die
+ fi
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ --disable-gtk-doc
+ $(use_enable introspection)
+ $(use_enable python)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+
+ if use python; then
+ python_copy_sources
+
+ building() {
+ cd "${BUILD_DIR}"/python || die
+ emake \
+ PYTHON_INCLUDES="-I$(python_get_includedir)" \
+ pyexecdir="$(python_get_sitedir)"
+ }
+ python_foreach_impl building
+ fi
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use python; then
+ installation() {
+ cd "${BUILD_DIR}"/python || die
+ emake \
+ DESTDIR="${D}" \
+ pyexecdir="$(python_get_sitedir)" \
+ install
+ }
+ python_foreach_impl installation
+ fi
+}
diff --git a/net-libs/gupnp-igd/metadata.xml b/net-libs/gupnp-igd/metadata.xml
index bcf095d10035..9198b0537de5 100644
--- a/net-libs/gupnp-igd/metadata.xml
+++ b/net-libs/gupnp-igd/metadata.xml
@@ -1,9 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>net-p2p</herd>
- <use>
- <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg> for
+ <herd>net-p2p</herd>
+ <use>
+ <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg> for
introspection</flag>
- </use>
+ </use>
</pkgmetadata>