summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-08-24 17:43:27 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2012-08-24 17:43:27 +0000
commit11adb174dd3a005db93827e030271bff99967ef4 (patch)
tree9bcf12def417b6951ef7968cda8e73b46b938bfc /net-libs/gupnp-av/gupnp-av-0.10.3.ebuild
parentFix build with USE=ssl. (diff)
downloadgentoo-2-11adb174dd3a005db93827e030271bff99967ef4.tar.gz
gentoo-2-11adb174dd3a005db93827e030271bff99967ef4.tar.bz2
gentoo-2-11adb174dd3a005db93827e030271bff99967ef4.zip
Version bump. Drop old revision. Add gnome to metadata.xml.
(Portage version: 2.2.0_alpha122/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/gupnp-av/gupnp-av-0.10.3.ebuild')
-rw-r--r--net-libs/gupnp-av/gupnp-av-0.10.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-libs/gupnp-av/gupnp-av-0.10.3.ebuild b/net-libs/gupnp-av/gupnp-av-0.10.3.ebuild
new file mode 100644
index 000000000000..60ba1d2a9dbe
--- /dev/null
+++ b/net-libs/gupnp-av/gupnp-av-0.10.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-av/gupnp-av-0.10.3.ebuild,v 1.1 2012/08/24 17:43:27 eva Exp $
+
+EAPI="4"
+
+inherit gnome.org
+
+DESCRIPTION="A small utility library that aims to ease the handling UPnP A/V profiles"
+HOMEPAGE="http://gupnp.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+introspection"
+
+RDEPEND=">=dev-libs/glib-2.16:2
+ >=net-libs/gssdp-0.9.2[introspection?]
+ >=net-libs/libsoup-2.28.2:2.4[introspection?]
+ >=net-libs/gupnp-0.17[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_configure() {
+ econf \
+ $(use_enable introspection) \
+ --disable-dependency-tracking \
+ --disable-static \
+ --disable-gtk-doc
+}
+
+src_install() {
+ default
+ # Remove pointless .la files
+ find "${D}" -name '*.la' -delete
+}