summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-05-15 07:14:17 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-05-15 07:14:17 +0000
commiteb82018177e0aa05f35121a67f907a204b38a645 (patch)
treefba3de8e2d2303d316c183288bbbda26d76354f6 /net-libs/gsoap
parentAdd icon (thanks Samuel BAUER, bug 469608), python-single-r1 eclass. (diff)
downloadgentoo-2-eb82018177e0aa05f35121a67f907a204b38a645.tar.gz
gentoo-2-eb82018177e0aa05f35121a67f907a204b38a645.tar.bz2
gentoo-2-eb82018177e0aa05f35121a67f907a204b38a645.zip
Bump
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-libs/gsoap')
-rw-r--r--net-libs/gsoap/ChangeLog7
-rw-r--r--net-libs/gsoap/gsoap-2.8.15.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/net-libs/gsoap/ChangeLog b/net-libs/gsoap/ChangeLog
index 4a82053b17b5..dd04dcc4b5ad 100644
--- a/net-libs/gsoap/ChangeLog
+++ b/net-libs/gsoap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/gsoap
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/ChangeLog,v 1.25 2013/05/10 05:37:09 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/ChangeLog,v 1.26 2013/05/15 07:14:17 patrick Exp $
+
+*gsoap-2.8.15 (15 May 2013)
+
+ 15 May 2013; Patrick Lauer <patrick@gentoo.org> +gsoap-2.8.15.ebuild:
+ Bump
10 May 2013; Lars Wendler <polynomial-c@gentoo.org> -gsoap-2.8.9.ebuild,
-gsoap-2.8.10.ebuild, -gsoap-2.8.11.ebuild, -gsoap-2.8.12.ebuild,
diff --git a/net-libs/gsoap/gsoap-2.8.15.ebuild b/net-libs/gsoap/gsoap-2.8.15.ebuild
new file mode 100644
index 000000000000..86a285b88280
--- /dev/null
+++ b/net-libs/gsoap/gsoap-2.8.15.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/gsoap-2.8.15.ebuild,v 1.1 2013/05/15 07:14:17 patrick Exp $
+
+EAPI=4
+
+inherit autotools eutils
+
+MY_P="${PN}-2.8"
+
+DESCRIPTION="A cross-platform open source C and C++ SDK to ease the development of SOAP/XML Web services"
+HOMEPAGE="http://gsoap2.sourceforge.net"
+SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.zip"
+
+LICENSE="GPL-2 gSOAP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug examples ipv6 gnutls +ssl"
+
+DEPEND="app-arch/unzip
+ sys-devel/flex
+ sys-devel/bison
+ sys-libs/zlib
+ gnutls? ( net-libs/gnutls )
+ ssl? ( dev-libs/openssl )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Fix Pre-ISO headers
+ epatch "${FILESDIR}/${PN}-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch"
+
+ # Fix configure.in for >=automake-1.13
+ sed 's@AM_CONFIG_HEADER@AC_CONFIG_HEADERS@' -i configure.in || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=
+ use ssl || myconf+="--disable-ssl "
+ use gnutls && myconf+="--enable-gnutls "
+ use ipv6 && myconf+="--enable-ipv6 "
+ econf \
+ ${myconf} \
+ $(use_enable debug) \
+ $(use_enable examples samples)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # yes, we also install the license-file since
+ # it contains info about how to apply the licenses
+ dodoc *.txt
+
+ dohtml changelog.html
+
+ find "${D}"/usr/ -name "*.la" -exec rm {} \;
+
+ if use examples; then
+ rm -rf gsoap/samples/Makefile* gsoap/samples/*/Makefile* gsoap/samples/*/*.o
+ insinto /usr/share/doc/${PF}/examples
+ doins -r gsoap/samples/*
+ fi
+
+ if use doc; then
+ dohtml -r gsoap/doc/*
+ fi
+}