summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2012-10-19 19:28:47 +0000
committerDane Smith <c1pher@gentoo.org>2012-10-19 19:28:47 +0000
commitf19b55ed7bc7689a5c04f61b5957188107dadb0d (patch)
tree6a6d9a372ec2e0c7b2604a5bc0d5b47bd3c68ad7 /net-libs/gnutls
parentAdd ~amd64, wrt to bug #438836 (diff)
downloadgentoo-2-f19b55ed7bc7689a5c04f61b5957188107dadb0d.tar.gz
gentoo-2-f19b55ed7bc7689a5c04f61b5957188107dadb0d.tar.bz2
gentoo-2-f19b55ed7bc7689a5c04f61b5957188107dadb0d.zip
Add patches to fix parallel make issues in bug 427844 and bug 437256.
Update ebuilds for 2.12.20 and 3.1.3 to make use of said patches. Drop old. (Portage version: 2.2.0_alpha140/cvs/Linux x86_64, signed Manifest commit with key E27104B3)
Diffstat (limited to 'net-libs/gnutls')
-rw-r--r--net-libs/gnutls/ChangeLog9
-rw-r--r--net-libs/gnutls/files/gnutls-2.12.20-guile-parallelmake.patch9
-rw-r--r--net-libs/gnutls/files/gnutls-3.1.3-guile-parallelmake.patch9
-rw-r--r--net-libs/gnutls/gnutls-2.12.18.ebuild129
-rw-r--r--net-libs/gnutls/gnutls-2.12.20.ebuild3
-rw-r--r--net-libs/gnutls/gnutls-3.1.3.ebuild4
6 files changed, 31 insertions, 132 deletions
diff --git a/net-libs/gnutls/ChangeLog b/net-libs/gnutls/ChangeLog
index 89d75c31f46c..9b3859d2eee6 100644
--- a/net-libs/gnutls/ChangeLog
+++ b/net-libs/gnutls/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/gnutls
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/ChangeLog,v 1.386 2012/10/13 19:07:34 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/ChangeLog,v 1.387 2012/10/19 19:28:47 c1pher Exp $
+
+ 19 Oct 2012; Dane Smith <c1pher@gentoo.org> -gnutls-2.12.18.ebuild,
+ gnutls-2.12.20.ebuild, +files/gnutls-2.12.20-guile-parallelmake.patch,
+ gnutls-3.1.3.ebuild, +files/gnutls-3.1.3-guile-parallelmake.patch:
+ Add patches to fix parallel make issues in bug 427844 and bug 437256.
+ Update ebuilds for 2.12.20 and 3.1.3 to make use of said patches.
+ Drop old.
*gnutls-3.1.3 (13 Oct 2012)
diff --git a/net-libs/gnutls/files/gnutls-2.12.20-guile-parallelmake.patch b/net-libs/gnutls/files/gnutls-2.12.20-guile-parallelmake.patch
new file mode 100644
index 000000000000..5bb085793deb
--- /dev/null
+++ b/net-libs/gnutls/files/gnutls-2.12.20-guile-parallelmake.patch
@@ -0,0 +1,9 @@
+--- a/guile/src/Makefile.am
++++ b/guile/src/Makefile.am
+@@ -124,4 +124,7 @@
+
+ .c.x: $(BUILT_SOURCES)
+ $(guile_snarf) -o $@ $< $(snarfcppopts)
++core.x: core.c enums.h enum-map.i.c priorities.i.c smobs.h smob-types.i.c
++errors.x: errors.c enums.h
++extra.x: extra.c enums.h extra-enums.h extra-enum-map.i.c extra-smobs.h extra-smob-types.i.c smobs.h
diff --git a/net-libs/gnutls/files/gnutls-3.1.3-guile-parallelmake.patch b/net-libs/gnutls/files/gnutls-3.1.3-guile-parallelmake.patch
new file mode 100644
index 000000000000..5bb085793deb
--- /dev/null
+++ b/net-libs/gnutls/files/gnutls-3.1.3-guile-parallelmake.patch
@@ -0,0 +1,9 @@
+--- a/guile/src/Makefile.am
++++ b/guile/src/Makefile.am
+@@ -124,4 +124,7 @@
+
+ .c.x: $(BUILT_SOURCES)
+ $(guile_snarf) -o $@ $< $(snarfcppopts)
++core.x: core.c enums.h enum-map.i.c priorities.i.c smobs.h smob-types.i.c
++errors.x: errors.c enums.h
++extra.x: extra.c enums.h extra-enums.h extra-enum-map.i.c extra-smobs.h extra-smob-types.i.c smobs.h
diff --git a/net-libs/gnutls/gnutls-2.12.18.ebuild b/net-libs/gnutls/gnutls-2.12.18.ebuild
deleted file mode 100644
index 5d31aaa8dd09..000000000000
--- a/net-libs/gnutls/gnutls-2.12.18.ebuild
+++ /dev/null
@@ -1,129 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-2.12.18.ebuild,v 1.16 2012/08/02 20:08:08 radhermit Exp $
-
-EAPI=4
-
-inherit autotools libtool eutils
-
-DESCRIPTION="A TLS 1.2 and SSL 3.0 implementation for the GNU project"
-HOMEPAGE="http://www.gnutls.org/"
-
-if [[ "${PV}" == *pre* ]]; then
- SRC_URI="http://daily.josefsson.org/${P%.*}/${P%.*}-${PV#*pre}.tar.gz"
-else
- MINOR_VERSION="${PV#*.}"
- MINOR_VERSION="${MINOR_VERSION%%.*}"
- if [[ $((MINOR_VERSION % 2)) == 0 ]]; then
- #SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.bz2"
- SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
- else
- SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.bz2"
- fi
- unset MINOR_VERSION
-fi
-
-# LGPL-2.1 for libgnutls library and GPL-3 for libgnutls-extra library.
-LICENSE="GPL-3 LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
-IUSE="bindist +cxx doc examples guile lzo +nettle nls pkcs11 static-libs test zlib"
-
-RDEPEND=">=dev-libs/libtasn1-0.3.4
- guile? ( >=dev-scheme/guile-1.8[networking] )
- nettle? ( >=dev-libs/nettle-2.1[gmp] )
- !nettle? ( >=dev-libs/libgcrypt-1.4.0 )
- nls? ( virtual/libintl )
- pkcs11? ( >=app-crypt/p11-kit-0.11 )
- zlib? ( >=sys-libs/zlib-1.2.3.1 )
- !bindist? ( lzo? ( >=dev-libs/lzo-2 ) )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- sys-devel/libtool
- doc? ( dev-util/gtk-doc )
- nls? ( sys-devel/gettext )
- test? ( app-misc/datefudge )"
-
-S="${WORKDIR}/${P%_pre*}"
-
-DOCS=( AUTHORS ChangeLog NEWS README THANKS doc/TODO )
-
-pkg_setup() {
- if use lzo && use bindist; then
- ewarn "lzo support is disabled for binary distribution of GnuTLS due to licensing issues."
- fi
-}
-
-src_prepare() {
- # tests/suite directory is not distributed.
- sed -i -e 's|AC_CONFIG_FILES(\[tests/suite/Makefile\])|:|' \
- configure.ac || die
-
- sed -i -e 's/imagesdir = $(infodir)/imagesdir = $(htmldir)/' \
- doc/Makefile.am || die
-
- local dir
- for dir in m4 lib/m4 libextra/m4; do
- rm -f "${dir}/lt"* "${dir}/libtool.m4"
- done
- find . -name ltmain.sh -exec rm {} \;
-
- # support user patches
- epatch_user
-
- for dir in . lib libextra; do
- pushd "${dir}" > /dev/null
- sed -i -e '/^AM_INIT_AUTOMAKE/s/-Werror//' configure.ac || die
- eautoreconf
- popd > /dev/null
- done
-
- # Use sane .so versioning on FreeBSD.
- elibtoolize
-}
-
-src_configure() {
- local myconf
- use bindist && myconf="--without-lzo" || myconf="$(use_with lzo)"
- [[ "${VALGRIND_TESTS}" != "1" ]] && myconf+=" --disable-valgrind-tests"
-
- econf \
- --htmldir=/usr/share/doc/${P}/html \
- --disable-silent-rules \
- $(use_enable cxx) \
- $(use_enable doc gtk-doc) \
- $(use_enable doc gtk-doc-pdf) \
- $(use_enable guile) \
- $(use_with !nettle libgcrypt) \
- $(use_enable nls) \
- $(use_with pkcs11 p11-kit) \
- $(use_enable static-libs static) \
- $(use_with zlib) \
- ${myconf}
-}
-
-src_test() {
- if has_version dev-util/valgrind && [[ ${VALGRIND_TESTS} != 1 ]]; then
- elog
- elog "You can set VALGRIND_TESTS=\"1\" to enable Valgrind tests."
- elog
- fi
-
- default
-}
-
-src_install() {
- default
-
- find "${ED}" -name '*.la' -exec rm -f {} +
-
- if use doc; then
- dodoc doc/gnutls.{pdf,ps}
- dohtml doc/gnutls.html
- fi
-
- if use examples; then
- docinto examples
- dodoc doc/examples/*.c
- fi
-}
diff --git a/net-libs/gnutls/gnutls-2.12.20.ebuild b/net-libs/gnutls/gnutls-2.12.20.ebuild
index ac3369f47616..965e29591d5e 100644
--- a/net-libs/gnutls/gnutls-2.12.20.ebuild
+++ b/net-libs/gnutls/gnutls-2.12.20.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-2.12.20.ebuild,v 1.9 2012/10/06 17:14:01 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-2.12.20.ebuild,v 1.10 2012/10/19 19:28:47 c1pher Exp $
EAPI=4
@@ -71,6 +71,7 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-AF_UNIX.patch
epatch "${FILESDIR}"/${P}-libadd.patch
epatch "${FILESDIR}"/${P}-glibc-2.16.patch
+ epatch "${FILESDIR}"/${P}-guile-parallelmake.patch
# support user patches
epatch_user
diff --git a/net-libs/gnutls/gnutls-3.1.3.ebuild b/net-libs/gnutls/gnutls-3.1.3.ebuild
index 0f4535e3345f..e2f48874110a 100644
--- a/net-libs/gnutls/gnutls-3.1.3.ebuild
+++ b/net-libs/gnutls/gnutls-3.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-3.1.3.ebuild,v 1.1 2012/10/13 19:07:34 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-3.1.3.ebuild,v 1.2 2012/10/19 19:28:47 c1pher Exp $
EAPI=4
@@ -66,6 +66,8 @@ src_prepare() {
rm src/$(basename ${file} .c).{c,h} || die
done
+ epatch "${FILESDIR}"/${P}-guile-parallelmake.patch
+
# support user patches
epatch_user