summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-02-04 16:57:28 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-02-04 16:57:28 +0000
commit54a0b4ec760e326e336461cbb9d42084de8aa148 (patch)
tree2dfd8a3e35dc8ea8a72522081d45e150bfad4ba1 /net-libs/gnutls/gnutls-1.0.4.ebuild
parentcleanup and bump (#40173) (Manifest recommit) (diff)
downloadgentoo-2-54a0b4ec760e326e336461cbb9d42084de8aa148.tar.gz
gentoo-2-54a0b4ec760e326e336461cbb9d42084de8aa148.tar.bz2
gentoo-2-54a0b4ec760e326e336461cbb9d42084de8aa148.zip
version bump. removed keyword because of major version upgrade. archs should look at marking this ~. added symlink hack to get around breaking apps because of major lib number change, however, the code is still binary compatible.
Diffstat (limited to 'net-libs/gnutls/gnutls-1.0.4.ebuild')
-rw-r--r--net-libs/gnutls/gnutls-1.0.4.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-libs/gnutls/gnutls-1.0.4.ebuild b/net-libs/gnutls/gnutls-1.0.4.ebuild
new file mode 100644
index 000000000000..bc6dd457c4f9
--- /dev/null
+++ b/net-libs/gnutls/gnutls-1.0.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-1.0.4.ebuild,v 1.1 2004/02/04 16:57:27 liquidx Exp $
+
+DESCRIPTION="A TLS 1.0 and SSL 3.0 implementation for the GNU project"
+HOMEPAGE="http://www.gnutls.org/"
+SRC_URI="ftp://ftp.gnutls.org/pub/gnutls/${P}.tar.gz"
+
+IUSE="zlib doc crypt"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=dev-libs/libgcrypt-1.1.90
+ crypt? ( >=app-crypt/opencdk-0.5.3 )
+ zlib? ( >=sys-libs/zlib-1.1 )"
+
+# gnutls has its own version of these. so let us use those instead.
+# >=dev-libs/libtasn1-0.2
+# >=dev-libs/lzo-1.0
+
+src_unpack() {
+ unpack ${A}
+ # allow for custom optimisation levels
+ cd ${S}; sed -i -e "s:\(CFLAGS.*\)-O2:\1:" configure
+}
+
+src_compile() {
+ local myconf
+
+ use crypt || myconf="${myconf} --disable-openpgp-authentication"
+
+ econf \
+ `use_with zlib` \
+ --with-included-minilzo \
+ --with-included-libtasn1 \
+ ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+
+ # make compatibility symlinks - 0.8.x
+ dosym /usr/lib/libgnutls.so.10 /usr/lib/libgnutls.so.7
+
+ dodoc AUTHORS COPYING COPYING.LIB ChangeLog NEWS \
+ README THANKS doc/TODO
+
+ if [ "`use doc`" ] ; then
+ dodoc doc/README.autoconf doc/tex/gnutls.ps
+ docinto examples
+ dodoc doc/examples/*.c
+ fi
+}