summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2008-04-21 19:05:36 +0000
committerMarkus Ullmann <jokey@gentoo.org>2008-04-21 19:05:36 +0000
commit1b4e72ec78fea90b5b459e68314e039030b82751 (patch)
tree9b29641107e33adf9c4e6cad0009b22b95c6090a /net-libs/gloox/gloox-0.9.9.5.ebuild
parentFix building with GCC 4.3. Closes bug #214368. (diff)
downloadgentoo-2-1b4e72ec78fea90b5b459e68314e039030b82751.tar.gz
gentoo-2-1b4e72ec78fea90b5b459e68314e039030b82751.tar.bz2
gentoo-2-1b4e72ec78fea90b5b459e68314e039030b82751.zip
Version bump
(Portage version: 2.1.5_rc5)
Diffstat (limited to 'net-libs/gloox/gloox-0.9.9.5.ebuild')
-rw-r--r--net-libs/gloox/gloox-0.9.9.5.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-libs/gloox/gloox-0.9.9.5.ebuild b/net-libs/gloox/gloox-0.9.9.5.ebuild
new file mode 100644
index 000000000000..bdef351f11fc
--- /dev/null
+++ b/net-libs/gloox/gloox-0.9.9.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gloox/gloox-0.9.9.5.ebuild,v 1.1 2008/04/21 19:05:36 jokey Exp $
+
+inherit autotools
+
+DESCRIPTION="A portable high-level Jabber/XMPP library for C++"
+HOMEPAGE="http://camaya.net/gloox"
+SRC_URI="http://camaya.net/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug gnutls idn ssl zlib"
+
+DEPEND="idn? ( >=net-dns/libidn-0.5.0 )
+ gnutls? ( >=net-libs/gnutls-1.2.0 )
+ ssl? ( >=dev-libs/openssl-0.9.8 )
+ zlib? ( >=sys-libs/zlib-1.2.3 )"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf \
+ $(use_enable debug debug) \
+ $(use_with idn libidn) \
+ $(use_with gnutls gnutls) \
+ $(use_with ssl openssl) \
+ $(use_with zlib zlib) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}