summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-12-03 18:40:04 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-12-03 18:40:04 +0000
commit6860f2cb0ab11c1dd2949d78409b4c8f7979a014 (patch)
tree37928d84fc2def24f4b90932c71c6906575ae4ce /net-libs/daq
parentAdded Prefix keywords, fix for Darwin (diff)
downloadgentoo-2-6860f2cb0ab11c1dd2949d78409b4c8f7979a014.tar.gz
gentoo-2-6860f2cb0ab11c1dd2949d78409b4c8f7979a014.tar.bz2
gentoo-2-6860f2cb0ab11c1dd2949d78409b4c8f7979a014.zip
Bump for #347445, default-enabling more useflags
(Portage version: 2.2.0_alpha6/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/daq')
-rw-r--r--net-libs/daq/ChangeLog7
-rw-r--r--net-libs/daq/daq-0.4.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/net-libs/daq/ChangeLog b/net-libs/daq/ChangeLog
index 31bd3d528615..a37c4d769664 100644
--- a/net-libs/daq/ChangeLog
+++ b/net-libs/daq/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/daq
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/daq/ChangeLog,v 1.3 2010/11/24 14:01:27 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/daq/ChangeLog,v 1.4 2010/12/03 18:40:04 patrick Exp $
+
+*daq-0.4 (03 Dec 2010)
+
+ 03 Dec 2010; Patrick Lauer <patrick@gentoo.org> +daq-0.4.ebuild:
+ Bump for #347445, default-enabling more useflags
24 Nov 2010; Patrick Lauer <patrick@gentoo.org> daq-0.3.ebuild:
Reducing makeopts to -j1 for #345915
diff --git a/net-libs/daq/daq-0.4.ebuild b/net-libs/daq/daq-0.4.ebuild
new file mode 100644
index 000000000000..80e8b39cc86f
--- /dev/null
+++ b/net-libs/daq/daq-0.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/daq/daq-0.4.ebuild,v 1.1 2010/12/03 18:40:04 patrick Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Data Acquisition library, for packet I/O"
+HOMEPAGE="http://www.snort.org/"
+SRC_URI="http://www.snort.org/downloads/579 -> ${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ipv6 +afpacket +dump +pcap"
+
+DEPEND="pcap? ( >=net-libs/libpcap-1.0.0 )
+ dump? ( >=net-libs/libpcap-1.0.0 )"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+
+ econf \
+ $(use_enable ipv6) \
+ $(use_enable pcap pcap-module) \
+ $(use_enable afpacket afpacket-module) \
+ $(use_enable dump dump-module) \
+ --disable-ipfw-module \
+ --disable-bundled-modules
+
+}
+
+src_install() {
+
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc ChangeLog README
+
+}
+
+pkg_postinst() {
+
+ elog
+ elog "The Data Acquisition library (DAQ) for packet I/O replaces direct"
+ elog "calls to PCAP functions with an abstraction layer that facilitates"
+ elog "operation on a variety of hardware and software interfaces without"
+ elog "requiring changes to application such as Snort."
+ elog
+ elog "The only DAQ modules supported with this ebuild are AFpacket, PCAP,"
+ elog "and Dump. IPQ and NFQ will be supported in future versions of this"
+ elog "package."
+ elog
+ elog "Please see the README file for DAQ for information about specific"
+ elog "DAQ modules."
+ ewarn
+ ewarn "If you are reinstalling this package, you should also reinstall"
+ ewarn "packages that use this library for packet capture."
+ ewarn
+
+}