summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-11-02 18:19:33 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-11-02 18:19:33 +0000
commit26bf6c4fe86e29fb0072f036ae3670f7db495405 (patch)
treeb826e63d4f2ba94aa559a9b98a1664390ea32a3b /net-libs/daq
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-26bf6c4fe86e29fb0072f036ae3670f7db495405.tar.gz
gentoo-2-26bf6c4fe86e29fb0072f036ae3670f7db495405.tar.bz2
gentoo-2-26bf6c4fe86e29fb0072f036ae3670f7db495405.zip
Bump
(Portage version: 2.2.0_alpha3/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/daq')
-rw-r--r--net-libs/daq/ChangeLog7
-rw-r--r--net-libs/daq/daq-0.3.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/net-libs/daq/ChangeLog b/net-libs/daq/ChangeLog
index b25d1bc43a28..5db0dce9688e 100644
--- a/net-libs/daq/ChangeLog
+++ b/net-libs/daq/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/daq
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/daq/ChangeLog,v 1.1 2010/11/02 18:11:18 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/daq/ChangeLog,v 1.2 2010/11/02 18:19:33 patrick Exp $
+
+*daq-0.3 (02 Nov 2010)
+
+ 02 Nov 2010; Patrick Lauer <patrick@gentoo.org> +daq-0.3.ebuild:
+ Bump
*daq-0.2 (02 Nov 2010)
diff --git a/net-libs/daq/daq-0.3.ebuild b/net-libs/daq/daq-0.3.ebuild
new file mode 100644
index 000000000000..3e47283d4050
--- /dev/null
+++ b/net-libs/daq/daq-0.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/daq/daq-0.3.ebuild,v 1.1 2010/11/02 18:19:33 patrick Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Data Acquisition library, for packet I/O"
+HOMEPAGE="http://www.snort.org/"
+SRC_URI="http://www.snort.org/downloads/302 -> ${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ipv6 afpacket dump +pcap"
+
+DEPEND="pcap? ( >=net-libs/libpcap-1.0.0 )
+ dump? ( >=net-libs/libpcap-1.0.0 )"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+
+ econf \
+ $(use_enable ipv6) \
+ $(use_enable pcap pcap-module) \
+ $(use_enable afpacket afpacket-module) \
+ $(use_enable dump dump-module) \
+ --disable-ipfw-module \
+ --disable-bundled-modules
+
+}
+
+src_install() {
+
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc ChangeLog README
+
+}
+
+pkg_postinst() {
+
+ elog
+ elog "The Data Acquisition library (DAQ) for packet I/O replaces direct"
+ elog "calls to PCAP functions with an abstraction layer that facilitates"
+ elog "operation on a variety of hardware and software interfaces without"
+ elog "requiring changes to application such as Snort."
+ elog
+ elog "The only DAQ modules supported with this ebuild are AFpacket, PCAP,"
+ elog "and Dump. IPQ and NFQ will be supported in future versions of this"
+ elog "package."
+ elog
+ elog "Please see the README file for DAQ for information about specific"
+ elog "DAQ modules."
+ ewarn
+ ewarn "If you are reinstalling this package, you should also reinstall"
+ ewarn "packages that use this library for packet capture."
+ ewarn
+
+}