summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2012-10-08 18:43:15 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2012-10-08 18:43:15 +0000
commite506d02fdd2f9e00741701500406718736e98f65 (patch)
tree1446b6300f500c71725cf48a4490d6fedc3dd9f2 /net-libs/c-client
parentFix SRC_URI (diff)
downloadgentoo-2-e506d02fdd2f9e00741701500406718736e98f65.tar.gz
gentoo-2-e506d02fdd2f9e00741701500406718736e98f65.tar.bz2
gentoo-2-e506d02fdd2f9e00741701500406718736e98f65.zip
Add in IPv6 and Kerberos support from uw-imap.
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/c-client')
-rw-r--r--net-libs/c-client/ChangeLog7
-rw-r--r--net-libs/c-client/c-client-2007f-r3.ebuild120
2 files changed, 126 insertions, 1 deletions
diff --git a/net-libs/c-client/ChangeLog b/net-libs/c-client/ChangeLog
index f84b31637a26..1c0bfe7eb319 100644
--- a/net-libs/c-client/ChangeLog
+++ b/net-libs/c-client/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/c-client
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/ChangeLog,v 1.90 2012/07/11 19:04:50 eras Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/ChangeLog,v 1.91 2012/10/08 18:43:15 robbat2 Exp $
+
+*c-client-2007f-r3 (08 Oct 2012)
+
+ 08 Oct 2012; Robin H. Johnson <robbat2@gentoo.org> +c-client-2007f-r3.ebuild:
+ Add in IPv6 and Kerberos support from uw-imap.
11 Jul 2012; Eray Aslan <eras@gentoo.org> -c-client-2007f.ebuild:
Remove old
diff --git a/net-libs/c-client/c-client-2007f-r3.ebuild b/net-libs/c-client/c-client-2007f-r3.ebuild
new file mode 100644
index 000000000000..80a3065ed045
--- /dev/null
+++ b/net-libs/c-client/c-client-2007f-r3.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/c-client-2007f-r3.ebuild,v 1.1 2012/10/08 18:43:15 robbat2 Exp $
+
+EAPI=4
+
+inherit flag-o-matic eutils libtool toolchain-funcs multilib
+
+MY_PN=imap
+MY_P="${MY_PN}-${PV}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="UW IMAP c-client library"
+HOMEPAGE="http://www.washington.edu/imap/"
+SRC_URI="ftp://ftp.cac.washington.edu/imap/${MY_P}.tar.Z"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="doc +ipv6 kerberos kernel_linux kernel_FreeBSD pam ssl static-libs"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ !net-mail/uw-imap
+ kerberos? ( app-crypt/mit-krb5 )"
+DEPEND="${RDEPEND}
+ kernel_linux? ( pam? ( >=sys-libs/pam-0.72 ) )"
+
+src_prepare() {
+ # Tarball packed with bad file perms
+ chmod -R u+rwX,go-w .
+
+ # lots of things need -fPIC, including various platforms, and this library
+ # generally should be built with it anyway.
+ append-flags -fPIC
+
+ # Modifications so we can build it optimally and correctly
+ sed \
+ -e "s:BASECFLAGS=\".*\":BASECFLAGS=:g" \
+ -e 's:SSLDIR=/usr/local/ssl:SSLDIR=/usr:g' \
+ -e 's:SSLCERTS=$(SSLDIR)/certs:SSLCERTS=/etc/ssl/certs:g' \
+ -i src/osdep/unix/Makefile || die "Makefile sed fixing failed"
+
+ # Make the build system more multilib aware
+ sed \
+ -e "s:^SSLLIB=\$(SSLDIR)/lib:SSLLIB=\$(SSLDIR)/$(get_libdir):" \
+ -e "s:^AFSLIB=\$(AFSDIR)/lib:AFSLIB=\$(AFSDIR)/$(get_libdir):" \
+ -i src/osdep/unix/Makefile || die "Makefile sed fixing failed"
+
+ # Targets should use the Gentoo (ie linux) fs
+ sed -e '/^bsf:/,/^$/ s:ACTIVEFILE=.*:ACTIVEFILE=/var/lib/news/active:g' \
+ -i src/osdep/unix/Makefile || die "Makefile sex fixing failed for FreeBSD"
+
+ # Apply a patch to only build the stuff we need for c-client
+ epatch "${FILESDIR}"/${PN}-2006k_GENTOO_Makefile.patch
+
+ # Apply patch to add the compilation of a .so for PHP
+ # This was previously conditional, but is more widely useful.
+ epatch "${FILESDIR}"/${PN}-2006k_GENTOO_amd64-so-fix.patch
+
+ # Remove the pesky checks about SSL stuff
+ sed -e '/read.*exit/d' -i Makefile || die
+
+ # Respect LDFLAGS
+ epatch "${FILESDIR}"/${PN}-2007e-ldflags.patch
+ sed -e "s/CC=cc/CC=$(tc-getCC)/" \
+ -e "s/ARRC=ar/ARRC=$(tc-getAR)/" \
+ -e "s/RANLIB=ranlib/RANLIB=$(tc-getRANLIB)/" \
+ -i src/osdep/unix/Makefile || die "Respecting build flags"
+
+ elibtoolize
+}
+
+src_compile() {
+ local mymake ipver ssltype target passwdtype
+ ipver='IP=4'
+ use ipv6 && ipver="IP=6"
+ use ssl && ssltype="unix" || ssltype="none"
+ if use kernel_linux ; then
+ use pam && target=lnp passwdtype=pam || target=lnx passwdtype=std
+ elif use kernel_FreeBSD ; then
+ target=bsf passwdtype=pam
+ fi
+ use kerberos && mymake="EXTRAAUTHENTICATORS=gss"
+ touch ip6 # IPv6 by default now
+ # no parallel builds supported!
+ emake -j1 SSLTYPE=${ssltype} $target \
+ IP=6 PASSWDTYPE=${passwdtype} ${mymake} \
+ EXTRACFLAGS="${CFLAGS}" EXTRALDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ if use static-libs; then
+ # Library binary
+ dolib.a c-client/c-client.a
+ dosym c-client.a /usr/$(get_libdir)/libc-client.a
+ fi
+
+ # Now the shared library
+ dolib.so c-client/libc-client.so.1.0.0
+
+ dosym libc-client.so.1.0.0 /usr/$(get_libdir)/libc-client.so
+ dosym libc-client.so.1.0.0 /usr/$(get_libdir)/libc-client.so.1
+
+ # Headers
+ insinto /usr/include/imap
+ doins src/osdep/unix/*.h
+ doins src/c-client/*.h
+ doins c-client/linkage.h
+ doins c-client/linkage.c
+ doins c-client/osdep.h
+
+ # Docs
+ dodoc README docs/*.txt docs/BUILD docs/CONFIG docs/RELNOTES docs/SSLBUILD
+ if use doc; then
+ docinto rfc
+ dodoc docs/rfc/*.txt
+ docinto draft
+ dodoc docs/draft/*
+ fi
+}