summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-05-18 12:21:16 +0000
committerRoy Marples <uberlord@gentoo.org>2007-05-18 12:21:16 +0000
commit69851a76c3841b8bbfa6c119d2fc1fd48d0a7ecb (patch)
treec42463bbd28d3e38ee9dfa3ad2f002543f26a769 /net-libs/c-client
parentFix the chmod's for suexec, as chmod can't be used on symlinks (triggers a sa... (diff)
downloadgentoo-2-69851a76c3841b8bbfa6c119d2fc1fd48d0a7ecb.tar.gz
gentoo-2-69851a76c3841b8bbfa6c119d2fc1fd48d0a7ecb.tar.bz2
gentoo-2-69851a76c3841b8bbfa6c119d2fc1fd48d0a7ecb.zip
Keyworded ~x86-fbsd, #138170 thanks to Nicholas Steicke.
(Portage version: 2.1.2.7)
Diffstat (limited to 'net-libs/c-client')
-rw-r--r--net-libs/c-client/ChangeLog5
-rw-r--r--net-libs/c-client/c-client-2004g.ebuild18
2 files changed, 17 insertions, 6 deletions
diff --git a/net-libs/c-client/ChangeLog b/net-libs/c-client/ChangeLog
index 34a8aa4672a0..03a0ef18279f 100644
--- a/net-libs/c-client/ChangeLog
+++ b/net-libs/c-client/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-libs/c-client
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/ChangeLog,v 1.32 2007/02/22 01:26:41 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/ChangeLog,v 1.33 2007/05/18 12:21:16 uberlord Exp $
+
+ 18 May 2007; Roy Marples <uberlord@gentoo.org> c-client-2004g.ebuild:
+ Keyworded ~x86-fbsd, #138170 thanks to Nicholas Steicke.
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/net-libs/c-client/c-client-2004g.ebuild b/net-libs/c-client/c-client-2004g.ebuild
index b1f0438ce718..bf5dee1fbb02 100644
--- a/net-libs/c-client/c-client-2004g.ebuild
+++ b/net-libs/c-client/c-client-2004g.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/c-client-2004g.ebuild,v 1.3 2006/12/26 02:58:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/c-client-2004g.ebuild,v 1.4 2007/05/18 12:21:16 uberlord Exp $
inherit flag-o-matic eutils libtool
@@ -14,8 +14,8 @@ SRC_URI="ftp://ftp.cac.washington.edu/imap/${MY_P}.tar.Z"
LICENSE="as-is"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="ssl pam"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl pam kernel_linux kernel_FreeBSD"
RDEPEND="ssl? ( dev-libs/openssl )
!virtual/imap-c-client"
@@ -42,6 +42,10 @@ src_unpack() {
-e 's:SSLCERTS=$(SSLDIR)/certs:SSLCERTS=/etc/ssl/certs:g' \
-i src/osdep/unix/Makefile || die "Makefile sed fixing failed"
+ # Targets should use the Gentoo (ie linux) fs
+ sed -e '/^bsf:/,/^$/ s:ACTIVEFILE=.*:ACTIVEFILE=/var/lib/news/active:g' \
+ -i src/osdep/unix/Makefile || die "Makefile sex fixing failed for FreeBSD"
+
# Apply a patch to only build the stuff we need for c-client
epatch ${FILESDIR}/2002d-Makefile.patch || die "epatch failed"
@@ -57,7 +61,11 @@ src_unpack() {
src_compile() {
local ssltype target
use ssl && ssltype="unix" || ssltype="none"
- use pam && target=lnp || target=lnx
+ if use kernel_linux ; then
+ use pam && target=lnp || target=lnx
+ elif use kernel_FreeBSD ; then
+ target=bsf
+ fi
# no parallel builds supported!
make $target SSLTYPE=${ssltype} EXTRACFLAGS="${CFLAGS}" || die "make failed"
}