summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-10-26 06:46:55 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-10-26 06:46:55 +0000
commit19610980f1b07556a7dabb7aa20f236cdfa7953b (patch)
treecf030753f2b9446d44c1ff7b64887b4682eed62e /net-libs/c-client
parentversion bump (diff)
downloadgentoo-2-19610980f1b07556a7dabb7aa20f236cdfa7953b.tar.gz
gentoo-2-19610980f1b07556a7dabb7aa20f236cdfa7953b.tar.bz2
gentoo-2-19610980f1b07556a7dabb7aa20f236cdfa7953b.zip
version bump
Diffstat (limited to 'net-libs/c-client')
-rw-r--r--net-libs/c-client/ChangeLog7
-rw-r--r--net-libs/c-client/Manifest4
-rw-r--r--net-libs/c-client/c-client-2002e.ebuild79
-rw-r--r--net-libs/c-client/files/digest-c-client-2002e1
4 files changed, 88 insertions, 3 deletions
diff --git a/net-libs/c-client/ChangeLog b/net-libs/c-client/ChangeLog
index b287a25b8968..b41cf7847d59 100644
--- a/net-libs/c-client/ChangeLog
+++ b/net-libs/c-client/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/c-client
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/ChangeLog,v 1.7 2003/10/26 05:35:52 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/ChangeLog,v 1.8 2003/10/26 06:46:53 robbat2 Exp $
+
+*c-client-2002e (25 Oct 2003)
+
+ 25 Oct 2003; Robin H. Johnson <robbat2@gentoo.org> c-client-2002e.ebuild:
+ version bump
25 Oct 2003; Robin H. Johnson <robbat2@gentoo.org> c-client-2002d-r1.ebuild:
bump -r1 to stable
diff --git a/net-libs/c-client/Manifest b/net-libs/c-client/Manifest
index d70691a7a3f8..e0a328e4deb4 100644
--- a/net-libs/c-client/Manifest
+++ b/net-libs/c-client/Manifest
@@ -1,6 +1,6 @@
-MD5 5c4a0c1327be112bc842cf036b366862 c-client-2002e.ebuild 1881
+MD5 9e3e64dc97ef1b565891d29569222d0b c-client-2002e.ebuild 1905
MD5 5ae91327a010a1d207efd745c61a424b c-client-2002d-r1.ebuild 1881
-MD5 e4976525cb859808d07932b492ed4727 ChangeLog 1212
+MD5 b3a1f0ec4a975071297d3e5ef4fc3cd4 ChangeLog 1335
MD5 921fed101cade175f914be4ef1a4b0a0 c-client-2002d.ebuild 1865
MD5 1fc1132a6fb90046b701e9196e7a96b0 files/digest-c-client-2002d-r1 62
MD5 1fc1132a6fb90046b701e9196e7a96b0 files/digest-c-client-2002d 62
diff --git a/net-libs/c-client/c-client-2002e.ebuild b/net-libs/c-client/c-client-2002e.ebuild
new file mode 100644
index 000000000000..d7ccc49cfac6
--- /dev/null
+++ b/net-libs/c-client/c-client-2002e.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/c-client-2002e.ebuild,v 1.1 2003/10/26 06:46:53 robbat2 Exp $
+
+MY_PN=imap
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="UW IMAP c-client library"
+SRC_URI="ftp://ftp.cac.washington.edu/imap/${MY_P}.tar.Z"
+HOMEPAGE="http://www.washington.edu/imap/"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~hppa ~alpha"
+IUSE="ssl pic"
+
+PROVIDE="virtual/imap-c-client"
+RDEPEND="ssl? ( dev-libs/openssl )
+ !virtual/imap-c-client"
+DEPEND="${RDEPEND}
+ >=sys-libs/pam-0.72"
+
+inherit flag-o-matic
+
+src_unpack() {
+ unpack ${A}
+
+ # Tarball packed with bad file perms
+ chmod -R ug+w ${S}
+
+ # alpha needs -fPIC
+ use pic || use alpha && append-flags -fPIC
+
+ # Modifications so we can build it optimially and correctly
+ cd ${S}/src/osdep/unix/
+ cp Makefile Makefile.orig
+ sed \
+ -e 's,-g -fno-omit-frame-pointer -O6,${CFLAGS},g' \
+ -e 's,SSLDIR=/usr/local/ssl,SSLDIR=/usr,g' \
+ -e 's,SSLCERTS=$(SSLDIR)/certs,SSLCERTS=/etc/ssl/certs,g' \
+ < Makefile.orig > Makefile
+
+ # Apply a patch to only build the stuff we need for c-client
+ cd ${S}
+ patch < ${FILESDIR}/2002d-Makefile.patch || die "Patch failed"
+
+ # Remove the pesky checks about SSL stuff
+ cd ${S}
+ cp Makefile Makefile.orig
+ grep -v 'read.*exit 1' <Makefile.orig >Makefile
+}
+
+src_compile() {
+ if use ssl; then
+ make lnp SSLTYPE=unix || die
+ else
+ make lnp SSLTYPE=none || die
+ fi
+}
+
+src_install() {
+ into /usr
+
+ # Library binary
+ dolib.a c-client/c-client.a
+ dosym /usr/lib/c-client.a /usr/lib/libc-client.a
+
+ # Headers
+ insinto /usr/include/imap
+ doins c-client/{c-client,mail,imap4r1,rfc822,linkage,misc,smtp,nntp}.h
+ doins c-client/{osdep,env_unix,env,fs,ftl,nl,tcp}.h
+
+ # Docs
+ dodoc CPYRIGHT README docs/*.txt docs/CONFIG docs/RELNOTES
+
+ docinto rfc
+ dodoc docs/rfc/*.txt
+}
diff --git a/net-libs/c-client/files/digest-c-client-2002e b/net-libs/c-client/files/digest-c-client-2002e
new file mode 100644
index 000000000000..cbbff9d87969
--- /dev/null
+++ b/net-libs/c-client/files/digest-c-client-2002e
@@ -0,0 +1 @@
+MD5 0d246d868f20d8c441d235b77c940676 imap-2002e.tar.Z 2157511