summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-06-17 21:14:32 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-06-17 21:14:32 +0000
commit64baedd6afcf69c910342cb07da794815c1b180d (patch)
treee9335802c70a64fcc7f551d91686ebf16919a5b8 /net-libs/axtls
parentNewer fcitx always has dbus support, bug 421187 (diff)
downloadgentoo-2-64baedd6afcf69c910342cb07da794815c1b180d.tar.gz
gentoo-2-64baedd6afcf69c910342cb07da794815c1b180d.tar.bz2
gentoo-2-64baedd6afcf69c910342cb07da794815c1b180d.zip
Make build system multilib aware, add USE=static-libs, for bug #421479
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/axtls')
-rw-r--r--net-libs/axtls/ChangeLog6
-rw-r--r--net-libs/axtls/axtls-1.4.6-r1.ebuild15
-rw-r--r--net-libs/axtls/files/explicit-libdir.patch41
3 files changed, 58 insertions, 4 deletions
diff --git a/net-libs/axtls/ChangeLog b/net-libs/axtls/ChangeLog
index 6800b54ebff7..51bea3a06556 100644
--- a/net-libs/axtls/ChangeLog
+++ b/net-libs/axtls/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/axtls
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/axtls/ChangeLog,v 1.3 2012/06/07 00:13:29 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/axtls/ChangeLog,v 1.4 2012/06/17 21:14:32 blueness Exp $
+
+ 17 Jun 2012; Anthony G. Basile <blueness@gentoo.org> axtls-1.4.6-r1.ebuild,
+ +files/explicit-libdir.patch:
+ Make build system multilib aware, add USE=static-libs, for bug #421479
*axtls-1.4.6-r1 (07 Jun 2012)
diff --git a/net-libs/axtls/axtls-1.4.6-r1.ebuild b/net-libs/axtls/axtls-1.4.6-r1.ebuild
index f3a4b68d014f..db55f38befd6 100644
--- a/net-libs/axtls/axtls-1.4.6-r1.ebuild
+++ b/net-libs/axtls/axtls-1.4.6-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/axtls/axtls-1.4.6-r1.ebuild,v 1.1 2012/06/07 00:13:28 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/axtls/axtls-1.4.6-r1.ebuild,v 1.2 2012/06/17 21:14:32 blueness Exp $
EAPI="4"
-inherit eutils savedconfig toolchain-funcs user
+inherit eutils multilib savedconfig toolchain-funcs user
################################################################################
# axtls CONFIG MINI-HOWTO
@@ -42,7 +42,7 @@ S="${WORKDIR}/${MY_PN}"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~x86"
-IUSE="httpd cgi-lua cgi-php static doc"
+IUSE="httpd cgi-lua cgi-php static static-libs doc"
# TODO: add ipv6, and c#, java, lua, perl bindings
# Currently these all have some issue
@@ -74,6 +74,10 @@ src_prepare() {
tc-export CC
epatch "${FILESDIR}/bigint_impl.h-add-missing-include.patch"
+ epatch "${FILESDIR}/explicit-libdir.patch"
+
+ sed -i -e 's:^LIBDIR.*/lib:LIBDIR = $(PREFIX)/'"$(get_libdir):" \
+ "${S}"/Makefile
#Use CC as the host compiler for mconf
sed -i -e "s:^HOSTCC.*:HOSTCC=${CC}:" \
@@ -155,6 +159,11 @@ src_install() {
fi
emake PREFIX="${ED}/usr" install
+
+ if ! use static-libs; then
+ rm -f "${ED}"/usr/$(get_libdir)/libaxtls.a
+ fi
+
if [ -f "${ED}"/usr/bin/htpasswd ]; then
mv "${ED}"/usr/bin/{,ax}htpasswd
fi
diff --git a/net-libs/axtls/files/explicit-libdir.patch b/net-libs/axtls/files/explicit-libdir.patch
new file mode 100644
index 000000000000..9a1bc7e250dc
--- /dev/null
+++ b/net-libs/axtls/files/explicit-libdir.patch
@@ -0,0 +1,41 @@
+diff -Naur axTLS.orig//Makefile axTLS/Makefile
+--- axTLS.orig//Makefile 2011-01-07 08:16:40.000000000 -0500
++++ axTLS/Makefile 2012-06-17 16:55:04.000000000 -0400
+@@ -60,6 +60,8 @@
+ $(MAKE) -C samples
+ endif
+
++LIBDIR = $(PREFIX)/lib
++
+ $(STAGE) : ssl/version.h
+ @mkdir -p $(STAGE)
+
+@@ -68,7 +70,7 @@
+ @echo "#define AXTLS_VERSION \"(no version)\"" > ssl/version.h
+
+ $(PREFIX) :
+- @mkdir -p $(PREFIX)/lib
++ @mkdir -p $(LIBDIR)
+ @mkdir -p $(PREFIX)/bin
+
+ release:
+@@ -89,8 +91,8 @@
+ $(MAKE) win32releaseconf
+
+ install: $(PREFIX) all
+- cp --no-dereference $(STAGE)/libax* $(PREFIX)/lib
+- chmod 755 $(PREFIX)/lib/libax*
++ cp --no-dereference $(STAGE)/libax* $(LIBDIR)
++ chmod 755 $(LIBDIR)/libax*
+ ifdef CONFIG_SAMPLES
+ install -m 755 $(STAGE)/ax* $(PREFIX)/bin
+ endif
+@@ -112,7 +114,7 @@
+ install -m 644 config/config.h $(PREFIX)/include/axTLS
+
+ installclean:
+- -@rm $(PREFIX)/lib/libax* > /dev/null 2>&1
++ -@rm $(LIBDIR)/libax* > /dev/null 2>&1
+ -@rm $(PREFIX)/bin/ax* > /dev/null 2>&1
+ -@rm $(PREFIX)/bin/axhttpd* > /dev/null 2>&1
+ -@rm `perl -e 'use Config; print $$Config{installarchlib};'`/axtlsp.pm > /dev/null 2>&1