summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-05-27 15:18:02 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-05-27 15:18:02 +0000
commitf8d75f65ed41e7de6cd69b1320d5285fa019e15c (patch)
treec287814dda353baf1acfa275834fcaa4c43e4299 /net-irc
parentslight adjustments (diff)
downloadgentoo-2-f8d75f65ed41e7de6cd69b1320d5285fa019e15c.tar.gz
gentoo-2-f8d75f65ed41e7de6cd69b1320d5285fa019e15c.tar.bz2
gentoo-2-f8d75f65ed41e7de6cd69b1320d5285fa019e15c.zip
oops
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/ChangeLog10
-rw-r--r--net-irc/xchat/files/digest-xchat-200205191
-rw-r--r--net-irc/xchat/xchat-20020519.ebuild81
3 files changed, 91 insertions, 1 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index 383e78469a08..283cdd5a2e58 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,7 +1,15 @@
# ChangeLog for net-irc/xchat
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.5 2002/05/21 09:45:08 blocke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.6 2002/05/27 15:18:02 spider Exp $
+
+*xchat-20020519 (27 May 2002)
+ 27 May 2002; Spider <spider@gentoo.org> xchat-20020519.ebuild
+ xchat ebuild written to work with GNOME2 or just GTK+2
+ ebuild wrote by Gabriele Giorgetti <g.gabriele79@genie.it> | stroke on #gentoo
+ hacked on and verified...
+ should be masked
+
*xchat-1.8.9.ebuild (21 May 2002)
21 May 2002; Bruce A. Locke <blocke@shivan.org> xchat-1.8.9.ebuild :
diff --git a/net-irc/xchat/files/digest-xchat-20020519 b/net-irc/xchat/files/digest-xchat-20020519
new file mode 100644
index 000000000000..895cf7c8339a
--- /dev/null
+++ b/net-irc/xchat/files/digest-xchat-20020519
@@ -0,0 +1 @@
+MD5 bd41d0fb94246a365abddff3b4972361 xchat-20020519.tar.bz2 668669
diff --git a/net-irc/xchat/xchat-20020519.ebuild b/net-irc/xchat/xchat-20020519.ebuild
new file mode 100644
index 000000000000..d44186a082a1
--- /dev/null
+++ b/net-irc/xchat/xchat-20020519.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-20020519.ebuild,v 1.1 2002/05/27 15:18:02 spider Exp $
+
+# Python is DISABLED
+
+S=${WORKDIR}/${P}
+DESCRIPTION="X-Chat is a graphical IRC client for UNIX operating systems."
+SRC_URI="http://www.xchat.org/files/source/1.9/${P}.tar.bz2"
+HOMEPAGE="http://www.xchat.org/"
+LICENSE="GPL-2"
+SLOT=0
+
+RDEPEND=">=dev-libs/glib-2.0.1
+ >=x11-libs/gtk+-2.0.1
+ perl? ( >=sys-devel/perl-5.6.1 )
+ gnome? ( >=x11-libs/libzvt-1.115.2
+ >=gnome-base/libgnome-1.117.1
+ >=gnome-base/gnome-applets-1.103.0
+ >=gnome-base/gnome-panel-1.5.22 )"
+
+
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.10.38 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+
+ local myopts myflags
+
+ use gnome \
+ && myopts="${myopts} --enable-gnome --enable-panel" \
+ || myopts="${myopts} --enable-gtkfe --disable-gnome --disable-zvt --disable-gdk-pixbuf"
+
+ use gnome \
+ && CFLAGS="${CFLAGS} -I/usr/include/orbit-2.0" \
+ || myopts="${myopts} --disable-gnome"
+
+ use gtk \
+ || myopts="${myopts} --disable-gtkfe"
+
+ use ssl \
+ && myopts="${myopts} --enable-openssl"
+
+ use perl \
+ || myopts="${myopts} --disable-perl"
+
+ use nls \
+ && myopts="${myopts} --enable-hebrew --enable-japanese-conv" \
+ || myopts="${myopts} --disable-nls"
+
+ use mmx \
+ && myopts="${myopts} --enable-mmx" \
+ || myopts="${myopts} --disable-mmx"
+
+ use ipv6 \
+ && myopts="${myopts} --enable-ipv6"
+
+
+ ./configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ ${myopts} || die
+
+ emake || die
+}
+
+src_install() {
+
+ make prefix=${D}/usr utildir=${D}${KDEDIR}/share/applnk/Internet install || die
+
+ use gnome &&
+ ( insinto /usr/share/gnome/apps/Internet
+ doins xchat.desktop )
+
+ dodoc AUTHORS COPYING ChangeLog README
+}