summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-07-10 07:25:04 +0000
committerPatrick Lauer <patrick@gentoo.org>2015-07-10 07:25:04 +0000
commitf66215e72336f3b24d45c9aa3b970dd1753d3543 (patch)
tree042126b652f70f4056ac8a752eae635cc2818d40 /net-irc
parentBump, ebuild borrowed from dotnet overlay (diff)
downloadgentoo-2-f66215e72336f3b24d45c9aa3b970dd1753d3543.tar.gz
gentoo-2-f66215e72336f3b24d45c9aa3b970dd1753d3543.tar.bz2
gentoo-2-f66215e72336f3b24d45c9aa3b970dd1753d3543.zip
Bump
(Portage version: 2.2.20/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/smuxi/ChangeLog9
-rw-r--r--net-irc/smuxi/smuxi-0.11.1.ebuild54
2 files changed, 61 insertions, 2 deletions
diff --git a/net-irc/smuxi/ChangeLog b/net-irc/smuxi/ChangeLog
index 2b50f915a223..f77291202ec7 100644
--- a/net-irc/smuxi/ChangeLog
+++ b/net-irc/smuxi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/smuxi
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/smuxi/ChangeLog,v 1.27 2014/08/10 20:53:50 slyfox Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/smuxi/ChangeLog,v 1.28 2015/07/10 07:25:04 patrick Exp $
+
+*smuxi-0.11.1 (10 Jul 2015)
+
+ 10 Jul 2015; Patrick Lauer <patrick@gentoo.org> +smuxi-0.11.1.ebuild:
+ Bump
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> smuxi-0.8.10.1.ebuild:
QA: drop trailing '.' from DESCRIPTION
diff --git a/net-irc/smuxi/smuxi-0.11.1.ebuild b/net-irc/smuxi/smuxi-0.11.1.ebuild
new file mode 100644
index 000000000000..7f9b73759918
--- /dev/null
+++ b/net-irc/smuxi/smuxi-0.11.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/smuxi/smuxi-0.11.1.ebuild,v 1.1 2015/07/10 07:25:04 patrick Exp $
+
+EAPI=5
+inherit eutils mono-env
+
+DESCRIPTION="A flexible, irssi-like and user-friendly IRC client for the Gnome Desktop"
+HOMEPAGE="http://www.smuxi.org/main/"
+SRC_URI="http://www.smuxi.org/jaws/data/files/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus debug gtk libnotify spell"
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+RDEPEND="
+ >=dev-lang/mono-2.0
+ >=dev-dotnet/smartirc4net-0.4.5.1
+ >=dev-dotnet/nini-1.1.0-r2
+ >=dev-dotnet/log4net-1.2.10-r2
+ dbus? ( dev-dotnet/dbus-sharp
+ dev-dotnet/dbus-sharp-glib
+ dev-dotnet/ndesk-dbus
+ dev-dotnet/ndesk-dbus-glib )
+ gtk? ( >=dev-dotnet/gtk-sharp-2.12
+ >=dev-dotnet/glade-sharp-2.12
+ >=dev-dotnet/glib-sharp-2.12 )
+ libnotify? ( dev-dotnet/notify-sharp )
+ spell? ( >=app-text/gtkspell-2.0.9:2 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.25
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+DOCS=( FEATURES TODO README.md )
+
+src_configure() {
+ # Our dev-dotnet/db4o is completely unmaintained
+ # We don't have ubuntu stuff
+ econf \
+ --enable-engine-irc \
+ --without-indicate \
+ --with-vendor-package-version="Gentoo ${PV}" \
+ --with-db4o=included \
+ --with-messaging-menu=no \
+ --with-indicate=no \
+ $(use_enable debug) \
+ $(use_enable gtk frontend-gnome) \
+ $(use_with libnotify notify) \
+ $(use_with spell gtkspell)
+}