summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-08-19 11:43:49 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-08-19 11:43:49 +0000
commitd26d66ece50955a85996b0770a8054b2cfca2db0 (patch)
tree1def3af7e47d20c4a7b8746c6d670627d2bdc223 /net-irc
parentBump to 3.0.0, from gnome overlay for GNOME 3 (diff)
downloadgentoo-2-d26d66ece50955a85996b0770a8054b2cfca2db0.tar.gz
gentoo-2-d26d66ece50955a85996b0770a8054b2cfca2db0.tar.bz2
gentoo-2-d26d66ece50955a85996b0770a8054b2cfca2db0.zip
Fix initscript wrt ipv6. Patch by Diego (flameeyes). Fixes bug #379861.
(Portage version: 2.1.10.3/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/quassel/ChangeLog5
-rw-r--r--net-irc/quassel/files/quasselcore.init10
2 files changed, 8 insertions, 7 deletions
diff --git a/net-irc/quassel/ChangeLog b/net-irc/quassel/ChangeLog
index 1ac22204b0c8..03fcd0cc7bdf 100644
--- a/net-irc/quassel/ChangeLog
+++ b/net-irc/quassel/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-irc/quassel
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/ChangeLog,v 1.130 2011/08/18 12:51:34 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/ChangeLog,v 1.131 2011/08/19 11:43:49 scarabeus Exp $
+
+ 19 Aug 2011; Tomáš Chvátal <scarabeus@gentoo.org> files/quasselcore.init:
+ Fix initscript wrt ipv6. Patch by Diego (flameeyes). Fixes bug #379861.
18 Aug 2011; Tomáš Chvátal <scarabeus@gentoo.org> quassel-9999.ebuild:
Use proper function name (sync with 0.7.2).
diff --git a/net-irc/quassel/files/quasselcore.init b/net-irc/quassel/files/quasselcore.init
index e1059e791f04..58aedfa53649 100644
--- a/net-irc/quassel/files/quasselcore.init
+++ b/net-irc/quassel/files/quasselcore.init
@@ -1,7 +1,7 @@
#!/sbin/runscript
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/files/quasselcore.init,v 1.7 2010/11/04 14:22:45 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/files/quasselcore.init,v 1.8 2011/08/19 11:43:49 scarabeus Exp $
depend() {
need localmount net
@@ -16,9 +16,7 @@ QUASSEL_USER=${QUASSEL_USER:-"quassel"}
checkconfig() {
# set defaults
- LISTEN=${LISTEN:-"0.0.0.0"}
LOGLEVEL=${LOGLEVEL:-"Info"}
- PORT=${PORT:-"4242"}
# check config folder
if [ ! -d "${CONFIGDIR}" ]; then
@@ -45,14 +43,14 @@ start() {
start-stop-daemon --start --user "${QUASSEL_USER}" --background --make-pidfile \
--pidfile "${PID}" \
--exec "${CORE}" -- --logfile="${LOGFILE}" --loglevel="${LOGLEVEL}" \
- --listen="${LISTEN}" --port="${PORT}" \
+ ${LISTEN:+--listen="${LISTEN}"} ${PORT:+--port="${PORT}"} \
--configdir="${CONFIGDIR}"
else
# running on baselayout-1
start-stop-daemon --start --chuid "${QUASSEL_USER}" --background --make-pidfile \
--pidfile "${PID}" --env HOME="${CONFIGDIR}" \
--exec "${CORE}" -- --logfile="${LOGFILE}" --loglevel="${LOGLEVEL}" \
- --listen="${LISTEN}" --port="${PORT}" \
+ ${LISTEN:+--listen="${LISTEN}"} ${PORT:+--port="${PORT}"} \
--configdir="${CONFIGDIR}"
fi
eend $?