summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-04-03 18:10:31 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-04-03 18:10:31 +0000
commitd1e6716a970a09e11421ffbe0c69d7a22b34ec9b (patch)
tree51ea13f7da14912642d610ad4da3350a9e22080f /net-irc
parentVersion bump (bug #464248). (diff)
downloadgentoo-2-d1e6716a970a09e11421ffbe0c69d7a22b34ec9b.tar.gz
gentoo-2-d1e6716a970a09e11421ffbe0c69d7a22b34ec9b.tar.bz2
gentoo-2-d1e6716a970a09e11421ffbe0c69d7a22b34ec9b.zip
version bump
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/hexchat/ChangeLog8
-rw-r--r--net-irc/hexchat/files/hexchat-2.9.5-cflags.patch23
-rw-r--r--net-irc/hexchat/files/hexchat-2.9.5-gettextize.patch27
-rw-r--r--net-irc/hexchat/hexchat-2.9.5.ebuild138
4 files changed, 195 insertions, 1 deletions
diff --git a/net-irc/hexchat/ChangeLog b/net-irc/hexchat/ChangeLog
index 7e3263e203d9..1e7826f111a0 100644
--- a/net-irc/hexchat/ChangeLog
+++ b/net-irc/hexchat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/hexchat
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/hexchat/ChangeLog,v 1.38 2013/04/03 17:48:51 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/hexchat/ChangeLog,v 1.39 2013/04/03 18:10:31 hasufell Exp $
+
+*hexchat-2.9.5 (03 Apr 2013)
+
+ 03 Apr 2013; Julian Ospald <hasufell@gentoo.org> +hexchat-2.9.5.ebuild,
+ +files/hexchat-2.9.5-cflags.patch, +files/hexchat-2.9.5-gettextize.patch:
+ version bump
*hexchat-2.9.4-r2 (03 Apr 2013)
diff --git a/net-irc/hexchat/files/hexchat-2.9.5-cflags.patch b/net-irc/hexchat/files/hexchat-2.9.5-cflags.patch
new file mode 100644
index 000000000000..7b5c13826c67
--- /dev/null
+++ b/net-irc/hexchat/files/hexchat-2.9.5-cflags.patch
@@ -0,0 +1,23 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Wed Apr 3 17:55:10 UTC 2013
+Subject: build system
+
+respect system CFLAGS
+
+--- hexchat-2.9.5/configure.ac
++++ hexchat-2.9.5/configure.ac
+@@ -807,14 +807,6 @@
+ if test -z "`echo "$CFLAGS" | grep "\-Wall" 2> /dev/null`" ; then
+ CFLAGS="$CFLAGS -Wall"
+ fi
+- if test "$system" = "Linux" -o "$system" = "FreeBSD"; then
+- if test -z "`echo "$CFLAGS" | grep "\-pipe" 2> /dev/null`" ; then
+- CFLAGS="$CFLAGS -pipe"
+- fi
+- fi
+- if test -z "`echo "$CFLAGS" | grep "\-g " 2> /dev/null`" ; then
+- CFLAGS="$CFLAGS -g"
+- fi
+ fi
+
+ dnl does this compiler support -Wno-pointer-sign ?
diff --git a/net-irc/hexchat/files/hexchat-2.9.5-gettextize.patch b/net-irc/hexchat/files/hexchat-2.9.5-gettextize.patch
new file mode 100644
index 000000000000..1bed75b89cf4
--- /dev/null
+++ b/net-irc/hexchat/files/hexchat-2.9.5-gettextize.patch
@@ -0,0 +1,27 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Wed Apr 3 17:52:09 UTC 2013
+Subject: build system
+
+allow gettextizing properly
+
+--- hexchat-2.9.5/configure.ac
++++ hexchat-2.9.5/configure.ac
+@@ -968,8 +968,6 @@
+ plugins/doat/Makefile
+ plugins/fishlim/Makefile
+ plugins/sysinfo/Makefile
+-intl/Makefile
+-po/Makefile.in
+ man/Makefile
+ ])
+ dnl plugins/tcl/Makefile
+--- hexchat-2.9.5/Makefile.am
++++ hexchat-2.9.5/Makefile.am
+@@ -1,6 +1,6 @@
+ ## Process this file with automake to produce Makefile.in
+
+-SUBDIRS = po intl src plugins man share
++SUBDIRS = po src plugins man share
+
+ EXTRA_DIST = autogen.sh
+
diff --git a/net-irc/hexchat/hexchat-2.9.5.ebuild b/net-irc/hexchat/hexchat-2.9.5.ebuild
new file mode 100644
index 000000000000..c99ed323c4ec
--- /dev/null
+++ b/net-irc/hexchat/hexchat-2.9.5.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/hexchat/hexchat-2.9.5.ebuild,v 1.1 2013/04/03 18:10:31 hasufell Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
+inherit autotools eutils gnome2-utils mono multilib python-single-r1
+
+DESCRIPTION="Graphical IRC client based on XChat"
+SRC_URI="mirror://github/${PN}/${PN}/${P}.tar.xz"
+HOMEPAGE="http://www.hexchat.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
+IUSE="dbus fastscroll +gtk ipv6 libnotify libproxy nls ntlm perl +plugins plugin-checksum plugin-doat plugin-fishlim plugin-sysinfo python spell ssl theme-manager"
+REQUIRED_USE="plugin-checksum? ( plugins )
+ plugin-doat? ( plugins )
+ plugin-fishlim? ( plugins )
+ plugin-sysinfo? ( plugins )"
+
+RDEPEND="dev-libs/glib:2
+ dbus? ( >=dev-libs/dbus-glib-0.98 )
+ fastscroll? ( x11-libs/libXft )
+ gtk? ( x11-libs/gtk+:2 )
+ libproxy? ( net-libs/libproxy )
+ libnotify? ( x11-libs/libnotify )
+ nls? ( virtual/libintl )
+ ntlm? ( net-libs/libntlm )
+ perl? ( >=dev-lang/perl-5.8.0 )
+ plugin-sysinfo? ( sys-apps/pciutils )
+ python? ( ${PYTHON_DEPS} )
+ spell? ( dev-libs/libxml2 )
+ ssl? ( >=dev-libs/openssl-0.9.8u )
+ theme-manager? ( dev-lang/mono )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ theme-manager? ( dev-util/monodevelop )"
+
+DOCS=""
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-2.9.1-input-box.patch \
+ "${FILESDIR}"/${PN}-2.9.5-cflags.patch \
+ "${FILESDIR}"/${PN}-2.9.5-gettextize.patch
+
+ cp $(type -p gettextize) "${T}"/ || die
+ sed -i -e 's:read dummy < /dev/tty::' "${T}/gettextize" || die
+ einfo "Running gettextize -f --no-changelog..."
+ "${T}"/gettextize -f --no-changelog > /dev/null || die "gettexize failed"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable libproxy socks) \
+ $(use_enable ipv6) \
+ $(use_enable fastscroll xft) \
+ $(use_enable ssl openssl) \
+ $(use_enable gtk gtkfe) \
+ $(use_enable !gtk textfe) \
+ $(usex python "--enable-python=${EPYTHON}" "--disable-python") \
+ $(use_enable perl) \
+ $(use_enable plugins plugin) \
+ $(use_enable plugin-checksum checksum) \
+ $(use_enable plugin-doat doat) \
+ $(use_enable plugin-fishlim fishlim) \
+ $(use_enable plugin-sysinfo sysinfo) \
+ $(use_enable dbus) \
+ $(use_enable libnotify) \
+ --enable-shm \
+ $(use_enable spell spell static) \
+ $(use_enable ntlm) \
+ $(use_enable libproxy)
+}
+
+src_compile() {
+ default
+ if use theme-manager ; then
+ export XDG_CACHE_HOME="${T}/.cache"
+ cd src/htm || die
+ mdtool --verbose build htm-mono.csproj || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" UPDATE_ICON_CACHE=true install
+ dodoc share/doc/{readme,hacking}.md
+ use plugin-fishlim && dodoc share/doc/fishlim.md
+ if use theme-manager ; then
+ dobin src/htm/thememan.exe
+ make_wrapper thememan "mono /usr/bin/thememan.exe"
+ fi
+ prune_libtool_files --all
+}
+
+pkg_preinst() {
+ if use gtk ; then
+ gnome2_icon_savelist
+ gnome2_gconf_savelist
+ fi
+}
+
+pkg_postinst() {
+ if use !gtk ; then
+ einfo
+ elog "You have disabled the gtk USE flag. This means you don't have"
+ elog "the GTK-GUI for HexChat but only a text interface called \"hexchat-text\"."
+ else
+ gnome2_icon_cache_update
+ gnome2_gconf_install
+ fi
+
+ if use theme-manager ; then
+ einfo
+ elog "Themes are available at:"
+ elog " http://hexchat.org/themes.html"
+ fi
+
+ ewarn
+ ewarn "If you're upgrading from hexchat <=2.9.3 remember to rename"
+ ewarn "the xchat.conf file found in ~/.config/hexchat/ to hexchat.conf"
+ ewarn
+}
+
+pkg_postrm() {
+ if use gtk ; then
+ gnome2_icon_cache_update
+ fi
+}