summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2006-10-26 20:47:46 +0000
committerMarkus Ullmann <jokey@gentoo.org>2006-10-26 20:47:46 +0000
commitc3010dca6d57dc40c8a9394cdf9a4d816345fd05 (patch)
tree2d85699e9a79c51973a7e640151894dc256e4814 /net-irc
parent2.14.0 deps on mozilla too... (diff)
downloadgentoo-2-c3010dca6d57dc40c8a9394cdf9a4d816345fd05.tar.gz
gentoo-2-c3010dca6d57dc40c8a9394cdf9a4d816345fd05.tar.bz2
gentoo-2-c3010dca6d57dc40c8a9394cdf9a4d816345fd05.zip
Security version bump
(Portage version: 2.1.2_pre3-r9)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/anope/ChangeLog7
-rw-r--r--net-irc/anope/anope-1.7.17.ebuild137
-rw-r--r--net-irc/anope/files/digest-anope-1.7.173
3 files changed, 146 insertions, 1 deletions
diff --git a/net-irc/anope/ChangeLog b/net-irc/anope/ChangeLog
index a38f0774bbc6..50637496c95e 100644
--- a/net-irc/anope/ChangeLog
+++ b/net-irc/anope/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/anope
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/anope/ChangeLog,v 1.1 2006/08/29 22:54:17 gurligebis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/anope/ChangeLog,v 1.2 2006/10/26 20:47:46 jokey Exp $
+
+*anope-1.7.17 (26 Oct 2006)
+
+ 26 Oct 2006; Markus Ullmann <jokey@gentoo.org> +anope-1.7.17.ebuild:
+ Security version bump
*anope-1.7.15 (29 Aug 2006)
diff --git a/net-irc/anope/anope-1.7.17.ebuild b/net-irc/anope/anope-1.7.17.ebuild
new file mode 100644
index 000000000000..9b65776e32a6
--- /dev/null
+++ b/net-irc/anope/anope-1.7.17.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/anope/anope-1.7.17.ebuild,v 1.1 2006/10/26 20:47:46 jokey Exp $
+
+inherit eutils
+
+DESCRIPTION="Anope IRC Services"
+HOMEPAGE="http://www.anope.org"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="mysql"
+
+DEPEND="mysql? ( dev-db/mysql )"
+
+INSTALL_DIR="/opt/anope"
+
+pkg_setup() {
+ enewgroup anope
+ enewuser anope -1 -1 ${INSTALL_DIR} anope
+}
+
+src_compile() {
+ local myconf
+ if ! use mysql; then
+ myconf="${myconf} --without-mysql"
+ fi
+ #Threads cant be disabled currently
+ #if ! use threads; then
+ # myconf="${myconf} --without-threads"
+ #fi
+
+ epatch ${FILESDIR}/pid-patch.diff
+
+ econf \
+ ${myconf} \
+ --bindir ${INSTALL_DIR} \
+ --with-bindir=${INSTALL_DIR} \
+ --with-datadir=${INSTALL_DIR}/data \
+ --with-modules=${INSTALL_DIR}/modules \
+ --with-encryption \
+ --with-rungroup=anope \
+ --with-permissions=077 \
+ || die "Configuration failed."
+
+ sed -i -e "/^build:/s:$: language:g" "${S}"/Makefile || die "sed failed"
+
+ emake || die "Make failed."
+}
+
+src_install() {
+ dodir ${INSTALL_DIR}
+ dodir ${INSTALL_DIR}/data
+ dodir ${INSTALL_DIR}/data/logs
+ dodir ${INSTALL_DIR}/data/languages
+ dodir ${INSTALL_DIR}/data/modules
+ dodir ${INSTALL_DIR}/data/modules/runtime
+ dodir ${INSTALL_DIR}/modules
+
+ dodir /var/run/anope
+ fowners anope:anope /var/run/anope
+ keepdir /var/run/anope
+
+ fowners anope:anope ${INSTALL_DIR}
+ fowners anope:anope ${INSTALL_DIR}/data
+ fowners anope:anope ${INSTALL_DIR}/data/logs
+ fowners anope:anope ${INSTALL_DIR}/data/languages
+ fowners anope:anope ${INSTALL_DIR}/data/modules
+ fowners anope:anope ${INSTALL_DIR}/data/modules/runtime
+ fowners anope:anope ${INSTALL_DIR}/modules
+
+ exeinto ${INSTALL_DIR}
+ doexe src/services
+ insinto ${INSTALL_DIR}/data
+ newins data/example.conf services.conf
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/anope.initd anope
+ insinto /etc/conf.d
+ newins ${FILESDIR}/anope.confd anope
+
+ insinto ${INSTALL_DIR}/modules
+ doins src/modules/*.so
+
+ keepdir ${INSTALL_DIR}/data/logs
+
+ insinto ${INSTALL_DIR}/data/languages
+ doins lang/cat
+ doins lang/de
+ doins lang/en_us
+ doins lang/es
+ doins lang/fr
+ doins lang/gr
+ doins lang/hun
+ doins lang/it
+ doins lang/nl
+ doins lang/pl
+ doins lang/pt
+ doins lang/ru
+ doins lang/tr
+
+ keepdir ${INSTALL_DIR}/data/modules/runtime
+
+ insinto ${INSTALL_DIR}/data/modules
+ doins src/protocol/*.so
+ doins src/core/*.so
+
+ fowners anope:anope ${INSTALL_DIR}/services
+ fowners anope:anope ${INSTALL_DIR}/data/services.conf
+ fowners anope:anope ${INSTALL_DIR}/data/languages/cat
+ fowners anope:anope ${INSTALL_DIR}/data/languages/de
+ fowners anope:anope ${INSTALL_DIR}/data/languages/en_us
+ fowners anope:anope ${INSTALL_DIR}/data/languages/fr
+ fowners anope:anope ${INSTALL_DIR}/data/languages/gr
+ fowners anope:anope ${INSTALL_DIR}/data/languages/hun
+ fowners anope:anope ${INSTALL_DIR}/data/languages/it
+ fowners anope:anope ${INSTALL_DIR}/data/languages/nl
+ fowners anope:anope ${INSTALL_DIR}/data/languages/pl
+ fowners anope:anope ${INSTALL_DIR}/data/languages/pt
+ fowners anope:anope ${INSTALL_DIR}/data/languages/ru
+ fowners anope:anope ${INSTALL_DIR}/data/languages/tr
+
+ dodoc Changes Changes.conf Changes.lang Changes.mysql docs/*
+}
+
+pkg_postinst() {
+ echo
+ ewarn "Anope won't run out of the box, you still have to configure it to match your IRCDs configuration."
+ ewarn "Edit ${INSTALL_DIR}/data/services.conf to configure Anope."
+ echo
+ ewarn "!!! ATTENTION !!!"
+ ewarn "If you had used 1.7.15 before, be sure to read Changes.mysql to update your MySQL"
+ ewarn "tables or anope will break after restart"
+ ewarn "!!! ATTENTION !!!"
+}
diff --git a/net-irc/anope/files/digest-anope-1.7.17 b/net-irc/anope/files/digest-anope-1.7.17
new file mode 100644
index 000000000000..30df917382d1
--- /dev/null
+++ b/net-irc/anope/files/digest-anope-1.7.17
@@ -0,0 +1,3 @@
+MD5 ff8f546fe4e3da7fcb3f920f2c337e36 anope-1.7.17.tar.gz 1471230
+RMD160 50edae6c22311aada6e2fdfd56a1cd7781143c5a anope-1.7.17.tar.gz 1471230
+SHA256 2f1712103fcf0343ee4cc811f258df6393fab73f2d6c2946f3dfbfaf48f1a4e4 anope-1.7.17.tar.gz 1471230