summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2006-06-30 13:12:59 +0000
committerMarkus Ullmann <jokey@gentoo.org>2006-06-30 13:12:59 +0000
commitbb2b6b55ff5799897fd42cf826c2a916d16ba88b (patch)
treedc41509d8a40db48878dcc55a609d7751db4bece /net-irc
parentStable on alpha wrt security Bug #135974. (diff)
downloadgentoo-2-bb2b6b55ff5799897fd42cf826c2a916d16ba88b.tar.gz
gentoo-2-bb2b6b55ff5799897fd42cf826c2a916d16ba88b.tar.bz2
gentoo-2-bb2b6b55ff5799897fd42cf826c2a916d16ba88b.zip
Version bump wrt bug #138298
(Portage version: 2.1.1_pre1-r5)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat-gnome/ChangeLog7
-rw-r--r--net-irc/xchat-gnome/files/digest-xchat-gnome-0.123
-rw-r--r--net-irc/xchat-gnome/xchat-gnome-0.12.ebuild82
3 files changed, 91 insertions, 1 deletions
diff --git a/net-irc/xchat-gnome/ChangeLog b/net-irc/xchat-gnome/ChangeLog
index 7d9884aaf71f..e32e16f665ff 100644
--- a/net-irc/xchat-gnome/ChangeLog
+++ b/net-irc/xchat-gnome/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/xchat-gnome
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-gnome/ChangeLog,v 1.21 2006/04/20 20:13:43 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-gnome/ChangeLog,v 1.22 2006/06/30 13:12:59 jokey Exp $
+
+*xchat-gnome-0.12 (30 Jun 2006)
+
+ 30 Jun 2006; Markus Ullmann <jokey@gentoo.org> +xchat-gnome-0.12.ebuild:
+ Version bump wrt bug #138298
20 Apr 2006; Sven Wegener <swegener@gentoo.org>
+files/0.10-libnotify-libsexy-configure.patch, +xchat-gnome-0.10.ebuild,
diff --git a/net-irc/xchat-gnome/files/digest-xchat-gnome-0.12 b/net-irc/xchat-gnome/files/digest-xchat-gnome-0.12
new file mode 100644
index 000000000000..054b1ff3a83f
--- /dev/null
+++ b/net-irc/xchat-gnome/files/digest-xchat-gnome-0.12
@@ -0,0 +1,3 @@
+MD5 414ab6d9ddd1c436e01cbab33a5dba15 xchat-gnome-0.12.tar.bz2 1301237
+RMD160 dfddfa11638e1bf06ed036433bd007415f2c1741 xchat-gnome-0.12.tar.bz2 1301237
+SHA256 6626ac2f979995b4d357156a4a74795eeec3895f50df3be1d9a5fb11527f2fb1 xchat-gnome-0.12.tar.bz2 1301237
diff --git a/net-irc/xchat-gnome/xchat-gnome-0.12.ebuild b/net-irc/xchat-gnome/xchat-gnome-0.12.ebuild
new file mode 100644
index 000000000000..51102ed94c21
--- /dev/null
+++ b/net-irc/xchat-gnome/xchat-gnome-0.12.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-gnome/xchat-gnome-0.12.ebuild,v 1.1 2006/06/30 13:12:59 jokey Exp $
+
+inherit gnome2 eutils autotools
+
+DESCRIPTION="GNOME frontend for the popular X-Chat IRC client"
+HOMEPAGE="http://xchat-gnome.navi.cx/"
+SRC_URI="http://releases.navi.cx/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="perl tcltk python ssl mmx ipv6 nls dbus libsexy libnotify spell"
+
+RDEPEND=">=dev-libs/glib-2.8.0
+ >=gnome-base/libgnome-2.13
+ >=gnome-base/gconf-2.8.0
+ >=gnome-base/libgnomeui-2.6.0
+ >=gnome-base/libglade-2.3.0
+ >=gnome-base/gnome-vfs-2.9.2
+ >=x11-libs/gtk+-2.8.0
+ spell? ( app-text/gtkspell )
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ perl? ( >=dev-lang/perl-5.6.1 )
+ python? ( dev-lang/python )
+ tcltk? ( dev-lang/tcl )
+ dbus? ( >=sys-apps/dbus-0.35 )
+ libsexy? ( >=x11-libs/libsexy-0.1.7 )
+ libnotify? ( >=x11-libs/libnotify-0.3.2 )"
+
+DEPEND="${RDEPEND}
+ gnome-base/gnome-common
+ >=dev-util/pkgconfig-0.7
+ >=app-text/gnome-doc-utils-0.3.2
+ nls? ( sys-devel/gettext )"
+
+# gnome-base/gnome-common is temporarily needed for re-creating configure
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/0.11-libnotify-libsexy-configure.patch
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ econf \
+ --enable-gnomefe \
+ --enable-shm \
+ --disable-schemas-install \
+ --disable-scrollkeeper \
+ $(use_enable ssl openssl) \
+ $(use_enable perl) \
+ $(use_enable python) \
+ $(use_enable tcltk tcl) \
+ $(use_enable mmx) \
+ $(use_enable ipv6) \
+ $(use_enable dbus) \
+ $(use_enable nls) \
+ $(use_enable libsexy) \
+ $(use_enable libnotify) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ USE_DESTDIR="1" gnome2_src_install || die "gnome2_src_install failed"
+
+ # install plugin development header
+ insinto /usr/include/xchat-gnome
+ doins src/common/xchat-plugin.h || die "doins failed"
+
+ dodoc AUTHORS ChangeLog NEWS || die "dodoc failed"
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+ gnome2_scrollkeeper_update
+}