summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2009-07-31 18:51:29 +0000
committerAlex Legler <a3li@gentoo.org>2009-07-31 18:51:29 +0000
commitb9ea83dd02678b41d6ae60832a8a22e726fb4f30 (patch)
tree33c12ed9f7d5026abbf6d5cc4c5cfdb57a5e3125 /net-irc
parentForgot to commit this... (diff)
downloadgentoo-2-b9ea83dd02678b41d6ae60832a8a22e726fb4f30.tar.gz
gentoo-2-b9ea83dd02678b41d6ae60832a8a22e726fb4f30.tar.bz2
gentoo-2-b9ea83dd02678b41d6ae60832a8a22e726fb4f30.zip
Version bump, remove old, fix configure. Thanks, diego.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/bip/ChangeLog9
-rw-r--r--net-irc/bip/bip-0.7.4-r1.ebuild46
-rw-r--r--net-irc/bip/bip-0.8.1.ebuild (renamed from net-irc/bip/bip-0.8.0_rc1.ebuild)26
-rw-r--r--net-irc/bip/files/bip-0.8.1-configure-oidentd.patch19
4 files changed, 46 insertions, 54 deletions
diff --git a/net-irc/bip/ChangeLog b/net-irc/bip/ChangeLog
index fb7ee9ec1ac7..40bd7dd8b6cf 100644
--- a/net-irc/bip/ChangeLog
+++ b/net-irc/bip/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-irc/bip
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bip/ChangeLog,v 1.6 2009/03/23 15:58:15 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bip/ChangeLog,v 1.7 2009/07/31 18:51:29 a3li Exp $
+
+*bip-0.8.1 (31 Jul 2009)
+
+ 31 Jul 2009; Alex Legler <a3li@gentoo.org> -bip-0.7.4-r1.ebuild,
+ -bip-0.8.0_rc1.ebuild, +bip-0.8.1.ebuild,
+ +files/bip-0.8.1-configure-oidentd.patch:
+ Version bump, removing old versions, fix configure (thanks to flameeyes)
*bip-0.8.0 (23 Mar 2009)
diff --git a/net-irc/bip/bip-0.7.4-r1.ebuild b/net-irc/bip/bip-0.7.4-r1.ebuild
deleted file mode 100644
index 4dad7e284e53..000000000000
--- a/net-irc/bip/bip-0.7.4-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bip/bip-0.7.4-r1.ebuild,v 1.1 2008/10/10 12:06:29 hawking Exp $
-
-DESCRIPTION="Multiuser IRC proxy with ssl support"
-HOMEPAGE="http://bip.t1r.net/"
-SRC_URI="http://bip.t1r.net/downloads/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="ssl vim-syntax"
-
-DEPEND="ssl? ( dev-libs/openssl )"
-RDEPEND="${DEPEND}
- vim-syntax? ( || ( app-editors/vim
- app-editors/gvim ) )"
-
-src_compile() {
- econf $(use_enable ssl)
- # Parallel make fails.
- # {C,CXX,LD}FLAGS aren't respected, bug 241030.
- emake CFLAGS="${CFLAGS}" CPPFLAGS="${CXXFLAGS}" \
- LDFLAGS="${LDFLAGS}" -j1 || die "emake failed"
-}
-
-src_install() {
- dobin src/bip src/bipmkpw || die "dobin failed"
-
- dodoc AUTHORS ChangeLog README NEWS TODO || die "dodoc failed"
- newdoc samples/bip.conf bip.conf.sample || die "newdoc failed"
- doman bip.1 bip.conf.5 bipmkpw.1 || die "doman failed"
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles/syntax
- doins samples/bip.vim || die "doins failed"
- insinto /usr/share/vim/vimfiles/ftdetect
- doins "${FILESDIR}"/bip.vim || die "doins failed"
- fi
-}
-
-pkg_postinst() {
- elog 'Default configuration file is "~/.bip/bip.conf"'
- elog "You can find a sample configuration file in"
- elog "/usr/share/doc/${PF}/bip.conf.sample"
-}
diff --git a/net-irc/bip/bip-0.8.0_rc1.ebuild b/net-irc/bip/bip-0.8.1.ebuild
index e422c2a00e0d..4af1a2ba8619 100644
--- a/net-irc/bip/bip-0.8.0_rc1.ebuild
+++ b/net-irc/bip/bip-0.8.1.ebuild
@@ -1,18 +1,19 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/bip/bip-0.8.0_rc1.ebuild,v 1.1 2009/02/23 22:47:21 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/bip/bip-0.8.1.ebuild,v 1.1 2009/07/31 18:51:29 a3li Exp $
-MY_PV="${PV/_rc/-rc}"
-MY_P="${PN}-${MY_PV}"
+EAPI="2"
+
+inherit autotools
DESCRIPTION="Multiuser IRC proxy with ssl support"
HOMEPAGE="http://bip.t1r.net/"
-SRC_URI="http://bip.t1r.net/downloads/${MY_P}.tar.gz"
+SRC_URI="http://bip.t1r.net/downloads/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="ssl vim-syntax oidentd"
+IUSE="debug ssl vim-syntax oidentd"
DEPEND="ssl? ( dev-libs/openssl )"
RDEPEND="${DEPEND}
@@ -20,10 +21,21 @@ RDEPEND="${DEPEND}
app-editors/gvim ) )
oidentd? ( >=net-misc/oidentd-2.0 )"
-S="${WORKDIR}/${MY_P}"
+src_prepare() {
+ # configure broken: --disable-oidentd enables it, too
+ epatch "${FILESDIR}/${P}-configure-oidentd.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable ssl openssl)\
+ $(use_enable debug)\
+ $(use_enable oidentd)
+}
src_compile() {
- econf $(use_enable ssl) $(use_enable oidentd)
# Parallel make fails.
# {C,CXX,LD}FLAGS aren't respected, bug 241030.
emake CFLAGS="${CFLAGS}" CPPFLAGS="${CXXFLAGS}" \
diff --git a/net-irc/bip/files/bip-0.8.1-configure-oidentd.patch b/net-irc/bip/files/bip-0.8.1-configure-oidentd.patch
new file mode 100644
index 000000000000..787129981658
--- /dev/null
+++ b/net-irc/bip/files/bip-0.8.1-configure-oidentd.patch
@@ -0,0 +1,19 @@
+--- a/configure.in 2009-07-17 11:43:29.000000000 +0200
++++ b/configure.in 2009-07-31 20:30:58.450934716 +0200
+@@ -36,11 +36,14 @@
+
+ AC_ARG_ENABLE(oidentd,
+ [ --enable-oidentd Enable oidentd support (bip overwrites ~/.oidentd.conf with this on!)],
+- enable_oidentd=yes
+- AC_DEFINE([HAVE_OIDENTD], [], [Enable oidentd.conf management support]),
++ ,
+ [enable_oidentd=no]
+ )
+
++if test "x$enable_oidentd" = "xyes"; then
++ AC_DEFINE([HAVE_OIDENTD], [], [Enable oidentd.conf management support])
++fi
++
+ AM_CONDITIONAL(OIDENTD, test x$enable_identd = xyes)
+
+ AC_ARG_ENABLE(openssl,