summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-04-05 21:20:02 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-04-05 21:20:02 +0000
commitb03b01e2df08763fb16699513aee24249720d94a (patch)
treeb35196691e67db3a3eeba82f957f77c0667c931c /net-irc
parentx86 stable, bug #251832 (diff)
downloadgentoo-2-b03b01e2df08763fb16699513aee24249720d94a.tar.gz
gentoo-2-b03b01e2df08763fb16699513aee24249720d94a.tar.bz2
gentoo-2-b03b01e2df08763fb16699513aee24249720d94a.zip
Fix bug 259434, smuxi enters an infinite loop when compiling on milli-second-precision FSes, suchs as tmpfs or XFS.
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/smuxi/ChangeLog7
-rw-r--r--net-irc/smuxi/files/smuxi-0.6.3-infinite-loop.patch76
-rw-r--r--net-irc/smuxi/smuxi-0.6.3.ebuild5
3 files changed, 85 insertions, 3 deletions
diff --git a/net-irc/smuxi/ChangeLog b/net-irc/smuxi/ChangeLog
index dd8ec44dcc44..6a20272af4fe 100644
--- a/net-irc/smuxi/ChangeLog
+++ b/net-irc/smuxi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/smuxi
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/smuxi/ChangeLog,v 1.1 2009/01/31 22:19:26 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/smuxi/ChangeLog,v 1.2 2009/04/05 21:20:02 loki_val Exp $
+
+ 05 Apr 2009; Peter Alfredsen <loki_val@gentoo.org>
+ +files/smuxi-0.6.3-infinite-loop.patch, smuxi-0.6.3.ebuild:
+ Fix bug 259434, smuxi enters an infinite loop when compiling on
+ milli-second-precision FSes, suchs as tmpfs or XFS.
*smuxi-0.6.3 (31 Jan 2009)
diff --git a/net-irc/smuxi/files/smuxi-0.6.3-infinite-loop.patch b/net-irc/smuxi/files/smuxi-0.6.3-infinite-loop.patch
new file mode 100644
index 000000000000..7ff07123ebdf
--- /dev/null
+++ b/net-irc/smuxi/files/smuxi-0.6.3-infinite-loop.patch
@@ -0,0 +1,76 @@
+From: Mirco Bauer <meebey@meebey.net>
+Date: Sun, 5 Apr 2009 20:34:13 +0000 (+0200)
+Subject: set subdir variable to "po" in all po-*/Makefile.in.in files
+X-Git-Url: http://git.qnetp.net/?p=smuxi.git;a=commitdiff_plain;h=81669b0fcb404562d9d0da99d9605b3f64c07af2
+
+set subdir variable to "po" in all po-*/Makefile.in.in files
+
+This doesn't really make sense to me as that causes to always stamp the same file (po/stamp-it) instead of each po directory, but this is how intltoolize wants it.
+At the same time this finally fixes the endless build loop if the source files are laying on xfs or tmpfs (which support more precise timestamps). (closes: #156)
+---
+
+diff --git a/po-Engine-IRC/Makefile.in.in b/po-Engine-IRC/Makefile.in.in
+index 27268fc..3add1c1 100644
+--- a/po-Engine-IRC/Makefile.in.in
++++ b/po-Engine-IRC/Makefile.in.in
+@@ -35,7 +35,7 @@ datarootdir = @datarootdir@
+ libdir = @libdir@
+ DATADIRNAME = @DATADIRNAME@
+ itlocaledir = $(prefix)/$(DATADIRNAME)/locale
+-subdir = po-Engine-IRC
++subdir = po
+ install_sh = @install_sh@
+ # Automake >= 1.8 provides @mkdir_p@.
+ # Until it can be supposed, use the safe fallback:
+diff --git a/po-Engine/Makefile.in.in b/po-Engine/Makefile.in.in
+index b84aa3a..2ec381e 100644
+--- a/po-Engine/Makefile.in.in
++++ b/po-Engine/Makefile.in.in
+@@ -35,7 +35,7 @@ datarootdir = @datarootdir@
+ libdir = @libdir@
+ DATADIRNAME = @DATADIRNAME@
+ itlocaledir = $(prefix)/$(DATADIRNAME)/locale
+-subdir = po-Engine
++subdir = po
+ install_sh = @install_sh@
+ # Automake >= 1.8 provides @mkdir_p@.
+ # Until it can be supposed, use the safe fallback:
+diff --git a/po-Frontend-GNOME-IRC/Makefile.in.in b/po-Frontend-GNOME-IRC/Makefile.in.in
+index 70d5713..5f70427 100644
+--- a/po-Frontend-GNOME-IRC/Makefile.in.in
++++ b/po-Frontend-GNOME-IRC/Makefile.in.in
+@@ -35,7 +35,7 @@ datarootdir = @datarootdir@
+ libdir = @libdir@
+ DATADIRNAME = @DATADIRNAME@
+ itlocaledir = $(prefix)/$(DATADIRNAME)/locale
+-subdir = po-Frontend-GNOME-IRC
++subdir = po
+ install_sh = @install_sh@
+ # Automake >= 1.8 provides @mkdir_p@.
+ # Until it can be supposed, use the safe fallback:
+diff --git a/po-Frontend-GNOME/Makefile.in.in b/po-Frontend-GNOME/Makefile.in.in
+index 1e74fca..9567482 100644
+--- a/po-Frontend-GNOME/Makefile.in.in
++++ b/po-Frontend-GNOME/Makefile.in.in
+@@ -35,7 +35,7 @@ datarootdir = @datarootdir@
+ libdir = @libdir@
+ DATADIRNAME = @DATADIRNAME@
+ itlocaledir = $(prefix)/$(DATADIRNAME)/locale
+-subdir = po-Frontend-GNOME
++subdir = po
+ install_sh = @install_sh@
+ # Automake >= 1.8 provides @mkdir_p@.
+ # Until it can be supposed, use the safe fallback:
+diff --git a/po-Server/Makefile.in.in b/po-Server/Makefile.in.in
+index 925fe32..edffc6e 100644
+--- a/po-Server/Makefile.in.in
++++ b/po-Server/Makefile.in.in
+@@ -35,7 +35,7 @@ datarootdir = @datarootdir@
+ libdir = @libdir@
+ DATADIRNAME = @DATADIRNAME@
+ itlocaledir = $(prefix)/$(DATADIRNAME)/locale
+-subdir = po-Server
++subdir = po
+ install_sh = @install_sh@
+ # Automake >= 1.8 provides @mkdir_p@.
+ # Until it can be supposed, use the safe fallback:
diff --git a/net-irc/smuxi/smuxi-0.6.3.ebuild b/net-irc/smuxi/smuxi-0.6.3.ebuild
index 27abdc7c0e43..cb820e153bb7 100644
--- a/net-irc/smuxi/smuxi-0.6.3.ebuild
+++ b/net-irc/smuxi/smuxi-0.6.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/smuxi/smuxi-0.6.3.ebuild,v 1.4 2009/02/01 11:21:41 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/smuxi/smuxi-0.6.3.ebuild,v 1.5 2009/04/05 21:20:02 loki_val Exp $
EAPI="2"
@@ -29,7 +29,8 @@ DEPEND="${RDEPEND}
>=sys-devel/gettext-0.17
>=dev-util/pkgconfig-0.23"
-PATCHES=( "${FILESDIR}/${P}-mono-2.2.patch" )
+PATCHES=( "${FILESDIR}/${P}-mono-2.2.patch"
+ "${FILESDIR}/${P}-infinite-loop.patch" )
src_configure() {
econf --disable-dependency-tracking \