summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2003-01-26 10:30:08 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2003-01-26 10:30:08 +0000
commit8c87940fc1c7c874da1dd6341af933716ea8d6ea (patch)
treed39523552a9d35e950033f97fed723a955b01c10 /net-irc
parentLittle cosmetic fix in ebuild (DEPEND section) (diff)
downloadgentoo-2-8c87940fc1c7c874da1dd6341af933716ea8d6ea.tar.gz
gentoo-2-8c87940fc1c7c874da1dd6341af933716ea8d6ea.tar.bz2
gentoo-2-8c87940fc1c7c874da1dd6341af933716ea8d6ea.zip
version bump to 2.0.0pre1
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/ChangeLog6
-rw-r--r--net-irc/xchat/files/digest-xchat-2.0.0_pre11
-rw-r--r--net-irc/xchat/xchat-2.0.0_pre1.ebuild85
3 files changed, 91 insertions, 1 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index 0e5fda6db8a5..212edf30345f 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/xchat
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.38 2003/01/23 14:45:00 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.39 2003/01/26 10:30:08 lordvan Exp $
+
+*xchat-2.0.0pre1 (26 Jan 2003)
+ 26 Jan 2003; Thomas Raschbacher <lordvan@gentoo.org> xchat-2.0.0_pre1.ebuild:
+ new version
*xchat-1.8.11 (23 Jan 2003)
diff --git a/net-irc/xchat/files/digest-xchat-2.0.0_pre1 b/net-irc/xchat/files/digest-xchat-2.0.0_pre1
new file mode 100644
index 000000000000..c37db253d95f
--- /dev/null
+++ b/net-irc/xchat/files/digest-xchat-2.0.0_pre1
@@ -0,0 +1 @@
+MD5 1aaa0477124897c4dcd26e8baba25226 xchat-2.0.0pre1.tar.bz2 875919
diff --git a/net-irc/xchat/xchat-2.0.0_pre1.ebuild b/net-irc/xchat/xchat-2.0.0_pre1.ebuild
new file mode 100644
index 000000000000..4b823eee9457
--- /dev/null
+++ b/net-irc/xchat/xchat-2.0.0_pre1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.0.0_pre1.ebuild,v 1.1 2003/01/26 10:30:08 lordvan Exp $
+
+inherit eutils
+
+IUSE="perl gnome ssl gtk python mmx ipv6 nls kde"
+S=${WORKDIR}/xchat-2.0.0pre1
+DESCRIPTION="X-Chat is a graphical IRC client for UNIX operating systems."
+SRC_URI="http://www.xchat.org/files/source/1.9/xchat-2.0.0pre1.tar.bz2"
+HOMEPAGE="http://www.xchat.org/"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+RDEPEND=">=dev-libs/glib-2.0.3
+ >=x11-libs/gtk+-2.0.3
+ perl? ( >=sys-devel/perl-5.6.1 )
+ gnome? ( >=gnome-base/libgnome-2.0 )
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ python? ( dev-lang/python )"
+
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.10.38 )"
+
+src_compile() {
+ local myopts myflags
+
+ if [ ! `use perl` ] ; then
+ use gnome \
+ && myopts="${myopts} --enable-gnome --enable-panel" \
+ || myopts="${myopts} --enable-gtkfe --disable-gnome --disable-zvt"
+
+ # use gnome \
+ # && CFLAGS="${CFLAGS} -I/usr/include/orbit-2.0" \
+ # || myopts="${myopts} --disable-gnome"
+ fi
+
+ use gtk \
+ && myopts="${myopts} --enable-gtkfe" \
+ || myopts="${myopts} --disable-gtkfe"
+ use ssl \
+ && myopts="${myopts} --enable-openssl" \
+ || myopts="${myopts} --disable-openssl"
+ use perl \
+ && myopts="${myopts} --enable-perl" \
+ || myopts="${myopts} --disable-perl"
+ use python \
+ && myopts="${myopts} --enable-python" \
+ || myopts="${myopts} --disable-python"
+ use nls \
+ && myopts="${myopts} --enable-nls" \
+ || myopts="${myopts} --disable-nls"
+ use mmx \
+ && myopts="${myopts} --enable-mmx" \
+ || myopts="${myopts} --disable-mmx"
+ use ipv6 \
+ && myopts="${myopts} --enable-ipv6" \
+ || myopts="${myopts} --disable-ipv6"
+
+# pango renderer standard now
+# [ -n "${DISABLE_XFT}" ] && myopts="${myopts} --disable-xft"
+
+ econf \
+ --program-suffix=-2 \
+ ${myopts} || die "Configure failed"
+
+ MAKEOPTS="-j1" emake || die "Compile failed"
+}
+
+src_install() {
+ # some magic to create a menu entry for xchat 2
+ mv xchat.desktop xchat.desktop.old
+ sed -e "s:Exec=xchat:Exec=xchat-2:" -e "s:Name=XChat IRC:Name=XChat 2 IRC:" xchat.desktop.old > xchat.desktop
+
+ einstall install || die "Install failed"
+
+ dodoc AUTHORS COPYING ChangeLog README
+}
+
+#pkg_postinst() {
+# einfo "If you want X-Chat to correctly display Hebrew (bidi) do "
+# einfo "'export DISABLE_XFT=1' and re-emerge xchat"
+#}