summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-03-12 12:52:19 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-03-12 12:52:19 +0000
commit77c35e5b985a47ac1a7c1307ddc427aeefbea141 (patch)
tree65b7a2fb2a403806c18af062e09babd7bfbbba22 /net-irc
parentVersion bumped, bug #309117. Fixed enbug, bug #299016. Removed old versions. (diff)
downloadgentoo-2-77c35e5b985a47ac1a7c1307ddc427aeefbea141.tar.gz
gentoo-2-77c35e5b985a47ac1a7c1307ddc427aeefbea141.tar.bz2
gentoo-2-77c35e5b985a47ac1a7c1307ddc427aeefbea141.zip
Revbump to fix plugin issue introduced with libdir fix.
(Portage version: 2.2_rc66/cvs/Linux i686)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/weechat/ChangeLog8
-rw-r--r--net-irc/weechat/weechat-0.3.1.1-r1.ebuild (renamed from net-irc/weechat/weechat-0.3.1.1.ebuild)11
2 files changed, 16 insertions, 3 deletions
diff --git a/net-irc/weechat/ChangeLog b/net-irc/weechat/ChangeLog
index 2b7d4208f4cd..52da63b795b7 100644
--- a/net-irc/weechat/ChangeLog
+++ b/net-irc/weechat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/weechat
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/ChangeLog,v 1.69 2010/03/11 10:31:15 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/ChangeLog,v 1.70 2010/03/12 12:52:19 scarabeus Exp $
+
+*weechat-0.3.1.1-r1 (12 Mar 2010)
+
+ 12 Mar 2010; Tomáš Chvátal <scarabeus@gentoo.org>
+ -weechat-0.3.1.1.ebuild, +weechat-0.3.1.1-r1.ebuild:
+ Revbump to fix plugin issue introduced with libdir fix.
*weechat-0.3.1.1 (11 Mar 2010)
diff --git a/net-irc/weechat/weechat-0.3.1.1.ebuild b/net-irc/weechat/weechat-0.3.1.1-r1.ebuild
index 116537a1a259..cd43af2292a4 100644
--- a/net-irc/weechat/weechat-0.3.1.1.ebuild
+++ b/net-irc/weechat/weechat-0.3.1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/weechat-0.3.1.1.ebuild,v 1.1 2010/03/11 10:31:15 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/weechat-0.3.1.1-r1.ebuild,v 1.1 2010/03/12 12:52:19 scarabeus Exp $
EAPI=2
inherit cmake-utils multilib
@@ -38,6 +38,14 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS ChangeLog NEWS README UPGRADE_0.3"
+src_prepare() {
+ # fix libdir placement
+ sed -i \
+ -e "s:lib/:$(get_libdir)/:g" \
+ -e "s:lib\":$(get_libdir)\":g" \
+ CMakeLists.txt || die "sed failed"
+}
+
src_configure() {
local x
@@ -48,7 +56,6 @@ src_configure() {
mycmakeargs="${mycmakeargs} $(cmake-utils_use_disable ${x/+/})"
fi
done
- mycmakeargs="${mycmakeargs} -DLIBDIR=$(get_libdir)"
cmake-utils_src_configure
}