summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-11-13 06:39:43 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-11-13 06:39:43 +0000
commit737988218f8847206319a0f229d0e9ac4afeb02c (patch)
tree7e06ebfdf8d5a42831c0207565ce27888dc30096 /net-irc
parentSplit doc building and compiling, resolving bug #442504 (diff)
downloadgentoo-2-737988218f8847206319a0f229d0e9ac4afeb02c.tar.gz
gentoo-2-737988218f8847206319a0f229d0e9ac4afeb02c.tar.bz2
gentoo-2-737988218f8847206319a0f229d0e9ac4afeb02c.zip
Bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/irker/ChangeLog7
-rw-r--r--net-irc/irker/irker-1.13.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/net-irc/irker/ChangeLog b/net-irc/irker/ChangeLog
index 915ea4db7434..e8bcf5ec33f1 100644
--- a/net-irc/irker/ChangeLog
+++ b/net-irc/irker/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/irker
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/irker/ChangeLog,v 1.6 2012/10/13 21:22:45 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irker/ChangeLog,v 1.7 2012/11/13 06:39:43 patrick Exp $
+
+*irker-1.13 (13 Nov 2012)
+
+ 13 Nov 2012; Patrick Lauer <patrick@gentoo.org> +irker-1.13.ebuild:
+ Bump
13 Oct 2012; Mike Gilbert <floppym@gentoo.org> irker-1.12-r1.ebuild:
Don't RDEPEND on xml documentation tools.
diff --git a/net-irc/irker/irker-1.13.ebuild b/net-irc/irker/irker-1.13.ebuild
new file mode 100644
index 000000000000..ee3fb284760d
--- /dev/null
+++ b/net-irc/irker/irker-1.13.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irker/irker-1.13.ebuild,v 1.1 2012/11/13 06:39:43 patrick Exp $
+
+EAPI=4
+
+inherit python
+
+DESCRIPTION="Submission tools for IRC notifications"
+HOMEPAGE="http://www.catb.org/esr/irker/"
+SRC_URI="http://www.catb.org/esr/${PN}/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="app-text/docbook-xml-dtd:4.1.2
+ app-text/xmlto"
+RDEPEND="=dev-lang/python-2*
+ dev-python/irc"
+
+src_install() {
+ python_convert_shebangs 2 irkerd irkerhook.py
+ emake DESTDIR="${D}" install
+ # the irkerhook.py is not installed with the default makefile
+ dobin irkerhook.py
+ newinitd "${FILESDIR}/irker.init" irkerd
+ newconfd "${FILESDIR}/irker.conf.d" irkerd
+}