summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-04-11 18:24:02 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-04-11 18:24:02 +0000
commit729d6262d6e3bdf7e90923b348bbc66592071249 (patch)
tree441050e64a26d636fbb29a27bcb522906505bd92 /net-irc
parentuse games_make_wrapper; add missing gtk+-1 dependency (diff)
downloadgentoo-2-729d6262d6e3bdf7e90923b348bbc66592071249.tar.gz
gentoo-2-729d6262d6e3bdf7e90923b348bbc66592071249.tar.bz2
gentoo-2-729d6262d6e3bdf7e90923b348bbc66592071249.zip
Version bump
(Portage version: 2.1.2.3)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/miau/ChangeLog7
-rw-r--r--net-irc/miau/files/digest-miau-0.6.43
-rw-r--r--net-irc/miau/miau-0.6.4.ebuild69
3 files changed, 78 insertions, 1 deletions
diff --git a/net-irc/miau/ChangeLog b/net-irc/miau/ChangeLog
index 9fedfc50d63f..03851c3ae1c7 100644
--- a/net-irc/miau/ChangeLog
+++ b/net-irc/miau/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/miau
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/miau/ChangeLog,v 1.9 2007/02/19 21:59:02 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/miau/ChangeLog,v 1.10 2007/04/11 18:24:02 armin76 Exp $
+
+*miau-0.6.4 (11 Apr 2007)
+
+ 11 Apr 2007; Raúl Porcel <armin76@gentoo.org> +miau-0.6.4.ebuild:
+ Version bump
*miau-0.6.2 (19 Feb 2007)
diff --git a/net-irc/miau/files/digest-miau-0.6.4 b/net-irc/miau/files/digest-miau-0.6.4
new file mode 100644
index 000000000000..4a6a71441229
--- /dev/null
+++ b/net-irc/miau/files/digest-miau-0.6.4
@@ -0,0 +1,3 @@
+MD5 6ee1b23fe55b46988d0714021b0ff76c miau-0.6.4.tar.bz2 201377
+RMD160 9773d108650947608a3ef52507b25ae0c132ad99 miau-0.6.4.tar.bz2 201377
+SHA256 ee1776789151f08837677fa5813efa11210eabd067e8aa37e7c74d0aa142c1f0 miau-0.6.4.tar.bz2 201377
diff --git a/net-irc/miau/miau-0.6.4.ebuild b/net-irc/miau/miau-0.6.4.ebuild
new file mode 100644
index 000000000000..b5e0ba6fcb77
--- /dev/null
+++ b/net-irc/miau/miau-0.6.4.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/miau/miau-0.6.4.ebuild,v 1.1 2007/04/11 18:24:02 armin76 Exp $
+
+inherit eutils
+
+DESCRIPTION="Persistent IRC bouncer with multi-client support - a fork of muh"
+HOMEPAGE="http://miau.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug ipv6"
+
+DEPEND=""
+
+pkg_setup() {
+ if use ipv6; then
+ echo
+ ewarn "Enabling the ipv6 useflag will disable ipv4 entirely. Press"
+ ewarn "Ctrl+C now if you don't want this."
+ echo
+ ebeep 5
+ fi
+}
+
+src_compile() {
+ # --disable-debug seems to actually enabled it, using if use rather than
+ # use_enable to get around it.
+ if use debug; then
+ myconf="--enable-debug"
+ fi
+ econf \
+ --enable-dccbounce \
+ --enable-automode \
+ --enable-releasenick \
+ --enable-ctcp-replies \
+ --enable-mkpasswd \
+ --enable-uptime \
+ --enable-chanlog \
+ --enable-privlog \
+ --enable-onconnect \
+ --enable-empty-awaymsg \
+ $(use_enable ipv6) \
+ ${myconf} \
+ $(use_enable debug enduserdebug) \
+ $(use_enable debug pingstat) \
+ $(use_enable debug dumpstatus) \
+ || die "econf failed."
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed."
+ dodoc AUTHORS ChangeLog TODO README || die "dodoc failed."
+
+ mv "${D}/usr/share/doc/miau/examples/miaurc" \
+ "${D}/usr/share/doc/${PF}/miaurc.sample"
+ rm -rf "${D}/usr/share/doc/miau"
+}
+
+pkg_postinst() {
+ echo
+ einfo "You'll need to configure miau before running it."
+ einfo "Put your config in ~/.miau/miaurc"
+ einfo "You can use the sample config is in /usr/share/doc/${PF}/miaurc.sample"
+ einfo "For more information, see the documentation."
+ echo
+}