summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-26 20:55:03 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-26 20:55:03 +0000
commit541f14235634ec9414e89e8089beca533ffca899 (patch)
tree86d726368da8d5082e4e7b43278d3a356de0605c /net-irc
parent*** empty log message *** (diff)
downloadgentoo-2-541f14235634ec9414e89e8089beca533ffca899.tar.gz
gentoo-2-541f14235634ec9414e89e8089beca533ffca899.tar.bz2
gentoo-2-541f14235634ec9414e89e8089beca533ffca899.zip
*** empty log message ***
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/files/digest-xchat-1.4.31
-rw-r--r--net-irc/xchat/xchat-1.4.3.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/net-irc/xchat/files/digest-xchat-1.4.3 b/net-irc/xchat/files/digest-xchat-1.4.3
new file mode 100644
index 000000000000..7142a2a36a6d
--- /dev/null
+++ b/net-irc/xchat/files/digest-xchat-1.4.3
@@ -0,0 +1 @@
+MD5 268ee72a8a58c323e838f72ebfc58cd6 xchat-1.4.3.tar.bz2
diff --git a/net-irc/xchat/xchat-1.4.3.ebuild b/net-irc/xchat/xchat-1.4.3.ebuild
new file mode 100644
index 000000000000..4ead9c0cb4e8
--- /dev/null
+++ b/net-irc/xchat/xchat-1.4.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-1.4.3.ebuild,v 1.1 2000/11/26 20:54:19 achim Exp $
+
+A=${P}.tar.bz2
+S=${WORKDIR}/${P}
+DESCRIPTION="xchat"
+SRC_URI="http://www.xchat.org/files/source/1.4/"${A}
+HOMEPAGE="http://www.xchat.org/"
+
+DEPEND=">=media-libs/imlib-1.9.8.1
+ gnome? ( >=gnome-base/gnome-core-1.2.2.1 )"
+
+src_compile() {
+ cd ${S}
+ local myopts
+ if [ -n "`use gnome`" ]
+ then
+ myopts="--enable-gnome --prefix=/opt/gnome"
+ else
+ myopts="--disable-gnome --prefix=/usr/X11R6"
+ fi
+ try ./configure --host=${CHOST} --disable-perl --disable-python ${myopts} --with-catgets
+ try make
+}
+
+src_install() {
+ cd ${S}
+ if [ -n "`use gnome`" ]
+ then
+ try make prefix=${D}/opt/gnome install
+ else
+ try make prefix=${D}/usr/X11R6 install
+ fi
+ dodoc AUTHORS COPYING ChangeLog NEWS README
+}
+
+
+
+
+
+