summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2009-02-22 10:41:19 +0000
committerRaúl Porcel <armin76@gentoo.org>2009-02-22 10:41:19 +0000
commit503d23199b3a987e73127b4f34e8d10c2bacd685 (patch)
treee28e1df5ca8d11b175a7c201312b4e37cd61b4e8 /net-irc
parentVersion bump (diff)
downloadgentoo-2-503d23199b3a987e73127b4f34e8d10c2bacd685.tar.gz
gentoo-2-503d23199b3a987e73127b4f34e8d10c2bacd685.tar.bz2
gentoo-2-503d23199b3a987e73127b4f34e8d10c2bacd685.zip
Version bump
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/irssi-otr/ChangeLog9
-rw-r--r--net-irc/irssi-otr/irssi-otr-0.3.ebuild37
2 files changed, 44 insertions, 2 deletions
diff --git a/net-irc/irssi-otr/ChangeLog b/net-irc/irssi-otr/ChangeLog
index bb8ae21ff477..b9899f2b1a82 100644
--- a/net-irc/irssi-otr/ChangeLog
+++ b/net-irc/irssi-otr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/irssi-otr
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi-otr/ChangeLog,v 1.3 2008/08/04 19:53:59 bluebird Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi-otr/ChangeLog,v 1.4 2009/02/22 10:41:19 armin76 Exp $
+
+*irssi-otr-0.3 (22 Feb 2009)
+
+ 22 Feb 2009; Raúl Porcel <armin76@gentoo.org> +irssi-otr-0.3.ebuild:
+ Version bump
04 Aug 2008; Friedrich Oslage <bluebird@gentoo.org> irssi-otr-0.2.ebuild:
Add ~sparc keyword at user(Michael Hellwig) request, bug #233886
diff --git a/net-irc/irssi-otr/irssi-otr-0.3.ebuild b/net-irc/irssi-otr/irssi-otr-0.3.ebuild
new file mode 100644
index 000000000000..e62acd0353a0
--- /dev/null
+++ b/net-irc/irssi-otr/irssi-otr-0.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi-otr/irssi-otr-0.3.ebuild,v 1.1 2009/02/22 10:41:19 armin76 Exp $
+
+inherit cmake-utils eutils
+
+DESCRIPTION="Off-The-Record messaging (OTR) for irssi"
+HOMEPAGE="http://irssi-otr.tuxfamily.org"
+
+# This should probably be exported by cmake-utils as a variable
+CMAKE_BINARY_DIR="${WORKDIR}"/${PN}_build
+mycmakeargs="-DDOCDIR=/usr/share/doc/${PF}"
+
+SRC_URI="ftp://download.tuxfamily.org/irssiotr/${PF}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND="net-libs/libotr
+ || (
+ net-irc/irssi
+ net-irc/irssi-svn
+ )"
+
+DEPEND="${RDEPEND}
+ dev-libs/glib
+ >=dev-util/cmake-2.4.7
+ dev-util/pkgconfig
+ dev-lang/python"
+
+src_install() {
+ cmake-utils_src_install
+ rm "${D}"/usr/share/doc/${PF}/LICENSE
+ prepalldocs
+}