summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2009-12-20 23:20:09 +0000
committerVictor Ostorga <vostorga@gentoo.org>2009-12-20 23:20:09 +0000
commit4e55caae2ffaedea7117a943a29aca4ef2cc07f8 (patch)
treed887161be97705621f5e979047fcc1948a6849de /net-irc
parentSet SUPPORT_PYTHON_ABIS. (diff)
downloadgentoo-2-4e55caae2ffaedea7117a943a29aca4ef2cc07f8.tar.gz
gentoo-2-4e55caae2ffaedea7117a943a29aca4ef2cc07f8.tar.bz2
gentoo-2-4e55caae2ffaedea7117a943a29aca4ef2cc07f8.zip
Cleaning out old ebuilds, Version bump bug #218880 , Fixing build with --as-needed bug #248019, Fixing build with build with >=net-libs/gnutls-2.7.1 bug #297324
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/inspircd/ChangeLog11
-rw-r--r--net-irc/inspircd/inspircd-1.0.7-r1.ebuild123
-rw-r--r--net-irc/inspircd/inspircd-1.1.14.ebuild88
-rw-r--r--net-irc/inspircd/inspircd-1.1.23.ebuild124
4 files changed, 134 insertions, 212 deletions
diff --git a/net-irc/inspircd/ChangeLog b/net-irc/inspircd/ChangeLog
index a41674399123..3348b624d7a7 100644
--- a/net-irc/inspircd/ChangeLog
+++ b/net-irc/inspircd/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-irc/inspircd
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/ChangeLog,v 1.27 2009/01/14 05:12:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/ChangeLog,v 1.28 2009/12/20 23:20:09 vostorga Exp $
+
+*inspircd-1.1.23 (20 Dec 2009)
+
+ 20 Dec 2009; Víctor Ostorga <vostorga@gentoo.org>
+ -inspircd-1.0.7-r1.ebuild, -inspircd-1.1.14.ebuild,
+ +inspircd-1.1.23.ebuild:
+ Cleaning out old ebuilds, Version bump bug #218880
+ Fixing build with --as-needed bug #248019
+ Fixing build with build with >=net-libs/gnutls-2.7.1 bug #297324
14 Jan 2009; Mike Frysinger <vapier@gentoo.org>
+files/inspircd-1.1.19-build.patch, inspircd-1.1.19.ebuild:
diff --git a/net-irc/inspircd/inspircd-1.0.7-r1.ebuild b/net-irc/inspircd/inspircd-1.0.7-r1.ebuild
deleted file mode 100644
index eeaea52884c4..000000000000
--- a/net-irc/inspircd/inspircd-1.0.7-r1.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/inspircd-1.0.7-r1.ebuild,v 1.2 2007/01/04 18:51:12 hansmi Exp $
-
-inherit eutils toolchain-funcs multilib
-
-IUSE="openssl gnutls"
-
-DESCRIPTION="InspIRCd - The Modular C++ IRC Daemon"
-HOMEPAGE="http://www.inspircd.org"
-SRC_URI="mirror://sourceforge/${PN}/InspIRCd-${PV}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ppc x86"
-RDEPEND="
- openssl? ( >=dev-libs/openssl-0.9.7d )
- gnutls? ( >=net-libs/gnutls-1.3.0 )"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/inspircd"
-
-pkg_setup() {
- enewgroup inspircd
- enewuser inspircd -1 -1 -1 inspircd
-}
-
-# Determines the appropriate value for the
-# GCC34= configuration option.
-inspircd-determine-gcc34() {
- if [[ $(gcc-major-version) -gt 3 ]] ; then
- echo "4"
- else
- if [[ $(gcc-minor-version) -lt 4 ]] ; then
- echo "3"
- else
- echo "4"
- fi
- fi
-}
-
-src_compile() {
- local myconf=""
-
- # Write a configuration file
- einfo "Building configuration parameters file."
-
- if use openssl; then
- einfo "Enabling OpenSSL SSL engine module."
- fi
-
- if use gnutls; then
- einfo "Enabling GnuTLS SSL engine module."
- fi
-
- cat << _EOF_ > .config.cache
-CC="$(tc-getCXX)"
-MAKEPROG="make $MFLAGS"
-GCCVER="$(gcc-major-version)"
-GCC34="$(inspircd-determine-gcc34)"
-OPTIMISATI=""
-FLAGS="$CXXFLAGS"
-CONFIG_DIR="/etc/inspircd"
-MODULE_DIR="/usr/$(get_libdir)/inspircd/modules"
-BASE_DIR="/"
-LIBRARY_DIR="/usr/$(get_libdir)/inspircd"
-OSNAME="$(uname)"
-BINARY_DIR="/usr/bin"
-LDLIBS="-ldl -lstdc++"
-CHANGE_COMPILER="n"
-HAS_STRLCPY="false"
-MAKEORDER="ircd mods"
-
-# User defined parameters.
-MAX_KICK="${INSPIRCD_KICKLEN:-255}"
-MAX_IDENT="${INSPIRCD_IDENTLEN:-12}"
-MAX_GECOS="${INSPIRCD_GECOSLEN:-128}"
-MAX_CLIENT_T="${INSPIRCD_MAX_CLIENTS:-512}"
-MAXI_MODES="${INSPIRCD_MAX_MODES:-20}"
-MAX_CLIENT="${INSPIRCD_MAX_CLIENTS:-512}"
-MAX_CHANNE="${INSPIRCD_MAX_CHANNELS:-20}"
-NICK_LENGT="${INSPIRCD_NICKLEN:-31}"
-MAX_OPERCH="${INSPIRCD_MAX_OPERCHANS:-60}"
-MAX_AWAY="${INSPIRCD_AWAYLEN:-200}"
-MAX_TOPIC="${INSPIRCD_TOPICLEN:-307}"
-MAX_QUIT="${INSPIRCD_QUITLEN:-255}"
-_EOF_
-
- # build makefiles based on our configure params
- # Please note that it's not the autoconf configure script, thus
- # we don't use econf.
- ./configure -update || die "configure failed"
-
- emake DESTDIR="${D}" || die "emake failed"
-}
-
-src_install() {
- # the inspircd buildsystem does not create these, it's configure script
- # does. so, we have to at this point to make sure they are there.
- dodir /usr/$(get_libdir)/inspircd
- dodir /usr/$(get_libdir)/inspircd/modules
- dodir /etc/inspircd
- dodir /usr/bin/ircd
-
- emake \
- LIBPATH="${D}/usr/$(get_libdir)/inspircd" \
- MODPATH="${D}/usr/$(get_libdir)/inspircd/modules" \
- CONPATH="${D}/etc/inspircd" \
- BINPATH="${D}/usr/bin" \
- BASE="${D}/usr/bin/inspircd.launcher" \
- install
-
- newinitd "${FILESDIR}"/init.d_inspircd inspircd
-}
-
-pkg_postinst() {
- chown -R inspircd:inspircd "${ROOT}"/etc/inspircd
- chmod 700 "${ROOT}"/etc/inspircd
-
- chown -R inspircd:inspircd "${ROOT}"/usr/$(get_libdir)/inspircd
- chmod -R 755 "${ROOT}"/usr/$(get_libdir)/inspircd
-
- chmod -R 755 /usr/bin/inspircd
-}
diff --git a/net-irc/inspircd/inspircd-1.1.14.ebuild b/net-irc/inspircd/inspircd-1.1.14.ebuild
deleted file mode 100644
index 0dde2843be35..000000000000
--- a/net-irc/inspircd/inspircd-1.1.14.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/inspircd-1.1.14.ebuild,v 1.1 2007/11/12 21:47:32 hansmi Exp $
-
-inherit eutils multilib
-
-DESCRIPTION="InspIRCd - The Modular C++ IRC Daemon"
-HOMEPAGE="http://www.inspircd.org/"
-SRC_URI="http://www.inspircd.org/downloads/InspIRCd-${PV}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="gnutls ipv6 openssl kernel_linux"
-
-DEPEND="
- >=sys-devel/gcc-3.3.0
- >=dev-lang/perl-5.8
- openssl? ( >=dev-libs/openssl-0.9.7d )
- gnutls? ( >=net-libs/gnutls-1.3.0 )"
-
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${PN}"
-
-pkg_setup() {
- ebegin "Creating inspircd user and group"
- enewgroup inspircd
- enewuser inspircd -1 -1 -1 inspircd
- eend ${?}
-}
-
-src_compile() {
- local myconf="
- --disable-interactive
- --enable-epoll"
-
- # ./configure doesn't know --disable-gnutls, -ipv6 and -openssl options,
- # so should be used only --enable-like.
- use gnutls && myconf="${myconf} $(use_enable gnutls)"
- use ipv6 && myconf="${myconf} $(use_enable ipv6) --enable-remote-ipv6"
- use openssl && myconf="${myconf} $(use_enable openssl)"
-
- ./configure \
- --prefix="/usr" \
- --binary-dir="/usr/bin" \
- --config-dir="/etc/${PN}" \
- --library-dir="/usr/$(get_libdir)/${PN}" \
- --module-dir="/usr/$(get_libdir)/${PN}/modules" \
- ${myconf} || die "configure failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- # the inspircd buildsystem does not create these, it's configure script
- # does. so, we have to at this point to make sure they are there.
- dodir /etc/${PN}
- dodir /usr/include/${PN}
- dodir /usr/$(get_libdir)/${PN}
- dodir /usr/$(get_libdir)/${PN}/modules
- dodir /var/log/${PN}
-
- emake install \
- BASE="${D}"/usr/$(get_libdir)/${PN}/inspircd.launcher \
- BINPATH="${D}"/usr/bin \
- CONPATH="${D}"/etc/${PN} \
- LIBPATH="${D}"/usr/$(get_libdir)/${PN}/ \
- MODPATH="${D}"/usr/$(get_libdir)/${PN}/modules/ \
-
- insinto /usr/include/inspircd/
- doins "${S}"/include/*
-
- newinitd "${FILESDIR}"/init.d_inspircd inspircd
-}
-
-pkg_postinst() {
- chown -R inspircd:inspircd "${ROOT}"/etc/${PN}
- chmod 700 "${ROOT}"/etc/${PN}
-
- chown -R inspircd:inspircd "${ROOT}"/var/log/${PN}
- chmod 750 "${ROOT}"/var/log/${PN}
-
- chown -R inspircd:inspircd "${ROOT}"/usr/$(get_libdir)/${PN}
- chmod -R 755 "${ROOT}"/usr/$(get_libdir)/${PN}
-
- chmod -R 755 "${ROOT}"/usr/bin/inspircd
-}
diff --git a/net-irc/inspircd/inspircd-1.1.23.ebuild b/net-irc/inspircd/inspircd-1.1.23.ebuild
new file mode 100644
index 000000000000..9fb805f91bee
--- /dev/null
+++ b/net-irc/inspircd/inspircd-1.1.23.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/inspircd-1.1.23.ebuild,v 1.1 2009/12/20 23:20:09 vostorga Exp $
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="InspIRCd - The Modular C++ IRC Daemon"
+HOMEPAGE="http://www.inspircd.org/"
+SRC_URI="http://www.inspircd.org/downloads/InspIRCd-${PV}.tar.bz2
+mirror://sourceforge/${PN}/InspIRCd-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="openssl gnutls ipv6 kernel_linux mysql postgres sqlite zlib ldap"
+
+RDEPEND="
+ dev-lang/perl
+ openssl? ( dev-libs/openssl )
+ gnutls? ( net-libs/gnutls )
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql )
+ sqlite? ( >=dev-db/sqlite-3.0 )
+ ldap? ( net-nds/openldap )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/inspircd"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ local SQL=0
+ cd src/modules
+
+ if use zlib ; then
+ cp extra/m_ziplink.cpp .
+ fi
+ if use openssl || use gnutls ; then
+ cp extra/m_sslinfo.cpp .
+ cp extra/m_ssl_oper_cert.cpp .
+ fi
+
+ if use ldap ; then
+ cp extra/m_ldapauth.cpp .
+ fi
+
+ if use mysql ; then
+ SQL=1
+ cp extra/m_mysql.cpp .
+ fi
+ if use postgres ; then
+ SQL=1
+ cp extra/m_pgsql.cpp .
+ fi
+ if use sqlite ; then
+ SQL=1
+ cp extra/m_sqlite3.cpp .
+ fi
+ if [ ${SQL} -eq 1 ] ; then
+ cp extra/m_sql{auth.cpp,log.cpp,oper.cpp,utils.cpp,utils.h,v2.h} .
+ fi
+}
+
+src_compile() {
+
+ # ./configure doesn't know --disable-gnutls, -ipv6 and -openssl options,
+ # so should be used only --enable-like.
+ local myconf=""
+ use gnutls && myconf="--enable-gnutls"
+ use ipv6 && myconf="${myconf} --enable-ipv6 --enable-remote-ipv6"
+ use openssl && myconf="${myconf} --enable-openssl"
+
+ ./configure ${myconf} \
+ --enable-epoll \
+ --prefix="/usr/$(get_libdir)/inspircd" \
+ --config-dir="/etc/inspircd" \
+ --binary-dir="/usr/bin" \
+ --library-dir="/usr/$(get_libdir)/inspircd" \
+ --module-dir="/usr/$(get_libdir)/inspircd/modules" \
+ || die "configure failed"
+ ./configure -modupdate || die "modupdate failed"
+
+ emake CC="$(tc-getCXX)" || die "emake failed"
+}
+
+src_install() {
+ # the inspircd buildsystem does not create these, its configure script
+ # does. so, we have to make sure they are there.
+ dodir /usr/$(get_libdir)/inspircd
+ dodir /usr/$(get_libdir)/inspircd/modules
+ dodir /etc/inspircd
+ dodir /var/log/inspircd
+ dodir /usr/include/inspircd
+
+ emake install \
+ LIBPATH="${D}/usr/$(get_libdir)/inspircd/" \
+ MODPATH="${D}/usr/$(get_libdir)/inspircd/modules/" \
+ CONPATH="${D}/etc/inspircd" \
+ BINPATH="${D}/usr/bin" \
+ BASE="${D}/usr/$(get_libdir)/inspircd/inspircd.launcher"
+
+ insinto /usr/include/inspircd/
+ doins "${S}"/include/*
+
+ newinitd "${FILESDIR}"/init.d_inspircd inspircd
+
+ keepdir "/var/log/inspircd/"
+}
+
+pkg_postinst() {
+ enewgroup inspircd
+ enewuser inspircd -1 -1 -1 inspircd
+ chown -R inspircd:inspircd "${ROOT}"/etc/inspircd
+ chmod 700 "${ROOT}"/etc/inspircd
+
+ chmod 750 "${ROOT}"/var/log/inspircd
+ chown -R inspircd:inspircd "${ROOT}"/var/log/inspircd
+
+ chown -R inspircd:inspircd "${ROOT}"/usr/$(get_libdir)/inspircd
+ chmod -R 755 "${ROOT}"/usr/$(get_libdir)/inspircd
+
+ chmod -R 755 "${ROOT}"/usr/bin/inspircd
+}