summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-12-30 23:51:12 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-12-30 23:51:12 +0000
commit4d597d4fe7a0ddd58ad14f161966ddede0b00061 (patch)
tree6dc9564d7be6fdfff46cd3531adf9ea7605836ad /net-irc
parentCleanup metadata. (diff)
downloadgentoo-2-4d597d4fe7a0ddd58ad14f161966ddede0b00061.tar.gz
gentoo-2-4d597d4fe7a0ddd58ad14f161966ddede0b00061.tar.bz2
gentoo-2-4d597d4fe7a0ddd58ad14f161966ddede0b00061.zip
fix collision with dev-util/ninja (bug #436804)
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/ninja/ChangeLog10
-rw-r--r--net-irc/ninja/ninja-1.5.9_pre14-r1.ebuild32
-rw-r--r--net-irc/ninja/ninja-1.5.9_pre14.ebuild8
3 files changed, 45 insertions, 5 deletions
diff --git a/net-irc/ninja/ChangeLog b/net-irc/ninja/ChangeLog
index 98c91e936b42..2f53d6f1a1fb 100644
--- a/net-irc/ninja/ChangeLog
+++ b/net-irc/ninja/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/ninja
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/ninja/ChangeLog,v 1.20 2009/09/23 18:45:04 patrick Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ninja/ChangeLog,v 1.21 2012/12/30 23:51:12 ottxor Exp $
+
+*ninja-1.5.9_pre14-r1 (30 Dec 2012)
+
+ 30 Dec 2012; Christoph Junghans <ottxor@gentoo.org>
+ +ninja-1.5.9_pre14-r1.ebuild, ninja-1.5.9_pre14.ebuild:
+ fix collision with dev-util/ninja (bug #436804)
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> ninja-1.5.9_pre14.ebuild:
Remove virtual/libc
diff --git a/net-irc/ninja/ninja-1.5.9_pre14-r1.ebuild b/net-irc/ninja/ninja-1.5.9_pre14-r1.ebuild
new file mode 100644
index 000000000000..2a91a355262c
--- /dev/null
+++ b/net-irc/ninja/ninja-1.5.9_pre14-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ninja/ninja-1.5.9_pre14-r1.ebuild,v 1.1 2012/12/30 23:51:12 ottxor Exp $
+
+EAPI=5
+
+S=${WORKDIR}/${P/_*/}
+
+DESCRIPTION="Ninja IRC Client"
+HOMEPAGE="http://ninja.qoop.org/"
+SRC_URI="ftp://qoop.org/ninja/stable/${P/_/}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ncurses ipv6 ssl"
+
+RESTRICT="test"
+
+DEPEND="ncurses? ( sys-libs/ncurses )
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_configure() {
+ econf $(use_enable ipv6)
+}
+
+src_install() {
+ default
+ mv "${ED}"/usr/bin/ninja{,_irc} || die #436804
+}
diff --git a/net-irc/ninja/ninja-1.5.9_pre14.ebuild b/net-irc/ninja/ninja-1.5.9_pre14.ebuild
index 5a87e914f622..9eb38743e96e 100644
--- a/net-irc/ninja/ninja-1.5.9_pre14.ebuild
+++ b/net-irc/ninja/ninja-1.5.9_pre14.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/ninja/ninja-1.5.9_pre14.ebuild,v 1.5 2009/09/23 18:45:04 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ninja/ninja-1.5.9_pre14.ebuild,v 1.6 2012/12/30 23:51:12 ottxor Exp $
S=${WORKDIR}/${P/_*/}
@@ -15,7 +15,9 @@ IUSE="ncurses ipv6 ssl"
RESTRICT="test"
DEPEND="ncurses? ( sys-libs/ncurses )
- ssl? ( dev-libs/openssl )"
+ ssl? ( dev-libs/openssl )
+ !dev-util/ninja" #436804
+RDEPEND="${DEPEND}"
MAKEOPTS="${MAKEOPTS} -j1"