summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-04-12 23:15:35 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-04-12 23:15:35 +0000
commit475f594d80a1fe4dcff96c23fec6f09345e8ab37 (patch)
tree59e131ce4510dde473008c7278021b9cada6de9c /net-irc
parentBump to 2.20.10. (diff)
downloadgentoo-2-475f594d80a1fe4dcff96c23fec6f09345e8ab37.tar.gz
gentoo-2-475f594d80a1fe4dcff96c23fec6f09345e8ab37.tar.bz2
gentoo-2-475f594d80a1fe4dcff96c23fec6f09345e8ab37.zip
Bump to 0.26.0.
(Portage version: 2.2_rc29/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat-gnome/ChangeLog8
-rw-r--r--net-irc/xchat-gnome/xchat-gnome-0.26.0.ebuild79
2 files changed, 86 insertions, 1 deletions
diff --git a/net-irc/xchat-gnome/ChangeLog b/net-irc/xchat-gnome/ChangeLog
index 92d18cd2b5c5..43f3c1c74ea9 100644
--- a/net-irc/xchat-gnome/ChangeLog
+++ b/net-irc/xchat-gnome/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/xchat-gnome
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-gnome/ChangeLog,v 1.44 2009/02/27 20:06:53 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-gnome/ChangeLog,v 1.45 2009/04/12 23:15:35 eva Exp $
+
+*xchat-gnome-0.26.0 (12 Apr 2009)
+
+ 12 Apr 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +xchat-gnome-0.26.0.ebuild:
+ Bump to 0.26.0.
27 Feb 2009; Joseph Jezak <josejx@gentoo.org> xchat-gnome-0.24.3.1.ebuild:
Marked ~ppc for bug #239847.
diff --git a/net-irc/xchat-gnome/xchat-gnome-0.26.0.ebuild b/net-irc/xchat-gnome/xchat-gnome-0.26.0.ebuild
new file mode 100644
index 000000000000..85bc3fb0798c
--- /dev/null
+++ b/net-irc/xchat-gnome/xchat-gnome-0.26.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-gnome/xchat-gnome-0.26.0.ebuild,v 1.1 2009/04/12 23:15:35 eva Exp $
+
+inherit gnome2 eutils toolchain-funcs
+
+DESCRIPTION="GNOME frontend for the popular X-Chat IRC client"
+HOMEPAGE="http://xchat-gnome.navi.cx/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dbus ipv6 libnotify mmx nls perl python sound spell ssl tcl"
+
+RDEPEND=">=dev-libs/glib-2.18.0
+ >=gnome-base/libgnome-2.16.0
+ >=gnome-base/gconf-2.8.0
+ >=gnome-base/libgnomeui-2.16.0
+ >=gnome-base/libglade-2.3.2
+ >=x11-libs/gtk+-2.14.0
+ spell? ( app-text/enchant )
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ perl? ( >=dev-lang/perl-5.6.1 )
+ python? ( dev-lang/python )
+ tcl? ( dev-lang/tcl )
+ dbus? ( >=sys-apps/dbus-0.60 )
+ >=x11-libs/libsexy-0.1.11
+ libnotify? ( >=x11-libs/libnotify-0.3.2 )
+ sound? ( >=media-libs/libcanberra-0.3 )
+ x11-libs/libX11"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.7
+ >=app-text/gnome-doc-utils-0.3.2
+ nls? ( sys-devel/gettext )"
+
+# gnome-base/gnome-common needed when doing eautoreconf
+
+pkg_setup() {
+ if [[ $(gcc-major-version) -lt 4 || (
+ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 1 || (
+ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -eq 1 && $(gcc-micro-version) -lt 3 ) ) ]]; then
+ ewarn "${P} requires >=sys-devel/gcc-4.1.3 to compile"
+ die "Please select >=sys-devel/gcc-4.1.3"
+ fi
+
+ if use sound && ! built_with_use media-libs/libcanberra gtk; then
+ eerror "You need to rebuild media-libs/libcanberra with gtk support."
+ die "Rebuild media-libs/libcanberra with USE='gtk'"
+ fi
+
+ # Per configure.ac, shm is disable because of upstream bug #565958
+ # --enable-shm
+ G2CONF="${G2CONF}
+ --enable-gnomefe
+ --disable-schemas-install
+ --disable-scrollkeeper
+ --disable-static
+ $(use_enable ssl openssl)
+ $(use_enable perl)
+ $(use_enable python)
+ $(use_enable tcl)
+ $(use_enable mmx)
+ $(use_enable ipv6)
+ $(use_enable dbus)
+ $(use_enable nls)
+ $(use_enable sound canberra)
+ $(use_enable libnotify notification)"
+}
+
+src_install() {
+ gnome2_src_install
+
+ # install plugin development header
+ insinto /usr/include/xchat-gnome
+ doins src/common/xchat-plugin.h || die "doins failed"
+
+ dodoc AUTHORS ChangeLog NEWS || die "dodoc failed"
+}