summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-05-02 15:59:23 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-05-02 15:59:23 +0000
commit3c37f85c0ed21c87c449405a838dacbbeb5bf371 (patch)
treec3f321dc8faeba2170f23f2363615dd46aac9187 /net-irc
parentstable x86, bug 219332 (diff)
downloadgentoo-2-3c37f85c0ed21c87c449405a838dacbbeb5bf371.tar.gz
gentoo-2-3c37f85c0ed21c87c449405a838dacbbeb5bf371.tar.bz2
gentoo-2-3c37f85c0ed21c87c449405a838dacbbeb5bf371.zip
Version bump
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/epic4/ChangeLog9
-rw-r--r--net-irc/epic4/epic4-2.10.ebuild94
2 files changed, 101 insertions, 2 deletions
diff --git a/net-irc/epic4/ChangeLog b/net-irc/epic4/ChangeLog
index 0f0cb476f5a4..0cc546f834d7 100644
--- a/net-irc/epic4/ChangeLog
+++ b/net-irc/epic4/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/epic4
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/epic4/ChangeLog,v 1.81 2007/11/10 16:00:40 armin76 Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/epic4/ChangeLog,v 1.82 2008/05/02 15:59:23 armin76 Exp $
+
+*epic4-2.10 (02 May 2008)
+
+ 02 May 2008; Raúl Porcel <armin76@gentoo.org> +epic4-2.10.ebuild:
+ Version bump
10 Nov 2007; Raúl Porcel <armin76@gentoo.org> -epic4-2.6.ebuild:
old
diff --git a/net-irc/epic4/epic4-2.10.ebuild b/net-irc/epic4/epic4-2.10.ebuild
new file mode 100644
index 000000000000..c92427e18617
--- /dev/null
+++ b/net-irc/epic4/epic4-2.10.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/epic4/epic4-2.10.ebuild,v 1.1 2008/05/02 15:59:23 armin76 Exp $
+
+inherit flag-o-matic eutils toolchain-funcs
+
+HELP_V="20050315"
+
+DESCRIPTION="Epic4 IRC Client"
+HOMEPAGE="http://epicsol.org/"
+SRC_URI="ftp://ftp.epicsol.org/pub/epic/EPIC4-PRODUCTION/${P}.tar.bz2
+ ftp://prbh.org/pub/epic/EPIC4-PRODUCTION/epic4-help-${HELP_V}.tar.gz
+ mirror://gentoo/epic4-local.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="ipv6 perl ssl"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ perl? ( >=dev-lang/perl-5.6.1 )
+ ssl? ( >=dev-libs/openssl-0.9.5 )"
+
+pkg_setup() {
+ if use perl && built_with_use dev-lang/perl ithreads
+ then
+ error "You need perl compiled with USE=\"-ithreads\" to be able to compile epic4."
+ die "perl with USE=\"-ithreads\" needed"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/epic-defaultserver.patch
+
+ rm -f "${WORKDIR}"/help/Makefile
+ find "${WORKDIR}"/help -type d -name CVS -print0 | xargs -0 rm -r
+}
+
+src_compile() {
+ replace-flags "-O?" "-O"
+
+ econf \
+ --libexecdir=/usr/lib/misc \
+ $(use_with ipv6) \
+ $(use_with perl) \
+ $(use_with ssl) \
+ || die "econf failed"
+ emake CC="$(tc-getCC)" || die "make failed"
+}
+
+src_install () {
+ einstall \
+ sharedir=${D}/usr/share \
+ libexecdir=${D}/usr/lib/misc || die "einstall failed"
+
+ dodoc BUG_FORM COPYRIGHT README KNOWNBUGS VOTES
+
+ cd "${S}"/doc
+ docinto doc
+ dodoc \
+ *.txt colors EPIC* IRCII_VERSIONS local_vars missing new-load \
+ nicknames outputhelp SILLINESS TS4
+
+ insinto /usr/share/epic/help
+ doins -r "${WORKDIR}"/help/* || die "doins failed"
+}
+
+pkg_postinst() {
+ if [ ! -f "${ROOT}"/usr/share/epic/script/local ]
+ then
+ elog "/usr/share/epic/script/local does not exist, I will now"
+ elog "create it. If you do not like the look/feel of this file, or"
+ elog "if you'd prefer to use your own script, simply remove this"
+ elog "file. If you want to prevent this file from being installed"
+ elog "in the future, simply create an empty file with this name."
+ cp "${WORKDIR}"/epic4-local "${ROOT}"/usr/share/epic/script/local
+ elog
+ elog "This provided local startup script adds a number of nifty"
+ elog "features to Epic including tab completion, a comprehensive set"
+ elog "of aliases, and channel-by-channel logging. To prevent"
+ elog "unintentional conflicts with your own scripting, if either the"
+ elog "~/.ircrc or ~/.epicrc script files exist, then the local script"
+ elog "is *not* run. If you like the script but want to make careful"
+ elog "additions (such as selecting your usual servers or setting your"
+ elog "nickname), simply copy /usr/share/epic/script/local to ~/.ircrc"
+ elog "and then add your additions to the copy."
+ fi
+
+ # Fix for bug 59075
+ chmod 755 "${ROOT}"/usr/share/epic/help
+}