summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-31 16:29:24 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-31 16:29:24 +0000
commit32c16b5806fe2da50a630a3b208a433dfe16f588 (patch)
tree2df0cd595ea7839a9927ad372483a000ddb4556f /net-irc
parentDepend correct ccp4-libs version to make test work (diff)
downloadgentoo-2-32c16b5806fe2da50a630a3b208a433dfe16f588.tar.gz
gentoo-2-32c16b5806fe2da50a630a3b208a433dfe16f588.tar.bz2
gentoo-2-32c16b5806fe2da50a630a3b208a433dfe16f588.zip
Call python_pkg_setup(). Update call to sed.
(Portage version: 2.2.0_alpha11_p1/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/kvirc/kvirc-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/net-irc/kvirc/kvirc-9999.ebuild b/net-irc/kvirc/kvirc-9999.ebuild
index 73a715eb6c12..3e3402930145 100644
--- a/net-irc/kvirc/kvirc-9999.ebuild
+++ b/net-irc/kvirc/kvirc-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/kvirc/kvirc-9999.ebuild,v 1.26 2010/06/25 13:57:14 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/kvirc/kvirc-9999.ebuild,v 1.27 2010/12/31 16:29:24 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
@@ -18,8 +18,7 @@ SLOT="4"
KEYWORDS=""
IUSE="audiofile dcc_video +dcc_voice debug doc gsm +ipc ipv6 kde +nls oss +perl +phonon profile +python +qt-dbus qt-webkit +ssl theora +transparency"
-RDEPEND="
- >=dev-libs/crypto++-5.6.0-r1
+RDEPEND=">=dev-libs/crypto++-5.6.0-r1
sys-libs/zlib
x11-libs/libX11
>=x11-libs/qt-core-4.5
@@ -58,14 +57,15 @@ pkg_setup() {
if use python; then
python_set_active_version 2
+ python_pkg_setup
fi
}
src_prepare() {
subversion_wc_info
VERSIO_PRAESENS="${ESVN_WC_REVISION}"
- elog "Setting revision number to ${VERSIO_PRAESENS}"
- sed -e "/#define KVI_DEFAULT_FRAME_CAPTION/s/KVI_VERSION/& \" r${VERSIO_PRAESENS}\"/" -i src/kvirc/ui/kvi_frame.cpp || die "Failed to set revision number"
+ einfo "Setting of revision number to ${VERSIO_PRAESENS}"
+ sed -e "/#define KVI_DEFAULT_FRAME_CAPTION/s/KVI_VERSION/& \" r${VERSIO_PRAESENS}\"/" -i src/kvirc/ui/KviMainWindow.cpp || die "Setting of revision number failed"
}
src_configure() {