summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-10-31 03:53:03 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-10-31 03:53:03 +0000
commit2b866e91951ae0142012f3da66a488782d7b9329 (patch)
tree259564036529781021ab2a539f85e3281952946e /net-irc
parentadd 'rm old' to Changelog (diff)
downloadgentoo-2-2b866e91951ae0142012f3da66a488782d7b9329.tar.gz
gentoo-2-2b866e91951ae0142012f3da66a488782d7b9329.tar.bz2
gentoo-2-2b866e91951ae0142012f3da66a488782d7b9329.zip
Bump
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/irker/ChangeLog7
-rw-r--r--net-irc/irker/irker-2.12.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/net-irc/irker/ChangeLog b/net-irc/irker/ChangeLog
index dc2d738ddd4f..19e51f2c151d 100644
--- a/net-irc/irker/ChangeLog
+++ b/net-irc/irker/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/irker
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/irker/ChangeLog,v 1.17 2014/07/06 12:54:39 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irker/ChangeLog,v 1.18 2014/10/31 03:53:03 patrick Exp $
+
+*irker-2.12 (31 Oct 2014)
+
+ 31 Oct 2014; Patrick Lauer <patrick@gentoo.org> +irker-2.12.ebuild:
+ Bump
06 Jul 2014; Michał Górny <mgorny@gentoo.org> irker-2.11.ebuild,
irker-2.9.ebuild:
diff --git a/net-irc/irker/irker-2.12.ebuild b/net-irc/irker/irker-2.12.ebuild
new file mode 100644
index 000000000000..40fc3dc06268
--- /dev/null
+++ b/net-irc/irker/irker-2.12.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irker/irker-2.12.ebuild,v 1.1 2014/10/31 03:53:03 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+PYTHON_REQ_USE="ssl"
+
+inherit python-single-r1 eutils
+
+DESCRIPTION="Submission tools for IRC notifications"
+HOMEPAGE="http://www.catb.org/esr/irker/"
+SRC_URI="http://www.catb.org/esr/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-text/docbook-xml-dtd:4.1.2
+ app-text/xmlto"
+
+src_prepare() {
+ # https://gitorious.org/irker/irker/merge_requests/25
+ epatch "${FILESDIR}/2.7-Register-author_name-as-author-instead-of-email-user.patch"
+
+ epatch "${FILESDIR}/2.7-irkerhook-Remove-file-listing.patch"
+
+ # Prefix support
+ sed -i -e "/^ExecStart=/ s:=/:=${EROOT}:" irkerd.service
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ python_doscript "${ED}/usr/bin/irkerd"
+ # Not installed with the default Makefile
+ python_doscript irk irkerhook.py
+
+ newinitd "${FILESDIR}/irkerd.initd" irkerd
+ newconfd "${FILESDIR}/irkerd.confd" irkerd
+
+ dodoc NEWS README hacking.txt security.txt
+ dohtml irkerd.html irkerhook.html
+
+ docinto examples
+ dodoc filter-example.py filter-test.py
+}