summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-06-17 06:32:03 +0000
committerPatrick Lauer <patrick@gentoo.org>2015-06-17 06:32:03 +0000
commit25d3fa442e9dd4dd32945047daa973d85e5c7cdc (patch)
tree0a317b2b599b54b7fdfb3054acb77fe5fbe36b09 /net-irc
parentBackport security fix. (diff)
downloadgentoo-2-25d3fa442e9dd4dd32945047daa973d85e5c7cdc.tar.gz
gentoo-2-25d3fa442e9dd4dd32945047daa973d85e5c7cdc.tar.bz2
gentoo-2-25d3fa442e9dd4dd32945047daa973d85e5c7cdc.zip
Bump
(Portage version: 2.2.20/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/irker/ChangeLog7
-rw-r--r--net-irc/irker/irker-2.13.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/net-irc/irker/ChangeLog b/net-irc/irker/ChangeLog
index 57356aad20a1..bbbfaab45d59 100644
--- a/net-irc/irker/ChangeLog
+++ b/net-irc/irker/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/irker
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/irker/ChangeLog,v 1.20 2015/04/08 18:01:55 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irker/ChangeLog,v 1.21 2015/06/17 06:32:03 patrick Exp $
+
+*irker-2.13 (17 Jun 2015)
+
+ 17 Jun 2015; Patrick Lauer <patrick@gentoo.org> +irker-2.13.ebuild:
+ Bump
08 Apr 2015; Michał Górny <mgorny@gentoo.org> irker-2.11.ebuild,
irker-2.12.ebuild, irker-2.9.ebuild:
diff --git a/net-irc/irker/irker-2.13.ebuild b/net-irc/irker/irker-2.13.ebuild
new file mode 100644
index 000000000000..d96003704ddf
--- /dev/null
+++ b/net-irc/irker/irker-2.13.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irker/irker-2.13.ebuild,v 1.1 2015/06/17 06:32:03 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="ssl"
+
+inherit python-single-r1 eutils
+
+DESCRIPTION="Submission tools for IRC notifications"
+HOMEPAGE="http://www.catb.org/esr/irker/"
+SRC_URI="http://www.catb.org/esr/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-text/docbook-xml-dtd:4.1.2
+ app-text/xmlto"
+
+src_prepare() {
+ # https://gitorious.org/irker/irker/merge_requests/25
+ epatch "${FILESDIR}/2.7-Register-author_name-as-author-instead-of-email-user.patch"
+
+ epatch "${FILESDIR}/2.7-irkerhook-Remove-file-listing.patch"
+
+ # Prefix support
+ sed -i -e "/^ExecStart=/ s:=/:=${EROOT}:" irkerd.service
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ python_doscript "${ED}/usr/bin/irkerd"
+ # Not installed with the default Makefile
+ python_doscript irk irkerhook.py
+
+ newinitd "${FILESDIR}/irkerd.initd" irkerd
+ newconfd "${FILESDIR}/irkerd.confd" irkerd
+
+ dodoc NEWS README hacking.txt security.txt
+ dohtml irkerd.html irkerhook.html
+
+ docinto examples
+ dodoc filter-example.py filter-test.py
+}