summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Horelick <jdhore@gentoo.org>2012-04-20 02:41:42 +0000
committerJeff Horelick <jdhore@gentoo.org>2012-04-20 02:41:42 +0000
commit193b196e09fe9cd50447c55854e75407f3986939 (patch)
tree6c4b6afa9e40609759e33d623398aa185b35a9f9 /net-irc
parentRemove older unstable version (diff)
downloadgentoo-2-193b196e09fe9cd50447c55854e75407f3986939.tar.gz
gentoo-2-193b196e09fe9cd50447c55854e75407f3986939.tar.bz2
gentoo-2-193b196e09fe9cd50447c55854e75407f3986939.zip
Version bump to 7.0.0 and fix a possible bug in the live ebuild.
(Portage version: 2.2.0_alpha100/cvs/Linux i686)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/atheme-services/ChangeLog9
-rw-r--r--net-irc/atheme-services/atheme-services-7.0.0.ebuild116
-rw-r--r--net-irc/atheme-services/atheme-services-9999.ebuild13
-rw-r--r--net-irc/atheme-services/files/atheme-services-7.0.0-perl-build-fix.patch13
4 files changed, 145 insertions, 6 deletions
diff --git a/net-irc/atheme-services/ChangeLog b/net-irc/atheme-services/ChangeLog
index ed869a53bf82..d6e846c68b00 100644
--- a/net-irc/atheme-services/ChangeLog
+++ b/net-irc/atheme-services/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-irc/atheme-services
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme-services/ChangeLog,v 1.39 2012/04/20 02:36:07 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme-services/ChangeLog,v 1.40 2012/04/20 02:41:42 jdhore Exp $
+
+*atheme-services-7.0.0 (20 Apr 2012)
+
+ 20 Apr 2012; Jeff Horelick <jdhore@gentoo.org> +atheme-services-7.0.0.ebuild,
+ +files/atheme-services-7.0.0-perl-build-fix.patch,
+ atheme-services-9999.ebuild:
+ Version bump to 7.0.0 and fix a possible bug in the live ebuild.
20 Apr 2012; Jeff Horelick <jdhore@gentoo.org>
-atheme-services-7.0.0_alpha11.ebuild, -atheme-services-7.0.0_alpha9.ebuild,
diff --git a/net-irc/atheme-services/atheme-services-7.0.0.ebuild b/net-irc/atheme-services/atheme-services-7.0.0.ebuild
new file mode 100644
index 000000000000..ce2d3003490c
--- /dev/null
+++ b/net-irc/atheme-services/atheme-services-7.0.0.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme-services/atheme-services-7.0.0.ebuild,v 1.1 2012/04/20 02:41:42 jdhore Exp $
+
+EAPI=4
+
+inherit autotools eutils flag-o-matic perl-module
+
+DESCRIPTION="A portable and secure set of open-source and modular IRC services"
+HOMEPAGE="http://atheme.net/"
+SRC_URI="http://atheme.net/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd ~amd64-linux"
+IUSE="cracklib largenet ldap nls +pcre perl profile ssl"
+
+RDEPEND=">=dev-libs/libmowgli-2.0.0:2
+ cracklib? ( sys-libs/cracklib )
+ ldap? ( net-nds/openldap )
+ nls? ( sys-devel/gettext )
+ perl? ( dev-lang/perl )
+ pcre? ( dev-libs/libpcre )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ # the dependency calculation puts all of the .c files together and
+ # overwhelms cc1 with this flag :-(
+ filter-flags -combine
+
+ if use profile; then
+ # bug #371119
+ ewarn "USE=\"profile\" is incompatible with the hardened profile's -pie flag."
+ ewarn "Disabling PIE. Please ignore any warning messages about -nopie being invalid."
+ append-flags -nopie
+ fi
+
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/atheme ${PN}
+}
+
+src_prepare() {
+ # Fix broken version detection
+ sed -i -e 's/2.0.0-alpha1/2.0.0/' configure.ac || die
+ eautoconf
+
+ # fix docdir
+ sed -i -e 's/\(^DOCDIR.*=.\)@DOCDIR@/\1@docdir@/' extra.mk.in || die
+
+ # basic logging config directive fix
+ sed -i -e '/^logfile/s;var/\(.*\.log\);'"${EPREFIX}"'/var/log/atheme/\1;g' dist/* || die
+
+ # Fix a bug with compilation of the perl stuff.
+ epatch "$FILESDIR"/${P}-perl-build-fix.patch
+
+ # QA against bundled libs
+ rm -rf libmowgli-2 || die
+}
+
+src_configure() {
+ # perl scriping module support is also broken in 7.0.0. Yay for QA failures.
+ econf \
+ atheme_cv_c_gcc_w_error_implicit_function_declaration=no \
+ --sysconfdir="${EPREFIX}"/etc/${PN} \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --localstatedir="${EPREFIX}"/var \
+ --enable-fhs-paths \
+ --disable-warnings \
+ --enable-contrib \
+ $(use_enable largenet large-net) \
+ $(use_with cracklib) \
+ $(use_with ldap) \
+ $(use_with nls) \
+ $(use_enable profile) \
+ $(use_with pcre) \
+ $(use_with perl) \
+ $(use_enable ssl)
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ insinto /etc/${PN}
+ for conf in dist/*.example; do
+ # The .cron file isn't meant to live in /etc/${PN}, so only
+ # install a .example version.
+ [[ ${conf} == *cron* ]] && continue
+
+ newins ${conf} $(basename ${conf} .example)
+ done
+
+ fowners -R 0:${PN} /etc/${PN}
+ keepdir /var/{lib,log}/atheme
+ fowners ${PN}:${PN} /var/{lib,log,run}/atheme
+ fperms -R go-w,o-rx /etc/${PN}
+ fperms 750 /etc/${PN} /var/{lib,log,run}/atheme
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ mv "${ED}"/usr/bin/{,atheme-}dbverify || die
+
+ # contributed scripts and such:
+ insinto /usr/share/doc/${PF}/contrib
+ doins contrib/*.{c,pl,php,py,rb}
+
+ if use perl; then
+ perlinfo
+ insinto "${VENDOR_LIB#${EPREFIX}}"
+ doins -r contrib/Atheme{,.pm}
+ fi
+}
diff --git a/net-irc/atheme-services/atheme-services-9999.ebuild b/net-irc/atheme-services/atheme-services-9999.ebuild
index 440663628da6..8bad8a773657 100644
--- a/net-irc/atheme-services/atheme-services-9999.ebuild
+++ b/net-irc/atheme-services/atheme-services-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme-services/atheme-services-9999.ebuild,v 1.1 2012/02/21 00:11:34 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme-services/atheme-services-9999.ebuild,v 1.2 2012/04/20 02:41:42 jdhore Exp $
EAPI=4
-inherit git-2 user flag-o-matic perl-module
+inherit git-2 user eutils flag-o-matic perl-module
MY_P=${P/_/-}
@@ -60,9 +60,6 @@ src_prepare() {
# because it only contains a git submodule
# and removing it MAY break everything.
#rm -rf libmowgli-2 || die
-
- # Get useful information into build.log
- sed -i -e '/^\.SILENT:$/d' buildsys.mk.in || die
}
src_configure() {
@@ -84,6 +81,10 @@ src_configure() {
$(use_enable ssl)
}
+src_compile() {
+ emake V=1
+}
+
src_install() {
emake DESTDIR="${D}" install
@@ -104,6 +105,8 @@ src_install() {
newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ mv "${ED}"/usr/bin/{,atheme-}dbverify || die
+
# contributed scripts and such:
insinto /usr/share/doc/${PF}/contrib
doins contrib/*.{c,pl,php,py,rb}
diff --git a/net-irc/atheme-services/files/atheme-services-7.0.0-perl-build-fix.patch b/net-irc/atheme-services/files/atheme-services-7.0.0-perl-build-fix.patch
new file mode 100644
index 000000000000..196034e4ef0d
--- /dev/null
+++ b/net-irc/atheme-services/files/atheme-services-7.0.0-perl-build-fix.patch
@@ -0,0 +1,13 @@
+diff --git a/modules/scripting/perl/Makefile b/modules/scripting/perl/Makefile
+index b7e4dbd..bce7584 100644
+--- a/modules/scripting/perl/Makefile
++++ b/modules/scripting/perl/Makefile
+@@ -12,7 +12,7 @@ include ../../../buildsys.mk
+
+ plugindir = $(MODDIR)/modules/scripting
+
+-CPPFLAGS += -I../../../include -I. $(PERL_CFLAGS) -DPERL_MODDIR='"$(plugindir)"'
++CPPFLAGS += -I../../../include -I. $(PERL_CFLAGS) -DPERL_MODDIR=\"$(plugindir)\"
+ CFLAGS += $(PLUGIN_CFLAGS)
+ LDFLAGS += $(PLUGIN_LDFLAGS) $(PERL_LIBS)
+ LIBS += -L../../../libathemecore -lathemecore ${LDFLAGS_RPATH}