summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-01-21 11:32:01 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-01-21 11:32:01 +0000
commit1520185487804d58088961bdd2d4666c47de5349 (patch)
treee16d8cf3de6cc4a9a9696373a86076ccc91c186e /net-irc
parentAdd missing test dependency over sinatra. (diff)
downloadgentoo-2-1520185487804d58088961bdd2d4666c47de5349.tar.gz
gentoo-2-1520185487804d58088961bdd2d4666c47de5349.tar.bz2
gentoo-2-1520185487804d58088961bdd2d4666c47de5349.zip
Fix the X11 detection.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/quassel/ChangeLog6
-rw-r--r--net-irc/quassel/files/0.5.2-fix_x11_detection.patch25
-rw-r--r--net-irc/quassel/quassel-0.5.2.ebuild6
3 files changed, 34 insertions, 3 deletions
diff --git a/net-irc/quassel/ChangeLog b/net-irc/quassel/ChangeLog
index 845f05822fba..46a6f68e1f78 100644
--- a/net-irc/quassel/ChangeLog
+++ b/net-irc/quassel/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/quassel
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/ChangeLog,v 1.77 2010/01/19 12:10:21 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/ChangeLog,v 1.78 2010/01/21 11:32:01 scarabeus Exp $
+
+ 21 Jan 2010; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/0.5.2-fix_x11_detection.patch, quassel-0.5.2.ebuild:
+ Fix the X11 detection.
*quassel-0.5.2 (19 Jan 2010)
diff --git a/net-irc/quassel/files/0.5.2-fix_x11_detection.patch b/net-irc/quassel/files/0.5.2-fix_x11_detection.patch
new file mode 100644
index 000000000000..12f34fd67198
--- /dev/null
+++ b/net-irc/quassel/files/0.5.2-fix_x11_detection.patch
@@ -0,0 +1,25 @@
+From 8df3e82b02a980d4e00f3dc9c90c11e96501cf6f Mon Sep 17 00:00:00 2001
+From: Manuel Nickschas <sputnick@quassel-irc.org>
+Date: Tue, 19 Jan 2010 21:51:41 +0100
+Subject: [PATCH] Don't require X11 headers for building quasselcore
+
+---
+ cmake/modules/Qt4ConfigDependentSettings.cmake | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/cmake/modules/Qt4ConfigDependentSettings.cmake b/cmake/modules/Qt4ConfigDependentSettings.cmake
+index 1956aa5..a6b6c3d 100644
+--- a/cmake/modules/Qt4ConfigDependentSettings.cmake
++++ b/cmake/modules/Qt4ConfigDependentSettings.cmake
+@@ -27,7 +27,7 @@
+ IF(UNIX)
+ # on OS X X11 may not be required
+ IF (Q_WS_X11)
+- FIND_PACKAGE(X11 REQUIRED)
++ FIND_PACKAGE(X11)
+ ENDIF (Q_WS_X11)
+ FIND_PACKAGE(Threads)
+ SET(QT_QTCORE_LIBRARY ${QT_QTCORE_LIBRARY} ${CMAKE_THREAD_LIBS_INIT})
+--
+1.6.5.1
+
diff --git a/net-irc/quassel/quassel-0.5.2.ebuild b/net-irc/quassel/quassel-0.5.2.ebuild
index b6c204b60163..99336eab4b3e 100644
--- a/net-irc/quassel/quassel-0.5.2.ebuild
+++ b/net-irc/quassel/quassel-0.5.2.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-0.5.2.ebuild,v 1.1 2010/01/19 12:10:21 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-0.5.2.ebuild,v 1.2 2010/01/21 11:32:01 scarabeus Exp $
EAPI="2"
MY_P="${P/_/-}"
-inherit cmake-utils eutils
+inherit base cmake-utils eutils
DESCRIPTION="Qt4/KDE4 IRC client suppporting a remote daemon for 24/7 connectivity."
HOMEPAGE="http://quassel-irc.org/"
@@ -54,6 +54,8 @@ DOCS="AUTHORS ChangeLog README"
S="${WORKDIR}/${MY_P}"
+PATCHES=( "${FILESDIR}/0.5.2-fix_x11_detection.patch" )
+
pkg_setup() {
if ! use monolithic && ! use server && ! use X ; then
eerror "You have to build at least one of the monolithic client (USE=monolithic),"