summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-04-26 22:16:43 +0000
committerSven Wegener <swegener@gentoo.org>2005-04-26 22:16:43 +0000
commit117b1212c46a9c922cd0d7d5eead9fe636ae3276 (patch)
tree0678dab94f31312900be7b26965bce162451f03c /net-irc
parentInitial import (diff)
downloadgentoo-2-117b1212c46a9c922cd0d7d5eead9fe636ae3276.tar.gz
gentoo-2-117b1212c46a9c922cd0d7d5eead9fe636ae3276.tar.bz2
gentoo-2-117b1212c46a9c922cd0d7d5eead9fe636ae3276.zip
Set ownership of configuration files the right way. Fixes bug #90075.
(Portage version: 2.0.51.20-r5)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/unrealircd/ChangeLog5
-rw-r--r--net-irc/unrealircd/files/digest-unrealircd-3.2.2b1
-rw-r--r--net-irc/unrealircd/unrealircd-3.2.2b.ebuild125
-rw-r--r--net-irc/unrealircd/unrealircd-3.2.3.ebuild15
4 files changed, 11 insertions, 135 deletions
diff --git a/net-irc/unrealircd/ChangeLog b/net-irc/unrealircd/ChangeLog
index 1f80cb6bbddd..c0da51470785 100644
--- a/net-irc/unrealircd/ChangeLog
+++ b/net-irc/unrealircd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-irc/unrealircd
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/ChangeLog,v 1.30 2005/04/22 14:57:59 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/ChangeLog,v 1.31 2005/04/26 22:16:43 swegener Exp $
+
+ 26 Apr 2005; Sven Wegener <swegener@gentoo.org> unrealircd-3.2.3.ebuild:
+ Set ownership of configuration files the right way. Fixes bug #90075.
22 Apr 2005; Sven Wegener <swegener@gentoo.org> unrealircd-3.2.3.ebuild:
Marked stable on x86.
diff --git a/net-irc/unrealircd/files/digest-unrealircd-3.2.2b b/net-irc/unrealircd/files/digest-unrealircd-3.2.2b
deleted file mode 100644
index 72289e4aa66b..000000000000
--- a/net-irc/unrealircd/files/digest-unrealircd-3.2.2b
+++ /dev/null
@@ -1 +0,0 @@
-MD5 d6a90889ce937d77e6e63787d7b31b51 Unreal3.2.2b.tar.gz 1708120
diff --git a/net-irc/unrealircd/unrealircd-3.2.2b.ebuild b/net-irc/unrealircd/unrealircd-3.2.2b.ebuild
deleted file mode 100644
index ad32f0bfffbf..000000000000
--- a/net-irc/unrealircd/unrealircd-3.2.2b.ebuild
+++ /dev/null
@@ -1,125 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/unrealircd-3.2.2b.ebuild,v 1.1 2005/01/18 17:48:54 swegener Exp $
-
-inherit eutils ssl-cert
-
-MY_P=Unreal${PV}
-
-DESCRIPTION="aimed to be an advanced (not easy) IRCd"
-HOMEPAGE="http://www.unrealircd.com/"
-SRC_URI="http://www.gower.net/unrealircd/${MY_P}.tar.gz
- ftp://unreal.secure-tech.net/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc"
-IUSE="hub ipv6 ssl zlib"
-
-RDEPEND="ssl? ( dev-libs/openssl )
- zlib? ( sys-libs/zlib )"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
-
-S=${WORKDIR}/Unreal3.2
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- sed -i \
- -e "s:ircd\.pid:/var/run/unrealircd/ircd.pid:" \
- -e "s:ircd\.log:/var/log/unrealircd/ircd.log:" \
- -e "s:debug\.log:/var/log/unrealircd/debug.log:" \
- -e "s:ircd\.tune:/var/lib/unrealircd/ircd.tune:" \
- include/config.h
-}
-
-src_compile() {
- local myconf=""
- use hub && myconf="${myconf} --enable-hub"
- use ipv6 && myconf="${myconf} --enable-inet6"
- use zlib && myconf="${myconf} --enable-ziplinks"
- use ssl && myconf="${myconf} --enable-ssl"
-
- econf \
- --with-listen=5 \
- --with-dpath=${D}/etc/unrealircd \
- --with-spath=/usr/bin/unrealircd \
- --with-nick-history=2000 \
- --with-sendq=3000000 \
- --with-bufferpool=18 \
- --with-hostname=$(hostname -f) \
- --with-permissions=0600 \
- --with-fd-setsize=1024 \
- --enable-dynamic-linking \
- --enable-prefixaq \
- ${myconf} \
- || die "econf failed"
-
- sed -i \
- -e "s:${D}::" \
- include/setup.h \
- ircdcron/ircdchk
-
- emake IRCDDIR=/etc/unrealircd || die "emake failed"
-}
-
-src_install() {
- keepdir /var/{lib,log,run}/unrealircd || die "keepdir failed"
-
- newbin src/ircd unrealircd || die "newbin failed"
-
- exeinto /usr/lib/unrealircd/modules
- doexe src/modules/*.so || die "doexe failed"
-
- dodir /etc/unrealircd || die "dodir failed"
- dosym /var/lib/unrealircd /etc/unrealircd/tmp || die "dosym failed"
-
- insinto /etc/unrealircd
- doins {badwords.*,help,spamfilter,dccallow}.conf || die "doins failed"
- newins doc/example.conf unrealircd.conf || die "newins failed"
-
- use ssl \
- && docert server.cert \
- && dosym server.cert.key /etc/unrealircd/server.key.pem
-
- insinto /etc/unrealircd/aliases
- doins aliases/*.conf || die "doins failed"
- insinto /etc/unrealircd/networks
- doins networks/*.network || die "doins failed"
-
- sed -i \
- -e s:src/modules:/usr/lib/unrealircd/modules: \
- -e s:ircd\\.log:/var/log/unrealircd/ircd.log: \
- ${D}/etc/unrealircd/unrealircd.conf
-
- dodoc \
- Changes Donation Unreal.nfo networks/makenet \
- ircdcron/{ircd.cron,ircdchk} \
- || die "dodoc failed"
- dohtml doc/*.html || die "dohtml failed"
-
- newinitd ${FILESDIR}/unrealircd.rc unrealircd || die "newinitd failed"
- newconfd ${FILESDIR}/unrealircd.confd unrealircd || die "newconfd failed"
-
- fperms 700 /etc/unrealircd
-}
-
-pkg_postinst() {
- enewuser unrealircd
- chown unrealircd \
- ${ROOT}/{etc,var/{lib,log,run}}/unrealircd \
- ${ROOT}/etc/unrealircd/server.cert.{key,pem} \
- ${ROOT}/etc/unrealircd/*.conf
-
- einfo
- einfo "UnrealIRCd will not run until you've set up /etc/unrealircd/unrealircd.conf"
- einfo
- einfo "You can find example cron scripts here:"
- einfo " /usr/share/doc/${PF}/ircd.cron.gz"
- einfo " /usr/share/doc/${PF}/ircdchk.gz"
- einfo
- einfo "You can also use /etc/init.d/unrealircd to start at boot"
- einfo
-}
diff --git a/net-irc/unrealircd/unrealircd-3.2.3.ebuild b/net-irc/unrealircd/unrealircd-3.2.3.ebuild
index d27c26b08d3a..fbd628d82ca9 100644
--- a/net-irc/unrealircd/unrealircd-3.2.3.ebuild
+++ b/net-irc/unrealircd/unrealircd-3.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/unrealircd-3.2.3.ebuild,v 1.2 2005/04/22 14:57:59 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/unrealircd-3.2.3.ebuild,v 1.3 2005/04/26 22:16:43 swegener Exp $
inherit eutils ssl-cert versionator
@@ -24,6 +24,10 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/Unreal$(get_version_component_range 1-2)"
+pkg_setup() {
+ enewuser unrealircd
+}
+
src_unpack() {
unpack ${A}
cd ${S}
@@ -105,15 +109,10 @@ src_install() {
newconfd ${FILESDIR}/unrealircd.confd unrealircd || die "newconfd failed"
fperms 700 /etc/unrealircd
+ chown -R unrealircd ${D}/{etc,var/{lib,log,run}}/unrealircd
}
-pkg_postinst() {
- enewuser unrealircd
- chown unrealircd \
- ${ROOT}/{etc,var/{lib,log,run}}/unrealircd \
- ${ROOT}/etc/unrealircd/server.cert.{key,pem} \
- ${ROOT}/etc/unrealircd/*.conf
-
+pkg_postins() {
einfo
einfo "UnrealIRCd will not run until you've set up /etc/unrealircd/unrealircd.conf"
einfo