summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink <binki@gentoo.org>2011-11-08 02:47:43 +0000
committerNathan Phillip Brink <binki@gentoo.org>2011-11-08 02:47:43 +0000
commit0ef01bf06e35a02e5c28b17d7abb9cba565d92e4 (patch)
tree11d63dac7a34bedb0a33bd2ea9c3c776cae4fc32 /net-irc
parentDrop the indefinite mask on net-irc/atheme-services requested by upstream whi... (diff)
downloadgentoo-2-0ef01bf06e35a02e5c28b17d7abb9cba565d92e4.tar.gz
gentoo-2-0ef01bf06e35a02e5c28b17d7abb9cba565d92e4.tar.bz2
gentoo-2-0ef01bf06e35a02e5c28b17d7abb9cba565d92e4.zip
Bump to atheme-services-7.0.0_alpha9.
(Portage version: 2.2.0_alpha71-r1/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/atheme-services/ChangeLog8
-rw-r--r--net-irc/atheme-services/atheme-services-7.0.0_alpha9.ebuild108
2 files changed, 115 insertions, 1 deletions
diff --git a/net-irc/atheme-services/ChangeLog b/net-irc/atheme-services/ChangeLog
index c49084e9dc5a..a0fd31b6741d 100644
--- a/net-irc/atheme-services/ChangeLog
+++ b/net-irc/atheme-services/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/atheme-services
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme-services/ChangeLog,v 1.15 2011/11/08 02:08:07 binki Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme-services/ChangeLog,v 1.16 2011/11/08 02:47:43 binki Exp $
+
+*atheme-services-7.0.0_alpha9 (08 Nov 2011)
+
+ 08 Nov 2011; Nathan Phillip Brink <binki@gentoo.org>
+ +atheme-services-7.0.0_alpha9.ebuild:
+ Bump to atheme-services-7.0.0_alpha9.
*atheme-services-6.0.9 (08 Nov 2011)
diff --git a/net-irc/atheme-services/atheme-services-7.0.0_alpha9.ebuild b/net-irc/atheme-services/atheme-services-7.0.0_alpha9.ebuild
new file mode 100644
index 000000000000..1847421a0cc7
--- /dev/null
+++ b/net-irc/atheme-services/atheme-services-7.0.0_alpha9.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/atheme-services/atheme-services-7.0.0_alpha9.ebuild,v 1.1 2011/11/08 02:47:43 binki Exp $
+
+EAPI=4
+
+inherit flag-o-matic perl-module
+
+MY_P=${P/_/-}
+
+DESCRIPTION="A portable and secure set of open-source and modular IRC services"
+HOMEPAGE="http://atheme.net/"
+SRC_URI="http://atheme.net/downloads/${MY_P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86 ~x86-fbsd ~amd64-linux"
+IUSE="largenet ldap nls +pcre perl profile ssl"
+
+RDEPEND=">=dev-libs/libmowgli-0.9.95
+ ldap? ( net-nds/openldap )
+ nls? ( sys-devel/gettext )
+ perl? ( dev-lang/perl )
+ pcre? ( dev-libs/libpcre )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ # the dependency calculation puts all of the .c files together and
+ # overwhelms cc1 with this flag :-(
+ filter-flags -combine
+
+ if use profile; then
+ # bug #371119
+ ewarn "USE=\"profile\" is incompatible with the hardened profile's -pie flag."
+ ewarn "Disabling PIE. Please ignore any warning messages about -nopie being invalid."
+ append-flags -nopie
+ fi
+
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/atheme ${PN}
+}
+
+src_prepare() {
+ # fix docdir
+ sed -i -e 's/\(^DOCDIR.*=.\)@DOCDIR@/\1@docdir@/' extra.mk.in || die
+
+ # basic logging config directive fix
+ sed -i -e '/^logfile/s;var/\(.*\.log\);'"${EPREFIX}"'/var/log/atheme/\1;g' dist/* || die
+
+ # QA against bundled libs
+ rm -rf libmowgli libmowgli-2 || die
+
+ # Get useful information into build.log
+ sed -i -e '/^\.SILENT:$/d' buildsys.mk.in || die
+}
+
+src_configure() {
+ econf \
+ atheme_cv_c_gcc_w_error_implicit_function_declaration=no \
+ --sysconfdir="${EPREFIX}"/etc/${PN} \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --localstatedir="${EPREFIX}"/var \
+ --enable-fhs-paths \
+ --disable-warnings \
+ --enable-contrib \
+ $(use_enable largenet large-net) \
+ $(use_with ldap) \
+ $(use_with nls) \
+ $(use_enable profile) \
+ $(use_with perl) \
+ $(use_with pcre) \
+ $(use_enable ssl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ insinto /etc/${PN}
+ for conf in dist/*.example; do
+ # The .cron file isn't meant to live in /etc/${PN}, so only
+ # install a .example version.
+ [[ ${conf} == *cron* ]] && continue
+
+ newins ${conf} $(basename ${conf} .example)
+ done
+
+ fowners -R 0:${PN} /etc/${PN}
+ keepdir /var/{lib,log}/atheme
+ fowners ${PN}:${PN} /var/{lib,log,run}/atheme
+ fperms -R go-w,o-rx /etc/${PN}
+ fperms 750 /etc/${PN} /var/{lib,log,run}/atheme
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+
+ # contributed scripts and such:
+ insinto /usr/share/doc/${PF}/contrib
+ doins contrib/*.{c,pl,php,py,rb}
+
+ if use perl; then
+ perlinfo
+ insinto "${VENDOR_LIB#${EPREFIX}}"
+ doins -r contrib/Atheme{,.pm}
+ fi
+}