summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-02-12 03:12:35 +0000
committerTim Harder <radhermit@gentoo.org>2014-02-12 03:12:35 +0000
commit090a07eb8a22f4d0b06642a48319922ecd308a49 (patch)
treea09fb7142ebcca4b046deed865cf6f3a324559dc /net-irc
parentRemove empty description from metadata. (diff)
downloadgentoo-2-090a07eb8a22f4d0b06642a48319922ecd308a49.tar.gz
gentoo-2-090a07eb8a22f4d0b06642a48319922ecd308a49.tar.bz2
gentoo-2-090a07eb8a22f4d0b06642a48319922ecd308a49.zip
Version bump, move to git-r3 eclass.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/weechat/ChangeLog10
-rw-r--r--net-irc/weechat/weechat-0.4.3.ebuild130
-rw-r--r--net-irc/weechat/weechat-9999.ebuild9
3 files changed, 142 insertions, 7 deletions
diff --git a/net-irc/weechat/ChangeLog b/net-irc/weechat/ChangeLog
index a46b1ec4b2cc..701416b4ab83 100644
--- a/net-irc/weechat/ChangeLog
+++ b/net-irc/weechat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/weechat
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/ChangeLog,v 1.135 2013/10/29 17:12:48 scarabeus Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/ChangeLog,v 1.136 2014/02/12 03:12:35 radhermit Exp $
+
+*weechat-0.4.3 (12 Feb 2014)
+
+ 12 Feb 2014; Tim Harder <radhermit@gentoo.org> +weechat-0.4.3.ebuild,
+ weechat-9999.ebuild:
+ Version bump, move to git-r3 eclass.
*weechat-0.4.2 (29 Oct 2013)
diff --git a/net-irc/weechat/weechat-0.4.3.ebuild b/net-irc/weechat/weechat-0.4.3.ebuild
new file mode 100644
index 000000000000..f402af12a3b3
--- /dev/null
+++ b/net-irc/weechat/weechat-0.4.3.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/weechat-0.4.3.ebuild,v 1.1 2014/02/12 03:12:35 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
+
+EGIT_REPO_URI="git://git.sv.gnu.org/weechat.git"
+[[ ${PV} == "9999" ]] && GIT_ECLASS="git-r3"
+inherit eutils python-single-r1 multilib cmake-utils ${GIT_ECLASS}
+
+DESCRIPTION="Portable and multi-interface IRC client."
+HOMEPAGE="http://weechat.org/"
+[[ ${PV} == "9999" ]] || SRC_URI="http://${PN}.org/files/src/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+if [[ ${PV} == "9999" ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~ppc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+fi
+
+NETWORKS="+irc"
+PLUGINS="+alias +charset +fifo +logger +relay +rmodifier +scripts +spell +xfer"
+#INTERFACES="+ncurses gtk"
+SCRIPT_LANGS="guile lua +perl +python ruby tcl"
+IUSE="${SCRIPT_LANGS} ${PLUGINS} ${INTERFACES} ${NETWORKS} doc nls +ssl"
+
+RDEPEND="
+ dev-libs/libgcrypt
+ net-misc/curl[ssl]
+ sys-libs/ncurses
+ sys-libs/zlib
+ charset? ( virtual/libiconv )
+ guile? ( dev-scheme/guile )
+ lua? ( dev-lang/lua[deprecated] )
+ nls? ( virtual/libintl )
+ perl? ( dev-lang/perl )
+ python? ( ${PYTHON_DEPS} )
+ ruby? ( >=dev-lang/ruby-1.9 )
+ ssl? ( net-libs/gnutls )
+ spell? ( app-text/aspell )
+ tcl? ( >=dev-lang/tcl-8.4.15 )
+"
+# ncurses? ( sys-libs/ncurses )
+# gtk? ( x11-libs/gtk+:2 )
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/asciidoc
+ dev-util/source-highlight
+ )
+ nls? ( >=sys-devel/gettext-0.15 )
+"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+#REQUIRED_USE=" || ( ncurses gtk )"
+
+LANGS=( cs de es fr hu it ja pl pt_BR ru )
+for X in "${LANGS[@]}" ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ local i
+
+ # fix libdir placement
+ sed -i \
+ -e "s:lib/:$(get_libdir)/:g" \
+ -e "s:lib\":$(get_libdir)\":g" \
+ CMakeLists.txt || die "sed failed"
+
+ # install only required translations
+ for i in "${LANGS[@]}" ; do
+ if ! use linguas_${i} ; then
+ sed -i \
+ -e "/${i}.po/d" \
+ po/CMakeLists.txt || die
+ fi
+ done
+
+ # install only required documentation ; en always
+ for i in `grep ADD_SUBDIRECTORY doc/CMakeLists.txt \
+ | sed -e 's/.*ADD_SUBDIRECTORY( \(..\) ).*/\1/' -e '/en/d'`; do
+ if ! use linguas_${i} ; then
+ sed -i \
+ -e '/ADD_SUBDIRECTORY( '${i}' )/d' \
+ doc/CMakeLists.txt || die
+ fi
+ done
+}
+
+src_configure() {
+ # $(cmake-utils_use_enable gtk)
+ # $(cmake-utils_use_enable ncurses)
+ local mycmakeargs=(
+ "-DENABLE_NCURSES=ON"
+ "-DENABLE_LARGEFILE=ON"
+ "-DENABLE_DEMO=OFF"
+ "-DENABLE_GTK=OFF"
+ "-DPYTHON_EXECUTABLE=${PYTHON}"
+ $(cmake-utils_use_enable alias)
+ $(cmake-utils_use_enable doc)
+ $(cmake-utils_use_enable charset)
+ $(cmake-utils_use_enable fifo)
+ $(cmake-utils_use_enable guile)
+ $(cmake-utils_use_enable irc)
+ $(cmake-utils_use_enable logger)
+ $(cmake-utils_use_enable lua)
+ $(cmake-utils_use_enable nls)
+ $(cmake-utils_use_enable perl)
+ $(cmake-utils_use_enable python)
+ $(cmake-utils_use_enable relay)
+ $(cmake-utils_use_enable rmodifier)
+ $(cmake-utils_use_enable ruby)
+ $(cmake-utils_use_enable scripts)
+ $(cmake-utils_use_enable scripts script)
+ $(cmake-utils_use_enable spell ASPELL)
+ $(cmake-utils_use_enable ssl GNUTLS)
+ $(cmake-utils_use_enable tcl)
+ $(cmake-utils_use_enable xfer)
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/net-irc/weechat/weechat-9999.ebuild b/net-irc/weechat/weechat-9999.ebuild
index 309649078f83..84c348a06483 100644
--- a/net-irc/weechat/weechat-9999.ebuild
+++ b/net-irc/weechat/weechat-9999.ebuild
@@ -1,13 +1,12 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/weechat-9999.ebuild,v 1.29 2013/07/27 20:11:11 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/weechat-9999.ebuild,v 1.30 2014/02/12 03:12:35 radhermit Exp $
EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_2 python3_3 )
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
EGIT_REPO_URI="git://git.sv.gnu.org/weechat.git"
-[[ ${PV} == "9999" ]] && GIT_ECLASS="git-2"
+[[ ${PV} == "9999" ]] && GIT_ECLASS="git-r3"
inherit eutils python-single-r1 multilib cmake-utils ${GIT_ECLASS}
DESCRIPTION="Portable and multi-interface IRC client."