summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2006-10-19 22:08:18 +0000
committerMarkus Ullmann <jokey@gentoo.org>2006-10-19 22:08:18 +0000
commit00092d0160fc70e5cc528dcd77871e816312017b (patch)
tree299800f0f8f81951abf0565968b496af364a7f8b /net-irc
parentrevision bump (diff)
downloadgentoo-2-00092d0160fc70e5cc528dcd77871e816312017b.tar.gz
gentoo-2-00092d0160fc70e5cc528dcd77871e816312017b.tar.bz2
gentoo-2-00092d0160fc70e5cc528dcd77871e816312017b.zip
Version bump wrt bug #149927 and cleanup
(Portage version: 2.1.2_pre3-r4)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/ngircd/ChangeLog8
-rw-r--r--net-irc/ngircd/files/digest-ngircd-0.10.03
-rw-r--r--net-irc/ngircd/files/digest-ngircd-0.8.32
-rw-r--r--net-irc/ngircd/ngircd-0.10.0.ebuild55
4 files changed, 67 insertions, 1 deletions
diff --git a/net-irc/ngircd/ChangeLog b/net-irc/ngircd/ChangeLog
index d21efcda09a4..376d7519ff11 100644
--- a/net-irc/ngircd/ChangeLog
+++ b/net-irc/ngircd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/ngircd
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/ngircd/ChangeLog,v 1.20 2006/02/15 16:17:04 antarus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ngircd/ChangeLog,v 1.21 2006/10/19 22:08:18 jokey Exp $
+
+*ngircd-0.10.0 (18 Oct 2006)
+
+ 18 Oct 2006; Markus Ullmann <jokey@gentoo.org> -ngircd-0.8.3-r1.ebuild,
+ -ngircd-0.9.2.ebuild, +ngircd-0.10.0.ebuild:
+ Version bump wrt bug #149927 and cleanup
15 Feb 2006; Alec Warner <antarus@gentoo.org> ngircd-0.9.2-r1.ebuild
Fixed an error in IUSE reported by Ciaran <ciaranm@gentoo.org>
diff --git a/net-irc/ngircd/files/digest-ngircd-0.10.0 b/net-irc/ngircd/files/digest-ngircd-0.10.0
new file mode 100644
index 000000000000..9eed718fefdc
--- /dev/null
+++ b/net-irc/ngircd/files/digest-ngircd-0.10.0
@@ -0,0 +1,3 @@
+MD5 6d963a3ed3f24af6fd848371dd315ff4 ngircd-0.10.0.tar.gz 306983
+RMD160 588ebb2125c68176591db89ef8e30991ea5a6bf4 ngircd-0.10.0.tar.gz 306983
+SHA256 64f82f728dd4bdb999c1e03ee30a5addb3866ecfaca013ce5c729f472738f6de ngircd-0.10.0.tar.gz 306983
diff --git a/net-irc/ngircd/files/digest-ngircd-0.8.3 b/net-irc/ngircd/files/digest-ngircd-0.8.3
index 543e599db7a0..85bd97e8cf3c 100644
--- a/net-irc/ngircd/files/digest-ngircd-0.8.3
+++ b/net-irc/ngircd/files/digest-ngircd-0.8.3
@@ -1 +1,3 @@
MD5 ee977ef8da1a0f637ce992280c7f1ca2 ngircd-0.8.3.tar.gz 276725
+RMD160 1362ed20c17740ff249fe8247799419dadc5f8d6 ngircd-0.8.3.tar.gz 276725
+SHA256 0e83aa269e0b3e239e64b6354ec24ba4f7365eff22730e105747635587575bb9 ngircd-0.8.3.tar.gz 276725
diff --git a/net-irc/ngircd/ngircd-0.10.0.ebuild b/net-irc/ngircd/ngircd-0.10.0.ebuild
new file mode 100644
index 000000000000..fb20be733fe8
--- /dev/null
+++ b/net-irc/ngircd/ngircd-0.10.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ngircd/ngircd-0.10.0.ebuild,v 1.1 2006/10/19 22:08:18 jokey Exp $
+
+inherit eutils
+
+DESCRIPTION="A IRC server written from scratch."
+HOMEPAGE="http://arthur.ath.cx/~alex/ngircd/"
+SRC_URI="ftp://download.berlios.de/pub/${PN}/${P}.tar.gz
+ ftp://ftp.berlios.de/pub/${PN}/${P}.tar.gz
+ ftp://arthur.ath.cx/pub/Users/alex/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="zlib tcpd debug ident"
+
+DEPEND="virtual/libc
+ zlib? ( sys-libs/zlib )
+ ident? ( net-libs/libident )
+ tcpd? ( sys-apps/tcp-wrappers )
+ >=sys-apps/sed-4"
+
+src_compile() {
+ econf \
+ --sysconfdir=/etc/ngircd \
+ $(use_with zlib) \
+ $(use_with tcpd tcp-wrappers) \
+ $(use_with ident ) \
+ $(use_enable debug) \
+ $(use_enable debug sniffer) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ sed -i \
+ -e "s:/usr/local/etc/ngircd.motd:/etc/ngircd/ngircd.motd:" \
+ -e "s:;ServerUID = 65534:ServerUID = ngircd:" \
+ -e "s:;ServerGID = 65534:ServerGID = nogroup:" \
+ doc/sample-ngircd.conf
+
+ make \
+ DESTDIR="${D}" \
+ docdir=/usr/share/doc/${PF} \
+ install || die "make install failed"
+
+ newinitd "${FILESDIR}"/ngircd.init.d ngircd
+}
+
+pkg_postinst() {
+ enewuser ngircd
+ chown ngircd "${ROOT}"/etc/ngircd/ngircd.conf
+}