summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2004-12-04 22:44:57 +0000
committerSven Wegener <swegener@gentoo.org>2004-12-04 22:44:57 +0000
commitb4478decdeb6cbd5d087d452b6deb2bfc844a56e (patch)
tree30591f6de858c265e24a2a408d9626d2edba07f8 /net-irc/xchatosd
parentGeneral version bumps for some more GNUstep apps (Manifest recommit) (diff)
downloadgentoo-2-b4478decdeb6cbd5d087d452b6deb2bfc844a56e.tar.gz
gentoo-2-b4478decdeb6cbd5d087d452b6deb2bfc844a56e.tar.bz2
gentoo-2-b4478decdeb6cbd5d087d452b6deb2bfc844a56e.zip
Added a patch that fixes wrong return value checking. Closes bug #72481.
Diffstat (limited to 'net-irc/xchatosd')
-rw-r--r--net-irc/xchatosd/ChangeLog6
-rw-r--r--net-irc/xchatosd/files/5.12-return-values.patch39
-rw-r--r--net-irc/xchatosd/xchatosd-5.12.ebuild6
3 files changed, 49 insertions, 2 deletions
diff --git a/net-irc/xchatosd/ChangeLog b/net-irc/xchatosd/ChangeLog
index 39d943dbca1b..de50ede3a35c 100644
--- a/net-irc/xchatosd/ChangeLog
+++ b/net-irc/xchatosd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/xchatosd
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchatosd/ChangeLog,v 1.4 2004/10/01 01:14:58 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchatosd/ChangeLog,v 1.5 2004/12/04 22:44:57 swegener Exp $
+
+ 04 Dec 2004; Sven Wegener <swegener@gentoo.org>
+ +files/5.12-return-values.patch, xchatosd-5.12.ebuild:
+ Added a patch that fixes wrong return value checking. Closes bug #72481.
01 Oct 2004; Sven Wegener <swegener@gentoo.org> xchatosd-5.12.ebuild:
Marked stable on x86.
diff --git a/net-irc/xchatosd/files/5.12-return-values.patch b/net-irc/xchatosd/files/5.12-return-values.patch
new file mode 100644
index 000000000000..5c82d62f8b4d
--- /dev/null
+++ b/net-irc/xchatosd/files/5.12-return-values.patch
@@ -0,0 +1,39 @@
+diff -Nur xchatosd-5.12.orig/xchatosd.c xchatosd-5.12/xchatosd.c
+--- xchatosd-5.12.orig/xchatosd.c 2004-12-04 23:30:10.621652464 +0100
++++ xchatosd-5.12/xchatosd.c 2004-12-04 23:31:10.636339349 +0100
+@@ -192,16 +192,25 @@
+ }
+ int status = 0;
+
+- status += xosd_set_pos(osd, conf.pos);
+- status += xosd_set_vertical_offset(osd, conf.voffset);
+- status += xosd_set_horizontal_offset(osd, conf.hoffset);
+- status += xosd_set_align(osd, conf.align);
+- status += xosd_set_shadow_offset(osd, conf.shadow_offset);
+- status += xosd_set_timeout(osd, conf.timeout);
+- status += xosd_set_font(osd, conf.font);
+- status += xosd_set_colour(osd, conf.color);
+- status += xosd_display(osd, 0, XOSD_string, MSG_Hello);
+- return status;
++ status = xosd_set_pos(osd, conf.pos);
++ if (-1 == status) return -1;
++ status = xosd_set_vertical_offset(osd, conf.voffset);
++ if (-1 == status) return -1;
++ status = xosd_set_horizontal_offset(osd, conf.hoffset);
++ if (-1 == status) return -1;
++ status = xosd_set_align(osd, conf.align);
++ if (-1 == status) return -1;
++ status = xosd_set_shadow_offset(osd, conf.shadow_offset);
++ if (-1 == status) return -1;
++ status = xosd_set_timeout(osd, conf.timeout);
++ if (-1 == status) return -1;
++ status = xosd_set_font(osd, conf.font);
++ if (-1 == status) return -1;
++ status = xosd_set_colour(osd, conf.color);
++ if (-1 == status) return -1;
++ status = xosd_display(osd, 0, XOSD_string, MSG_Hello);
++ if (-1 == status) return -1;
++ return 0;
+ }
+
+ #ifdef ICONV_LIB
diff --git a/net-irc/xchatosd/xchatosd-5.12.ebuild b/net-irc/xchatosd/xchatosd-5.12.ebuild
index bd44d9af7bed..06dfa228fd2b 100644
--- a/net-irc/xchatosd/xchatosd-5.12.ebuild
+++ b/net-irc/xchatosd/xchatosd-5.12.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchatosd/xchatosd-5.12.ebuild,v 1.4 2004/10/01 01:14:58 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchatosd/xchatosd-5.12.ebuild,v 1.5 2004/12/04 22:44:57 swegener Exp $
+
+inherit eutils
DESCRIPTION="On-Screen Display for XChat"
HOMEPAGE="http://sourceforge.net/projects/xchatosd/"
@@ -19,6 +21,8 @@ src_unpack() {
unpack ${A}
cd ${S}
+ epatch ${FILESDIR}/${PV}-return-values.patch
+
# We have our own include file in /usr/include/xchat
einfo "Updating xchat-plugin.h from /usr/include/xchat/xchat-plugin.h"
cp -f ${ROOT}/usr/include/xchat/xchat-plugin.h xchat-plugin.h