summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-04-03 18:08:12 +0000
committerSven Wegener <swegener@gentoo.org>2005-04-03 18:08:12 +0000
commit6fdeeb7b7c52a0d6be89149ab191e6fc03802898 (patch)
tree4722741e003edc8e34756e6bf0220a1f96aa8dac /net-irc/xchat
parentRe-added xbox support (bug #80989) (diff)
downloadgentoo-2-6fdeeb7b7c52a0d6be89149ab191e6fc03802898.tar.gz
gentoo-2-6fdeeb7b7c52a0d6be89149ab191e6fc03802898.tar.bz2
gentoo-2-6fdeeb7b7c52a0d6be89149ab191e6fc03802898.zip
Removed old ebuilds.
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-irc/xchat')
-rw-r--r--net-irc/xchat/ChangeLog6
-rw-r--r--net-irc/xchat/files/digest-xchat-2.0.92
-rw-r--r--net-irc/xchat/files/digest-xchat-2.4.02
-rw-r--r--net-irc/xchat/xchat-2.0.9.ebuild87
-rw-r--r--net-irc/xchat/xchat-2.4.0.ebuild90
5 files changed, 5 insertions, 182 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index db1113f31d4d..37de0b4000d0 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/xchat
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.154 2005/04/03 15:38:59 hardave Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.155 2005/04/03 18:08:12 swegener Exp $
+
+ 03 Apr 2005; Sven Wegener <swegener@gentoo.org> -xchat-2.0.9.ebuild,
+ -xchat-2.4.0.ebuild:
+ Removed old ebuilds.
03 Apr 2005; Hardave Riar <hardave@gentoo.org> xchat-2.4.1-r1.ebuild:
Stable on mips.
diff --git a/net-irc/xchat/files/digest-xchat-2.0.9 b/net-irc/xchat/files/digest-xchat-2.0.9
deleted file mode 100644
index 10817799bdd7..000000000000
--- a/net-irc/xchat/files/digest-xchat-2.0.9
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 8a38f161176cc2c54b32bbe5e51e3fc7 xchat-2.0.9.tar.bz2 1093203
-MD5 064010843fe56d2b17acc8a0bbc83b11 xc209-fixbidi.diff 1719
diff --git a/net-irc/xchat/files/digest-xchat-2.4.0 b/net-irc/xchat/files/digest-xchat-2.4.0
deleted file mode 100644
index 379df169720c..000000000000
--- a/net-irc/xchat/files/digest-xchat-2.4.0
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 084585b765509d5da355155189b16ecd xchat-2.4.0.tar.bz2 1159266
-MD5 4e66cb157c70b8d02f74238dc9a5057c xchat-dccserver-0.4.patch 11767
diff --git a/net-irc/xchat/xchat-2.0.9.ebuild b/net-irc/xchat/xchat-2.0.9.ebuild
deleted file mode 100644
index 91865b34bec5..000000000000
--- a/net-irc/xchat/xchat-2.0.9.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.0.9.ebuild,v 1.10 2005/01/01 07:38:41 swegener Exp $
-
-inherit flag-o-matic eutils
-
-DESCRIPTION="Graphical IRC client"
-SRC_URI="http://www.xchat.org/files/source/2.0/${P}.tar.bz2
- http://www.xchat.org/files/source/2.0/patches/xc209-fixbidi.diff"
-HOMEPAGE="http://www.xchat.org/"
-
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="x86 sparc hppa ppc alpha amd64 ia64 ~mips"
-IUSE="perl tcltk python ssl mmx ipv6 nls xchattext xchatnogtk"
-
-# Added for to fix a sparc seg fault issue by Jason Wever <weeve@gentoo.org>
-if [ ${ARCH} = "sparc" ]
-then
- replace-flags "-O3" "-O2"
-fi
-
-
-RDEPEND=">=dev-libs/glib-2.0.3
- !xchatnogtk? ( >=x11-libs/gtk+-2.0.3 )
- perl? ( >=dev-lang/perl-5.6.1 )
- ssl? ( >=dev-libs/openssl-0.9.6d )
- python? ( dev-lang/python )
- tcltk? ( dev-lang/tcl )"
-
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.7
- nls? ( sys-devel/gettext )"
-
-src_unpack() {
-
- unpack ${A}
- cd ${S}
-
- epatch ${DISTDIR}/xc209-fixbidi.diff
-
-}
-
-src_compile() {
-
- # xchat's configure script uses sys.path to find library path
- # instead of python-config (#25943)
- unset PYTHONPATH
-
- # test for local usage of xchatnogtk
- local gtkconf
- use xchatnogtk \
- && gtkconf="--disable-gtkfe" \
- || gtkconf="--enable-gtkfe"
-
- econf \
- ${gtkconf} \
- `use_enable ssl openssl` \
- `use_enable perl` \
- `use_enable python` \
- `use_enable tcltk tcl` \
- `use_enable mmx` \
- `use_enable ipv6` \
- `use_enable nls` \
- `use_enable xchattext textfe` \
- --program-suffix=-2 \
- || die "Configure failed"
-
- emake || die "Compile failed"
-
-}
-
-src_install() {
-
- # some magic to create a menu entry for xchat 2
- mv xchat.desktop xchat.desktop.old
- sed -e "s:Exec=xchat:Exec=xchat-2:" -e "s:Name=XChat IRC:Name=XChat 2 IRC:" xchat.desktop.old > xchat.desktop
-
- einstall install || die "Install failed"
-
- # install plugin development header
- insinto /usr/include/xchat
- doins src/common/xchat-plugin.h
-
- dodoc AUTHORS COPYING ChangeLog README*
-
-}
diff --git a/net-irc/xchat/xchat-2.4.0.ebuild b/net-irc/xchat/xchat-2.4.0.ebuild
deleted file mode 100644
index f7d43e3524fe..000000000000
--- a/net-irc/xchat/xchat-2.4.0.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.4.0.ebuild,v 1.13 2005/01/01 07:38:41 swegener Exp $
-
-inherit flag-o-matic eutils
-
-DESCRIPTION="Graphical IRC client"
-SRC_URI="http://www.xchat.org/files/source/2.4/${P}.tar.bz2
- xchatdccserver? ( http://dfx.at/xchat/xchat-dccserver-0.4.patch )"
-HOMEPAGE="http://www.xchat.org/"
-
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="x86 sparc hppa ppc alpha amd64 ~ia64 mips ppc64"
-IUSE="perl tcltk python ssl mmx ipv6 nls xchattext xchatnogtk xchatdccserver"
-
-# Added for to fix a sparc seg fault issue by Jason Wever <weeve@gentoo.org>
-if [ ${ARCH} = "sparc" ]
-then
- replace-flags "-O3" "-O2"
-fi
-
-RDEPEND=">=dev-libs/glib-2.0.3
- !xchatnogtk? ( >=x11-libs/gtk+-2.0.3 )
- ssl? ( >=dev-libs/openssl-0.9.6d )
- perl? ( >=dev-lang/perl-5.6.1 )
- python? ( dev-lang/python )
- tcltk? ( dev-lang/tcl )"
-
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.7
- >=sys-apps/sed-4
- nls? ( sys-devel/gettext )"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- use xchatdccserver && epatch ${DISTDIR}/xchat-dccserver-0.4.patch
-}
-
-src_compile() {
-
- # xchat's configure script uses sys.path to find library path
- # instead of python-config (#25943)
- unset PYTHONPATH
-
- econf \
- $(use_enable ssl openssl) \
- $(use_enable perl) \
- $(use_enable python) \
- $(use_enable tcltk tcl) \
- $(use_enable mmx) \
- $(use_enable ipv6) \
- $(use_enable nls) \
- $(use_enable xchattext textfe) \
- $(use_enable !xchatnogtk gtkfe) \
- --program-suffix=-2 \
- || die "Configure failed"
-
- emake || die "Compile failed"
-
-}
-
-src_install() {
-
- # some magic to create a menu entry for xchat 2
- sed -i \
- -e "s:^Exec=xchat$:Exec=xchat-2:" \
- -e "s:Name=XChat IRC:Name=XChat 2 IRC:" \
- xchat.desktop
-
- make DESTDIR=${D} install || die "Install failed"
-
- # install plugin development header
- insinto /usr/include/xchat
- doins src/common/xchat-plugin.h
-
- dodoc ChangeLog README*
-
-}
-
-pkg_postinst() {
- einfo
- einfo "The default theme has been changed to be black on white."
- einfo "You can download the old theme files at:"
- einfo "\thttp://xchat.org/files/themes/blacktheme.zip"
- einfo "Place the files into your ~/.xchat2 directory."
- einfo
-}