summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-07-08 16:37:52 +0000
committerMarinus Schraal <foser@gentoo.org>2003-07-08 16:37:52 +0000
commit67c2456b63439b2296d7fe9f8ea310844d7a2720 (patch)
tree346e3c9a41ea5c1e52e0b244e809759972fc4abb /net-irc/xchat
parentadded dcc patch (diff)
downloadgentoo-2-67c2456b63439b2296d7fe9f8ea310844d7a2720.tar.gz
gentoo-2-67c2456b63439b2296d7fe9f8ea310844d7a2720.tar.bz2
gentoo-2-67c2456b63439b2296d7fe9f8ea310844d7a2720.zip
added dcc patch
Diffstat (limited to 'net-irc/xchat')
-rw-r--r--net-irc/xchat/ChangeLog7
-rw-r--r--net-irc/xchat/Manifest6
-rw-r--r--net-irc/xchat/files/digest-xchat-2.0.3-r1 (renamed from net-irc/xchat/files/digest-xchat-2.0.3)0
-rw-r--r--net-irc/xchat/files/xchat-2.0.3-fix_cps.patch11
-rw-r--r--net-irc/xchat/xchat-2.0.3-r1.ebuild (renamed from net-irc/xchat/xchat-2.0.3.ebuild)4
5 files changed, 22 insertions, 6 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index efc394eec70b..c7b180618f4b 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/xchat
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.55 2003/06/29 14:43:00 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.56 2003/07/08 16:37:41 foser Exp $
+
+*xchat-2.0.3-r1 (08 Jul 2003)
+
+ 08 Jul 2003; foser <foser@gentoo.org> xchat-2.0.3-r1.ebuild :
+ Added dcc patch, should fix possible dcc problems
*xchat-2.0.3 (29 Jun 2003)
diff --git a/net-irc/xchat/Manifest b/net-irc/xchat/Manifest
index 086df5768d43..bab7eb27d3b0 100644
--- a/net-irc/xchat/Manifest
+++ b/net-irc/xchat/Manifest
@@ -1,15 +1,13 @@
MD5 e533d379622f911ced2832e22263f31b xchat-2.0.1.ebuild 1982
-MD5 34616906669d508783738853a01d374b xchat-2.0.3.ebuild 2098
MD5 5e5d21a6b4e47c04f504c69b4272b029 xchat-1.8.11.ebuild 2285
MD5 d4b23b8ff3dd54a2ca5560884c64bf7f xchat-2.0.0.ebuild 1909
MD5 38c72021ed0c065d4973a36211d31e19 xchat-2.0.2-r2.ebuild 2130
MD5 d6896c2421454aab5a0cefef7bed9946 xchat-1.8.10-r1.ebuild 2307
-MD5 1bb0a95ca1779ea456ffc2003d55ce90 ChangeLog 8264
+MD5 07160b8293d7bad73df0a552952d8001 ChangeLog 8264
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
-MD5 1801dda38d9c2d4d60780a414d6b89e1 xchat-2.0.3-r1.ebuild 2164
+MD5 1e166dba032ec5bca0f47e13351f37ed xchat-2.0.3-r1.ebuild 2167
MD5 acbd4afdd7d00bceb3816147eb508e4b files/digest-xchat-2.0.0 64
MD5 1ee812a2b3e28e3866413e75a80ff983 files/digest-xchat-2.0.1 64
-MD5 f5c539e05a29071298f3d580fb1a3c72 files/digest-xchat-2.0.3 64
MD5 a8f607d224408d4a27777d2ffce8beac files/xc1811fixststint.diff 422
MD5 e470c6b909112da5b80be6880e56c8c3 files/xchat-2.0.3-fix_cps.patch 438
MD5 579cf7b7098f443691fcd6e3e41acba2 files/xc202-fixurlg.diff 510
diff --git a/net-irc/xchat/files/digest-xchat-2.0.3 b/net-irc/xchat/files/digest-xchat-2.0.3-r1
index 52de16838138..52de16838138 100644
--- a/net-irc/xchat/files/digest-xchat-2.0.3
+++ b/net-irc/xchat/files/digest-xchat-2.0.3-r1
diff --git a/net-irc/xchat/files/xchat-2.0.3-fix_cps.patch b/net-irc/xchat/files/xchat-2.0.3-fix_cps.patch
new file mode 100644
index 000000000000..fc1c8b98a1b2
--- /dev/null
+++ b/net-irc/xchat/files/xchat-2.0.3-fix_cps.patch
@@ -0,0 +1,11 @@
+--- xchat-2.0.3/src/common/dcc.c 2003-06-16 22:54:37.000000000 +1000
++++ xchat-2.0.3p1/src/common/dcc.c 2003-07-07 19:04:48.000000000 +1000
+@@ -129,7 +129,7 @@
+ if (dcc->type == TYPE_SEND)
+ {
+ /* carefull to avoid 32bit overflow */
+- pos = dcc->pos + ((dcc->pos - dcc->ack) / 2);
++ pos = dcc->pos - ((dcc->pos - dcc->ack) / 2);
+ glob_throttle_bit = 0x1;
+ cpssum = &dcc_sendcpssum;
+ glob_limit = prefs.dcc_global_max_send_cps;
diff --git a/net-irc/xchat/xchat-2.0.3.ebuild b/net-irc/xchat/xchat-2.0.3-r1.ebuild
index 46aeae109067..1ece09d2fd93 100644
--- a/net-irc/xchat/xchat-2.0.3.ebuild
+++ b/net-irc/xchat/xchat-2.0.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.0.3.ebuild,v 1.1 2003/06/29 14:43:00 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.0.3-r1.ebuild,v 1.1 2003/07/08 16:37:41 foser Exp $
inherit eutils
@@ -30,6 +30,8 @@ src_unpack() {
# fixes mmx problem
epatch ${FILESDIR}/${P}-fix_tint.patch
+ # fix dcc cps calculation
+ epatch ${FILESDIR}/${P}-fix_cps.patch
}