summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2006-02-19 19:59:55 +0000
committerSven Wegener <swegener@gentoo.org>2006-02-19 19:59:55 +0000
commit85ed31eccf7ca32b06e122d0859d56a8747fff1f (patch)
treeeafc1414d26bed226bf2a5636a550e33ff8db95c /net-irc/xchat-gnome
parentAdded ~mips to KEYWORDS. (diff)
downloadgentoo-2-85ed31eccf7ca32b06e122d0859d56a8747fff1f.tar.gz
gentoo-2-85ed31eccf7ca32b06e122d0859d56a8747fff1f.tar.bz2
gentoo-2-85ed31eccf7ca32b06e122d0859d56a8747fff1f.zip
Revision bump for optional libnotify and libsexy support.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'net-irc/xchat-gnome')
-rw-r--r--net-irc/xchat-gnome/ChangeLog9
-rw-r--r--net-irc/xchat-gnome/files/0.9-libnotify-api-changes.patch13
-rw-r--r--net-irc/xchat-gnome/files/0.9-libnotify-libsexy-configure.patch54
-rw-r--r--net-irc/xchat-gnome/files/digest-xchat-gnome-0.9-r13
-rw-r--r--net-irc/xchat-gnome/xchat-gnome-0.9-r1.ebuild81
5 files changed, 159 insertions, 1 deletions
diff --git a/net-irc/xchat-gnome/ChangeLog b/net-irc/xchat-gnome/ChangeLog
index 724b74f53fdb..a2557927470b 100644
--- a/net-irc/xchat-gnome/ChangeLog
+++ b/net-irc/xchat-gnome/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-irc/xchat-gnome
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-gnome/ChangeLog,v 1.13 2006/02/19 16:39:40 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-gnome/ChangeLog,v 1.14 2006/02/19 19:59:55 swegener Exp $
+
+*xchat-gnome-0.9-r1 (19 Feb 2006)
+
+ 19 Feb 2006; Sven Wegener <swegener@gentoo.org>
+ +files/0.9-libnotify-api-changes.patch,
+ +files/0.9-libnotify-libsexy-configure.patch, +xchat-gnome-0.9-r1.ebuild:
+ Revision bump for optional libnotify and libsexy support.
*xchat-gnome-0.9 (19 Feb 2006)
diff --git a/net-irc/xchat-gnome/files/0.9-libnotify-api-changes.patch b/net-irc/xchat-gnome/files/0.9-libnotify-api-changes.patch
new file mode 100644
index 000000000000..796d1135e5fe
--- /dev/null
+++ b/net-irc/xchat-gnome/files/0.9-libnotify-api-changes.patch
@@ -0,0 +1,13 @@
+Index: plugins/notify-osd/notify-osd.c
+===================================================================
+--- plugins/notify-osd/notify-osd.c (revision 10007)
++++ plugins/notify-osd/notify-osd.c (revision 10065)
+@@ -66,7 +66,7 @@
+
+ notify = notify_notification_new (summary, message, NULL, NULL);
+ notify_notification_set_urgency (notify, NOTIFY_URGENCY_NORMAL);
+- notify_notification_set_icon_data_from_pixbuf (notify, notify_icon);
++ notify_notification_set_icon_from_pixbuf (notify, notify_icon);
+ if (!notify_notification_show (notify, &error)) {
+ g_warning (_("Failed to send notification: %s\n"), error->message);
+ g_error_free (error);
diff --git a/net-irc/xchat-gnome/files/0.9-libnotify-libsexy-configure.patch b/net-irc/xchat-gnome/files/0.9-libnotify-libsexy-configure.patch
new file mode 100644
index 000000000000..ac9ba7c25067
--- /dev/null
+++ b/net-irc/xchat-gnome/files/0.9-libnotify-libsexy-configure.patch
@@ -0,0 +1,54 @@
+diff -Nur xchat-gnome-0.9.orig/configure.ac xchat-gnome-0.9/configure.ac
+--- xchat-gnome-0.9.orig/configure.ac 2006-01-19 22:54:01.000000000 +0000
++++ xchat-gnome-0.9/configure.ac 2006-02-19 17:57:55.394803381 +0000
+@@ -104,21 +104,42 @@
+
+ AM_CONDITIONAL([ENABLE_DBUS],[test "x$dbus" = "xyes"])
+
++AC_ARG_ENABLE([libsexy],
++ AS_HELP_STRING([--enable-libsexy],[Enable libsexy support]),
++ [enable_libsexy=$enableval libsexy=$enableval],
++ [enable_libsexy=no libsexy=no])
++
+ # libsexy soft dependency
+-PKG_CHECK_MODULES([LIBSEXY], [libsexy >= $LIBSEXY_REQUIRED], libsexy=yes, libsexy=no)
+-AC_SUBST([LIBSEXY_CFLAGS])
+-AC_SUBST([LIBSEXY_LIBS])
++if test "x$enable_libsexy" = "xyes"; then
++ PKG_CHECK_MODULES([LIBSEXY], [libsexy >= $LIBSEXY_REQUIRED], libsexy=yes, libsexy=no)
++ AC_SUBST([LIBSEXY_CFLAGS])
++ AC_SUBST([LIBSEXY_LIBS])
++fi
++
+ AM_CONDITIONAL([ENABLE_LIBSEXY],[test "x$libsexy" = "xyes"])
+-if test "x$libsexy" = xyes; then
+- AC_DEFINE(HAVE_LIBSEXY, 1, [Enable libsexy])
++
++if test "x$enable_libsexy" = "xyes" && test "x$libsexy" != "xyes"; then
++ AC_MSG_ERROR([libsexy not found])
+ fi
+
++AC_ARG_ENABLE([libnotify],
++ AS_HELP_STRING([--enable-libnotify],[Enable libnotify support]),
++ [enable_libnotify=$enableval libnotify=$enableval],
++ [enable_libnotify=no libnotify=no])
++
+ # libnotify soft dependency
+-PKG_CHECK_MODULES([LIBNOTIFY], [libnotify >= $LIBNOTIFY_REQUIRED], libnotify=yes, libnotify=no)
+-AC_SUBST([LIBNOTIFY_CFLAGS])
+-AC_SUBST([LIBNOTIFY_LIBS])
++if test "x$enable_libnotify" = "xyes"; then
++ PKG_CHECK_MODULES([LIBNOTIFY], [libnotify >= $LIBNOTIFY_REQUIRED], libnotify=yes, libnotify=no)
++ AC_SUBST([LIBNOTIFY_CFLAGS])
++ AC_SUBST([LIBNOTIFY_LIBS])
++fi
++
+ AM_CONDITIONAL([ENABLE_LIBNOTIFY],[test "x$libnotify" = "xyes"])
+
++if test "x$enable_libnotify" = "xyes" && test "x$libnotify" != "xyes"; then
++ AC_MSG_ERROR([libnotify not found])
++fi
++
+ # GConf
+ AM_GCONF_SOURCE_2
+ AC_PATH_PROG(GCONFTOOL, gconftool-2, no)
diff --git a/net-irc/xchat-gnome/files/digest-xchat-gnome-0.9-r1 b/net-irc/xchat-gnome/files/digest-xchat-gnome-0.9-r1
new file mode 100644
index 000000000000..ec0c340f04ab
--- /dev/null
+++ b/net-irc/xchat-gnome/files/digest-xchat-gnome-0.9-r1
@@ -0,0 +1,3 @@
+MD5 607d36afbadd35a163464b3f39c93526 xchat-gnome-0.9.tar.bz2 1187552
+RMD160 60fae4853ad9a6b0497897e6002a94e5b0bc05d8 xchat-gnome-0.9.tar.bz2 1187552
+SHA256 bc97fcfc8999b4f35c00688dbe1ae7255cd5900e9b9442d835d6cfc21279806e xchat-gnome-0.9.tar.bz2 1187552
diff --git a/net-irc/xchat-gnome/xchat-gnome-0.9-r1.ebuild b/net-irc/xchat-gnome/xchat-gnome-0.9-r1.ebuild
new file mode 100644
index 000000000000..db76e9edbf72
--- /dev/null
+++ b/net-irc/xchat-gnome/xchat-gnome-0.9-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-gnome/xchat-gnome-0.9-r1.ebuild,v 1.1 2006/02/19 19:59:55 swegener Exp $
+
+inherit gnome2 eutils autotools
+
+DESCRIPTION="GNOME frontend for the popular X-Chat IRC client"
+HOMEPAGE="http://xchat-gnome.navi.cx/"
+SRC_URI="http://releases.navi.cx/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="perl tcltk python ssl mmx ipv6 nls dbus libsexy libnotify"
+
+RDEPEND=">=dev-libs/glib-2.0.3
+ >=gnome-base/libgnome-2
+ >=gnome-base/gconf-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/libglade-2
+ >=gnome-base/gnome-vfs-2
+ >=x11-libs/gtk+-2.8
+ >=x11-libs/libsexy-0.1.4
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ perl? ( >=dev-lang/perl-5.6.1 )
+ python? ( dev-lang/python )
+ tcltk? ( dev-lang/tcl )
+ dbus? ( >=sys-apps/dbus-0.35 )
+ libsexy? ( x11-libs/libsexy )
+ libnotify? ( x11-libs/libnotify )"
+
+DEPEND="${RDEPEND}
+ gnome-base/gnome-common
+ >=dev-util/pkgconfig-0.7
+ nls? ( sys-devel/gettext )"
+
+# gnome-base/gnome-common is temporarily needed for re-creating configure
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/xchat-gnome-0.7-scrollkeeper.patch
+ epatch ${FILESDIR}/0.9-libnotify-libsexy-configure.patch
+ epatch ${FILESDIR}/0.9-libnotify-api-changes.patch
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ econf \
+ --enable-gnomefe \
+ --enable-shm \
+ $(use_enable ssl openssl) \
+ $(use_enable perl) \
+ $(use_enable python) \
+ $(use_enable tcltk tcl) \
+ $(use_enable mmx) \
+ $(use_enable ipv6) \
+ $(use_enable dbus) \
+ $(use_enable nls) \
+ $(use_enable libsexy) \
+ $(use_enable libnotify) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ addpredict /var/lib/scrollkeeper/scrollkeeper_docs
+
+ USE_DESTDIR="1" gnome2_src_install || die "gnome2_src_install failed"
+
+ # install plugin development header
+ insinto /usr/include/xchat-gnome
+ doins src/common/xchat-plugin.h || die "doins failed"
+
+ dodoc AUTHORS ChangeLog NEWS || die "dodoc failed"
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+}