summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-10-05 06:17:55 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-10-05 06:17:55 +0000
commit5907cc721b73890ac746662171fdf533c93bcaf7 (patch)
treec25cc369be6e7c26cb3802e85d48f3a525581c21 /net-irc/weechat
parentBump (diff)
downloadgentoo-2-5907cc721b73890ac746662171fdf533c93bcaf7.tar.gz
gentoo-2-5907cc721b73890ac746662171fdf533c93bcaf7.tar.bz2
gentoo-2-5907cc721b73890ac746662171fdf533c93bcaf7.zip
Version bump to latest.
(Portage version: 2.2.0_alpha135/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/weechat')
-rw-r--r--net-irc/weechat/ChangeLog7
-rw-r--r--net-irc/weechat/weechat-0.3.9.ebuild120
2 files changed, 126 insertions, 1 deletions
diff --git a/net-irc/weechat/ChangeLog b/net-irc/weechat/ChangeLog
index dbc5e247e28c..8bdceaa1a22c 100644
--- a/net-irc/weechat/ChangeLog
+++ b/net-irc/weechat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/weechat
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/ChangeLog,v 1.114 2012/08/21 13:28:37 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/ChangeLog,v 1.115 2012/10/05 06:17:55 scarabeus Exp $
+
+*weechat-0.3.9 (05 Oct 2012)
+
+ 05 Oct 2012; Tomáš Chvátal <scarabeus@gentoo.org> +weechat-0.3.9.ebuild:
+ Version bump to latest.
21 Aug 2012; Tomáš Chvátal <scarabeus@gentoo.org> -weechat-0.3.7.ebuild,
weechat-0.3.8.ebuild, weechat-9999.ebuild:
diff --git a/net-irc/weechat/weechat-0.3.9.ebuild b/net-irc/weechat/weechat-0.3.9.ebuild
new file mode 100644
index 000000000000..e382fdfec9bb
--- /dev/null
+++ b/net-irc/weechat/weechat-0.3.9.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/weechat/weechat-0.3.9.ebuild,v 1.1 2012/10/05 06:17:55 scarabeus Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="python? 2" # it can use only ONE python, so stick with two for now
+
+EGIT_REPO_URI="git://git.sv.gnu.org/weechat.git"
+[[ ${PV} == "9999" ]] && GIT_ECLASS="git-2"
+inherit python multilib cmake-utils ${GIT_ECLASS}
+
+DESCRIPTION="Portable and multi-interface IRC client."
+HOMEPAGE="http://weechat.org/"
+[[ ${PV} == "9999" ]] || SRC_URI="http://${PN}.org/files/src/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+if [[ ${PV} == "9999" ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~x86-linux ~amd64-linux"
+fi
+
+NETWORKS="+irc"
+PLUGINS="+alias +charset +fifo +logger +relay +rmodifier +scripts +spell +xfer"
+#INTERFACES="+ncurses gtk"
+SCRIPT_LANGS="guile lua +perl +python ruby tcl"
+IUSE="${SCRIPT_LANGS} ${PLUGINS} ${INTERFACES} ${NETWORKS} +crypt doc nls +ssl"
+
+RDEPEND="
+ net-misc/curl[ssl]
+ sys-libs/ncurses
+ charset? ( virtual/libiconv )
+ guile? ( dev-scheme/guile )
+ lua? ( dev-lang/lua[deprecated] )
+ perl? ( dev-lang/perl )
+ ruby? ( >=dev-lang/ruby-1.9 )
+ ssl? ( net-libs/gnutls )
+ spell? ( app-text/aspell )
+ tcl? ( >=dev-lang/tcl-8.4.15 )
+"
+# ncurses? ( sys-libs/ncurses )
+# gtk? ( x11-libs/gtk+:2 )
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.15 )
+"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+#REQUIRED_USE=" || ( ncurses gtk )"
+
+LANGS=( cs de es fr hu it ja pl pt_BR ru )
+for X in "${LANGS[@]}" ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ local i
+
+ # fix libdir placement
+ sed -i \
+ -e "s:lib/:$(get_libdir)/:g" \
+ -e "s:lib\":$(get_libdir)\":g" \
+ CMakeLists.txt || die "sed failed"
+
+ # install only required translations
+ for i in "${LANGS[@]}" ; do
+ if ! use linguas_${i} ; then
+ sed -i \
+ -e "/${i}.po/d" \
+ po/CMakeLists.txt || die
+ fi
+ done
+}
+
+# alias, rmodifier, xfer
+src_configure() {
+ # $(cmake-utils_use_enable gtk)
+ # $(cmake-utils_use_enable ncurses)
+ local mycmakeargs=(
+ "-DENABLE_NCURSES=ON"
+ "-DENABLE_LARGEFILE=ON"
+ "-DENABLE_DEMO=OFF"
+ "-DENABLE_GTK=OFF"
+ $(cmake-utils_use_enable nls)
+ $(cmake-utils_use_enable crypt GCRYPT)
+ $(cmake-utils_use_enable spell ASPELL)
+ $(cmake-utils_use_enable charset)
+ $(cmake-utils_use_enable fifo)
+ $(cmake-utils_use_enable irc)
+ $(cmake-utils_use_enable logger)
+ $(cmake-utils_use_enable relay)
+ $(cmake-utils_use_enable scripts)
+ $(cmake-utils_use_enable perl)
+ $(cmake-utils_use_enable python)
+ $(cmake-utils_use_enable ruby)
+ $(cmake-utils_use_enable lua)
+ $(cmake-utils_use_enable tcl)
+ $(cmake-utils_use_enable guile)
+ $(cmake-utils_use_enable doc)
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ if use scripts && use python; then
+ elog "You may use the following script from upstream to manage your scripts."
+ elog "It helps with downloading and updating other scripts:"
+ elog " http://www.weechat.org/scripts/source/stable/weeget.py/"
+ fi
+}