summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2004-08-15 15:57:50 +0000
committerSven Wegener <swegener@gentoo.org>2004-08-15 15:57:50 +0000
commitb4a901c66875c12bab04c9b6f7a3451a84f0ad8e (patch)
tree0c38919285f8f487f74ea6ea98bf2724a8533d93 /net-irc/unrealircd
parentMoved from net-www/wordpress to www-apps/wordpress (diff)
downloadgentoo-2-b4a901c66875c12bab04c9b6f7a3451a84f0ad8e.tar.gz
gentoo-2-b4a901c66875c12bab04c9b6f7a3451a84f0ad8e.tar.bz2
gentoo-2-b4a901c66875c12bab04c9b6f7a3451a84f0ad8e.zip
Updated init script with reload support.
Diffstat (limited to 'net-irc/unrealircd')
-rw-r--r--net-irc/unrealircd/ChangeLog6
-rw-r--r--net-irc/unrealircd/files/digest-unrealircd-3.2.11
-rw-r--r--net-irc/unrealircd/files/unrealircd.rc11
-rw-r--r--net-irc/unrealircd/unrealircd-3.2.1-r1.ebuild15
-rw-r--r--net-irc/unrealircd/unrealircd-3.2.1.ebuild114
5 files changed, 24 insertions, 123 deletions
diff --git a/net-irc/unrealircd/ChangeLog b/net-irc/unrealircd/ChangeLog
index 5ce337b78eda..da0dfb8b5637 100644
--- a/net-irc/unrealircd/ChangeLog
+++ b/net-irc/unrealircd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/unrealircd
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/ChangeLog,v 1.21 2004/08/14 20:43:09 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/ChangeLog,v 1.22 2004/08/15 15:57:50 swegener Exp $
+
+ 15 Aug 2004; Sven Wegener <swegener@gentoo.org> files/unrealircd.rc,
+ unrealircd-3.2.1-r1.ebuild, -unrealircd-3.2.1.ebuild:
+ Updated init script with reload support.
14 Aug 2004; Sven Wegener <swegener@gentoo.org> unrealircd-3.2.1-r1.ebuild:
Modified the ebuild to install configuration files for aliases and networks
diff --git a/net-irc/unrealircd/files/digest-unrealircd-3.2.1 b/net-irc/unrealircd/files/digest-unrealircd-3.2.1
deleted file mode 100644
index 97de2ae29e96..000000000000
--- a/net-irc/unrealircd/files/digest-unrealircd-3.2.1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 ebe56fd42fc229681f527932eaa173cc Unreal3.2.1.tar.gz 1614434
diff --git a/net-irc/unrealircd/files/unrealircd.rc b/net-irc/unrealircd/files/unrealircd.rc
index 08b3c6abaefd..4d1a553d7b06 100644
--- a/net-irc/unrealircd/files/unrealircd.rc
+++ b/net-irc/unrealircd/files/unrealircd.rc
@@ -1,11 +1,14 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/files/unrealircd.rc,v 1.5 2004/07/24 20:24:31 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/files/unrealircd.rc,v 1.6 2004/08/15 15:57:50 swegener Exp $
+
+opts="reload start stop"
depend() {
need net
use dns
+ provide ircd
}
start() {
@@ -20,3 +23,9 @@ stop() {
killall unrealircd
eend $?
}
+
+reload() {
+ ebegin "Re-Loading unrealircd"
+ killall -1 unrealircd
+ eend $?
+}
diff --git a/net-irc/unrealircd/unrealircd-3.2.1-r1.ebuild b/net-irc/unrealircd/unrealircd-3.2.1-r1.ebuild
index dae9829de403..ed580550d0da 100644
--- a/net-irc/unrealircd/unrealircd-3.2.1-r1.ebuild
+++ b/net-irc/unrealircd/unrealircd-3.2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/unrealircd-3.2.1-r1.ebuild,v 1.3 2004/08/14 20:43:09 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/unrealircd-3.2.1-r1.ebuild,v 1.4 2004/08/15 15:57:50 swegener Exp $
inherit eutils ssl-cert
@@ -36,6 +36,12 @@ src_unpack() {
}
src_compile() {
+ local myconf=""
+ use hub && myconf="${myconf} --enable-hub"
+ use ipv6 && myconf="${myconf} --enable-inet6"
+ use zlib && myconf="${myconf} --enable-ziplinks"
+ use ssl && myconf="${myconf} --enable-ssl"
+
econf \
--with-listen=5 \
--with-dpath=${D}/etc/unrealircd \
@@ -48,10 +54,7 @@ src_compile() {
--with-fd-setsize=1024 \
--enable-dynamic-linking \
--enable-prefixaq \
- $(use_enable zlib ziplinks) \
- $(use_enable ssl) \
- $(use_enable hub) \
- $(use_enable ipv6 inet6) \
+ ${myconf} \
|| die "econf failed"
sed -i \
@@ -74,7 +77,7 @@ src_install() {
dosym /var/lib/unrealircd /etc/unrealircd/tmp
insinto /etc/unrealircd
- doins badwords.*.conf help.conf spamfilter.conf
+ doins badwords.*.conf help.conf spamfilter.conf dccallow.conf
newins doc/example.conf unrealircd.conf
use ssl \
diff --git a/net-irc/unrealircd/unrealircd-3.2.1.ebuild b/net-irc/unrealircd/unrealircd-3.2.1.ebuild
deleted file mode 100644
index 9eca6dc8678c..000000000000
--- a/net-irc/unrealircd/unrealircd-3.2.1.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/unrealircd-3.2.1.ebuild,v 1.4 2004/07/25 02:45:33 swegener Exp $
-
-inherit eutils ssl-cert
-
-MY_P=Unreal${PV}
-
-DESCRIPTION="aimed to be an advanced (not easy) IRCd"
-HOMEPAGE="http://www.unrealircd.com/"
-SRC_URI="http://www.gower.net/unrealircd/${MY_P}.tar.gz
- ftp://unreal.secure-tech.net/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc"
-IUSE="ssl zlib"
-
-RDEPEND="ssl? ( dev-libs/openssl )
- zlib? ( sys-libs/zlib )"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
-
-S=${WORKDIR}/Unreal3.2
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- sed -i \
- -e "s:ircd\.pid:/var/run/unrealircd/ircd.pid:" \
- -e "s:ircd\.log:/var/log/unrealircd/ircd.log:" \
- -e "s:debug\.log:/var/log/unrealircd/debug.log:" \
- -e "s:ircd\.tune:/var/lib/unrealircd/ircd.tune:" \
- include/config.h
-}
-
-src_compile() {
- econf \
- --enable-hub \
- --with-listen=5 \
- --with-dpath=${D}/etc/unrealircd \
- --with-spath=/usr/bin/unrealircd \
- --with-nick-history=2000 \
- --with-sendq=3000000 \
- --with-bufferpool=18 \
- --with-hostname=${HOSTNAME} \
- --with-permissions=0600 \
- --with-fd-setsize=1024 \
- --enable-dynamic-linking \
- `use_enable zlib ziplinks` \
- `use_enable ssl` \
- || die "econf failed"
-
- sed -i \
- -e "s:${D}::" \
- include/setup.h \
- ircdcron/ircdchk
-
- emake IRCDDIR=/etc/unrealircd || die "emake failed"
-}
-
-src_install() {
- keepdir /var/{lib,log,run}/unrealircd
-
- newbin src/ircd unrealircd
-
- exeinto /usr/lib/unrealircd/modules
- doexe src/modules/*.so
-
- dodir /etc/unrealircd
- dosym /var/lib/unrealircd /etc/unrealircd/tmp
-
- insinto /etc/unrealircd
- doins badwords.*.conf help.conf spamfilter.conf
- newins doc/example.conf unrealircd.conf
-
- use ssl \
- && docert server.cert \
- && dosym server.cert.key /etc/unrealircd/server.key.pem
-
- sed -i \
- -e s:src/modules:/usr/lib/unrealircd/modules: \
- -e s:ircd\\.log:/var/log/unrealircd/ircd.log: \
- ${D}/etc/unrealircd/unrealircd.conf
-
- dodoc Changes Donation Unreal.nfo ircdcron/{ircd.cron,ircdchk}
- dohtml doc/*.html
-
- exeinto /etc/init.d
- newexe ${FILESDIR}/unrealircd.rc unrealircd
- insinto /etc/conf.d
- newins ${FILESDIR}/unrealircd.confd unrealircd
-
- fperms 700 /etc/unrealircd
-}
-
-pkg_postinst() {
- enewuser unrealircd
- chown unrealircd \
- ${ROOT}/{etc,var/{lib,log,run}}/unrealircd \
- ${ROOT}/etc/unrealircd/server.cert.{key,pem} \
- ${ROOT}/etc/unrealircd/*.conf
-
- einfo
- einfo "UnrealIRCd will not run until you've set up /etc/unrealircd/unrealircd.conf"
- einfo
- einfo "You can find example cron scripts here:"
- einfo " /usr/share/doc/${PF}/ircd.cron.gz"
- einfo " /usr/share/doc/${PF}/ircdchk.gz"
- einfo
- einfo "You can also use /etc/init.d/unrealircd to start at boot"
- einfo
-}